Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Cannot Add Second Nest Thermostat to App

Community Member

I have 3 Nest learning thermostats for my home (I have three separate units). I have added one, and it connected to WiFi just fine, and connected to the app - it's all setup and working. The second thermostat will connect to WiFi just fine, but I cannot get it to connect to the App. It gives me the m15 error. I have reset the thermostat 4 times, tried different WiFi networks, removed security, etc, to no avail. I just cannot get this second thermostat to connect to the app. I'm waiting to get this fixed before I connect my third, or I'll just have to find another brand.

If any of you have any recommendations, please let me know!



Community Member

Any luck? I’m having the exact same issue and it is SO FRUSTRATING!

Super stupid but I just created different "houses" for each thermo and got it work

Community Member

I’m having the same issue.  It is frustrating.  

Community Member

Still nothing...I'm at a loss.

Community Member

Really dumb, but I got all three of my thermo's to work by creating a new "house" for each one named a room.  Would be nice if we could connect manually and go the room option.  

Community Member

I figured out why my second thermostat wouldn’t work.  It was the Wi-Fi connection.  I got the thermostat to work with no Wi-Fi and not connected to my nest network ( no Wi-Fi so can’t do this regardless).  I then reset the Wi-Fi network on the thermostat.  It reset and then I left it searching for for my houses Wi-Fi.  Nothing showed up but then I spun the dial up and down a few times and then all of a sudden the nearby Wi-Fi networks appeared and I saw mine.  I picked it and then it connected.   Then I checked for a software update right on the thermostat and there was one.  I updated it.  Then I open then nest app on my cell and added to my account, using the QR code, thus adding it to my nest network.  That did it for me.  It’s been working all day fine.  I hope this helps others.  

Community Member

This is unnecessarily aggravating due to poor product development and no support.  It is NOT possible to connect a properly wifi-connected thermostat to the app, without resetting it and then searching for the entry key or QR image - or both.  This reset leaves the sensors "associated with a prior account."  In other words, unless your thermostat is already in the app, you can not manage it, delete the sensors, etc.   To add it, the "support" presumes that the entry or QR codes (to add to the app) are available on the display.  Pain every step of the way.  There is no way for the phone app to find a thermostat even when both are configured to the same wifi network.  There is no way to reset the sensors, OR, even re-connect them to the same thermostat even with NO change in wifi network.  Scanning the QR from back of the display .. app still asks for the entry key...  then, asks for "symbols on the display."  Forced to try again, what eventually worked was scanning the QR image from display after full reset.  But now the sensors are "associated with another account" even though they were accessible prior to reset.

Community Member

This helped tremendously. (I hadn’t connected remote sensors, so can’t speak to that issue). But it was very difficult to get a second Nest Learning Thermostat connected. 

As noted here, the difficulty seems to stem from:

1. Setting it up fully via Wi-Fi as a standalone system. Rather, connecting to your app should be the first thing you do. Only connect to Wi-Fi when the “add to app” workflow require it. 

2. My first nest thermostat; connected an hour earlier, worked fine through a range extender. The second one? Not so much. Definitely remove range extenders (mine was not an Orbi brand, but removing it from the network was part of the fix).


3. connect to same network/SSID.


4. If you’ve messed up the order, take heart. It is solvable to connect a second nest thermostat. The secret sauce in my case was to use the “reset TYY CONNECTIONS” option in the rest menu. Using the “reset all” function didn’t seem to do the trick. So, for good measure, cycle through all reset options and reset EVERYTHING. 

5. I can’t find this option in my reset menu now. Hmm. This second Nest required a software update immediately, and was 10 months out of date. Possibly update software before troubleshooting (great policy always).

Community Member

I had the same problem but discovered it was because of my router extenders (Orbi).  When I shut the Orbi Satellite down, the Nest Thermostat was forced to jump to the same wifi device and it worked as described in the user's guide.

Community Member

I have an Orbi system as well and tried your solution….worked like a charm. So simple of a fix after a couple of days of frustration. Would recommend trying the same to any others of you who have a mesh/satellite wifi system.

Community Member

THIS! 100% solved my problem. Had no idea the Orbi satellite was conflicting with communicating with the 1st nest. Unplug your satellites and try to do the QR code method. 

Community Member

Same here. Thank you @kempton26  I changes my phone and two thermostats from Orbi to AT&T connections and it works flawlessly. 

Community Member

Thank you, thank you, thank! 

This worked for me as well. Turned off my orbi satelites and it connected

Community Member

I had same problem.  Could not add a second device to the app.  It was giving me a TD030 error code.  Apparently the nest app was first trying to find my first thermostat and couldn’t connect the two because the two nest devices were too far apart.  Try adding a second and third “home” to the nest app.  Almost like you have different geographic locations within the app.  Click the + sign in upper right corner and add the device to the second and third location.  Worked like a charm for us. 

Community Member

I had to do the same thing. It is not ideal, but it is a good workaround. 

Community Member

Having worked with Nest Thermostats for awhile as an HVAC Technician I have discovered a (aggravating) work around connecting multiple thermostats to one home. I discovered this while adding 5 Nest thermostats to a huge home in Raleigh NC. If you can add one to the app but not another, simply remove the first one from the app and then add the second one first. Then add the first one back. Had to do this several times with other technicians out in the field and haven't had any issues adding multiple Nests since discovering this work around. Hope this Helps

This worked for me also. Just got done with it, had to do a factory reset on the original unit(first one) once i Got the second unit to connect. Removed the original unit that connected successfully. Added the second unit that wouldn't connect. It's now connected properly. Added the original unit installed it wouldn't connect initially but indicated to do a factory reset of the this unit. Once I did that, the unit successfully connect now both working on the same network. Thaks you for the tip.

This solution works, thank you so much! I just bought a house and wasted three hours trying to reset all the Nest Thermostats (connected to previous owner's app). First thermostat was easy, the 2nd and 3rd just wouldn't add to the app. I tried every other solution out there (reset WWN setting, use personal hotspot), nothing worked. Until I saw this post. After deleting the first one, the 2nd and 3rd just added properly. 

Shame on Nest team who can't even provide any good help besides "reset your WiFi router". 

This solution worked for me as well! Thanks, HVAC Trainer, and everyone else who weighed in with this solution that worked, unlike the so-called “help” from Google. 

Thanks for this. Don’t know how or why, but this works. 

Just wanted to confirm this worked for me.   I do also have an Orbi, but just removed the first and it worked like a charm allowing me to add the second.  Having to re-add the sensors was a pain. It it just took a little time to re-add them manually.  

I registered here just to say thank you for this. This issue was driving me insane, and this worked like a charm. Take care, and be well!

Here’s what worked for me:

I have a mesh wifi and 3 Nest Learning Thermostats (adding #2 and #3 were problematic).

I installed #2. Removed it from the wall and brought it next to #1 (I have about 5 minutes before the it’s battery starts dieing). I kept #2 about 3” from #1 and started the install with the App. This worked  to add #2 to my “Home” and then I quickly returned #2 back to its room.

I used the same process for #3 BUT I had to restart my wifi to add it to my “Home”… not sure if I was lucky with #2 by not restarting my wifi…

Good luck to all! I found this Post after pulling out my hair for about 2 hours of trying to get #2 added

Community Member

Following an earlier suggestion I updated the Nest software to 6.2-22 and was able to connect multiple thermostats in the Nest App after doing that.

Community Member

What you described is my exact problem, too.   As a work around, I had to create another home, called it the zone I was trying to use.  Then under that home I added the second Gen 3 Nest thermostat without any issues at all.  No matter what I did, it would not recognize the second thermostat  under the primary home with the first Nest thermostat.   This is all strange since google shows a diagram of a multi system house using two Nest thermostats.

Community Specialist
Community Specialist

Hey folks,


I'm just checking up on this thread, I apologize about the late response. I'm glad to see a work-around was found for this problem! Was there anyone who was still experiencing this issue? If so, please let me know.


Best regards,


I for one am still having issues adding a second nest thermostat to my house. I have two (upstairs and downstairs) and am having the same issues outlined above. I have followed the instructions to the workaround to no avail. Like previously mentioned, I can add the second thermostat to a second ‘home’ without issue, however this isn’t a proper workaround since the two thermostats don’t interact with each other in this configuration. 

I believe this issue is likely stemming from having wireless internet broadcasting from ‘mesh’ networks since several others referenced this issue occurring in tandem with router extenders and Orbi routers. I personally have 4 routers (Eeros) and so while the nest is connecting to the same network, it is likely communicating with a different individual router from the first thermostat. All that said, given the increasing popularity for these mesh networks, I can’t believe Google doesn’t have something in place to mitigate this extremely frustrating issue. 

can anyone outline the workaround with a ‘step-by-step’ explanation (referring to the workaround where you remove the original nest, then add the second, and re-add the first.) this just hasn’t worked for me so far and I must be missing something.


Thanks very much to all.

Same issue here. I have 5 in our new home. Only one on my app. I’ve tried everting. Such an easy fix if the devs could be bothered! 

Yes, I cannot get the 2nd thermostat to be added. I followed the above suggestions and have removed #1 from the app, added the 2nd to the network and the app, factory reset the 1st and now it won’t add back to the app. Tried multiple times. Could someone please provide step by step instructions? Thanks!

Yes, have tried all suggestions and still cannot get the 2nd nest added to the app

Same, no matter what I try nothing works.  easily get one on the app but when it tries to "connect to the assisting Nest product" (the thermostat that is connected properly) it fails.  I wish there was a work around to not rely on the other product to connect to.


See my post above. I talked about how I couldn't get the 'remove one, add the second, add the original' method to work. I brought up the mesh network issues and how ridiculous it is that google hasn't addressed this issue.


It's been mentioned a few times on this thread, but the solution is to add both nests using your phone as a wifi hotspot. THIS IS IT.


You reset everything, add one, and then the other using your phone's wifi hotspot. After that, you can go in and reconnect each nest to your home's wifi network.


Even this did not work for me....and I was on the phone with Google trying it.  When I finally got disconnected from them, while they were in the middle of escalating it, after more than an hour on the phone, the only thing that worked for me was using the Nest app on my iPad (not my phone) to connect to my hotspot. 


But of course now, both are showing up, but they keep losing connection to my home wifi....always something

Thanks for providing this detail. Unfortunately this did not work for me. Tried both with my phone and my wife's.

Community Member

I just added a nest in a 3rd house and it says I have too many houses. Unfortunately one house is set up as two houses due to the inability to connect the second thermostat. How to I add my 3rd house which shows as a 4th house on Nest?

Community Member

I am experiencing this problem in my house with a nest upstairs and downstairs.  one adds seamlessly and the other one is not recognized, despite being on the same network.


Community Member

I am having this same issue with the Nest thermostat and doorbell. I have one thermostat set up under a primary home and then had to set up a second home in the nest app as a workaround. Unfortunately I can’t do that with the doorbell. When I try to install the doorbell it pushes me to the Google Home app to begin setup there. In the Google Home app, I can only get one thermostat to work and now the doorbell is in there. Switching between the Nest and Home apps to control all three products is ridiculous - plus the Home app has limited functionality compared to the Nest app. Please help!

Community Member

I had two Nest on my house and app at one time until something happened on the combination of Nest app and Google home app.  One day all hell broke lose on many of my Google devices including the two nest thermostats.  Now the account won't allow the second nest to be setup.