Showing results for 
Search instead for 
Did you mean: 

Google Nest Smart Thermostat - Stainless Steel - 3rd Generation, stopped working

Community Member


We have a Google Nest Smart Thermostat - Stainless Steel - 3rd Generation. Having worked fine since install around Dec 2019, this afternoon it's started showing a H72 error - 'The power to this thermostat is off'

We have tried all the debugging steps - making sure it's properly seated, fuse box etc. to no avail. The manual override button doesn't work either. 

We have a combi boiler and have checked all okay with it - boiler is on, no error codes and we can get hot water from it by running a hot tap. Looks like the nest thermostat itself is at fault - please can this be resolved quickly as we have no central heating until it is.

Thanks for your help


Community Specialist
Community Specialist

Hi there. Thanks for reaching out. I'll do my best to find a resolution for you. You checked the fusebox/switches and turned them off and on, correct? Do you have any lights on the Heat Link when you press the button? 

Hi Cristian,

Thanks for getting back to me. I started a case with nest customer support and they confirmed the heatlink was broken. They were also able to arrange for the unit replaced for free, which is much appreciated. It's all working again now.


Community Specialist
Community Specialist

Hey @jmorris1,


I'm glad to hear everything's back up and running. Let me know if there's anything else you need assistance with.

Community Specialist
Community Specialist


Hey there, I haven't heard from you in a while so I'll be locking this thread since seem to be back on track. If you have any new issues, updates or just a discussion topic, feel free to start a new thread in the community.


Thanks, AlexD.