cancel
Showing results for 
Search instead for 
Did you mean: 

Home/Away Assist Problems

junalmeida
Community Member

The home/away assist is not working as expected. It often thinks I'm away when I am home, and turns it to Eco mode. Today I am not home, and it thinks it is, heating the house for no one. 

Everything seems to be set correctly, and yet the support team suggestion is to "buy another phone". 

 

165 REPLIES 165

JohnV
Community Member

I am having the same issue. It is a pretty crappy app that only works some of the time. This is absolutely the worst performing application I have ever used. I have also double checked all settings, reinstalled app, logged out / logged in and no change in behavior. I leave the house and get far enough away that it should go into away mode. Sometimes when I look at the app, it is fine and in away mode, other times when I open the app, THEN it decides to go into away mode. I have location settings set to always on my iPhone. Yesterday, I left and went for a walk at least 1/2 mile away from home and it never went into away mode.

This is really frustrating as I have to remember to check the app when I am gone to make sure it actually went into away mode. What good is having a "location aware" app if it only works 'some of the time"???

And no, I do not need another phone, I have other "location aware" apps that are working just fine and very reliably.

 

 

junalmeida
Community Member

It is interesting to see that you use an iPhone, and I use an Android, so it could really be a widespread issue. Unfortunately support guys refuse to see they have a problem, and leave their customers frustrated. If only I could do the same for my customers, I would earn money easy, right? 

 

 

JohnV
Community Member

Totally agree. I develop software to do systems integration for a number of clients - not that hard to monitor to see what is going on and provide a fix... 🙂 

I have had this problem for years. I had the problem with my Samsung & now I have an IPhone I still have the same problem. There are 2 of us using this feature - it works for him but for me it always says that it hasn’t heard from my phone & I need to change my location settings. They’re set to always allow, like they always have done. Does anyone have any kind of solution? 

There doesn’t seem to be a solution that consistently works for everyone. 

What I’ve been encouraging people to  do is to reach out to Google Support on Social media particularly on Twitter and Facebook as this seems to get their attention and complain that way. 

it hasn’t generated a solution from Google yet and I’m not holding my breath but I’m hoping at some point that if enough customers complain they will either fix the problem or admit there is no solution and we can then decide to live with the problem or move to another company’s product 

 

nestripoff
Community Member

i have the same issue. I have tried EVERYTHING to resolve this without success. iPhone. It is total garbage. it just does not work and the help line is useless, just telling you to constantly repeat all the checks I've done a hundred times already. . Sadly this is the main reason for buying a 'smart stat'. Lesson learned :- avoid any nest product or anything associated with google in future!

  • Reply to me so far from good ogle Nest 
  • Hi there, we've checked on the case, it seems it's still assigned to our engineering department trying to find a fix for it. Once we got word from them, we'll let you know.

Please let me know too as I have the same problem 

 

I am now using SmartThings app and nest app using the settings from the other thread 

working fine for now 

puts it into eco and switch back to heating when I enter the geofence that you can set in SmartThings 

happy for now but Google you should fix your app 

LizHC
Community Member

The problem. has existed for at least four years…

JohnV
Community Member

So, I have news - for some unknown reason, the app has been working perfectly for the last 6 weeks. Of course now that I post this is will probably stop working 😞 

It is recognizing when I leave and going into ECO mode like it should and then comes out of ECO mode when I return.

No update to the app during this time (although there is one last week for IOS) and no changes to the stats firmware. It started working before the last iPhone update as well...

Oh well, must be some fluke - we'll see how it goes...

vlynn599
Community Member

Google please don't take over anything else that I own!!!!

LifeonMars
Bronze
Bronze

Having a similar problem recently in the UK. iPhone Home/away not always switching when away. I have reset everything and some days when i am out, I check the settings and find that no events are shown and the Thermostat has not switched to away., even though I have been a long way a way from home.  This is only happening recently, prior I had no problems with the same phone.

I'm having same issue with iPhone8. Come home and I have to sign out and in  again to my account to get it working. Am I supposed to walk past the thermostat to get it to come on?

KazzieB10 are you also in the UK ?    I think the problem is in the Nest App  as as I said It has only started recently,  The Thermostat should also recognise that there is no one at Home and should switch to away if you have set that up under Home/Away settings  as well as the iPhone .   I have found that signing in and out every so often does seem make it work but only for a short time. Some thing is not quite right with Nest/Google  app either, with the app not finding location of my iPhone when I am away and the Thermostat not realising no one is home. All has been reset but problem exists intermittently. 

JohnV
Community Member

Okay - I found a potential work around. I now keep the Nest iPhone app open in the background. I had been 'swiping up' to close it before. Even closing it though worked fine until recently.

So, something is definitely changed to where, apparently, you may need to keep the app open and 'minimized'.

I thought that it might use up the battery having it open in the background, but after doing it this way for > 24 hours, battery usage is only 1%

So far it has worked consistently, going into away mode when I am gone and going back to home mode when I return.

Your mileage may vary.... 😎

nestripoff
Community Member

nope. didn't work for me sadly.

Palmer_AK
Community Member

This’ doesn’t work for me

miltex145
Community Member

https://support.google.com/googlenest/answer/9261396
Under either the "Nest thermostats" or "Nest cameras and Nest doorbells" sections.
For me, the "Your camera didn’t switch on or off as expected" topic under the "Nest cameras and Nest doorbells" section fixed my problem. As I suspected, the "Google Home" and "Nest" apps on the iPhone are fighting each other and causing Home/Away Assist not to work properly. What resolved the problem for me was following the instructions under bullet point #3 which was to setup the "Routines" function within the Google Home app which sets it as running the Home/Away assist function with my iPhone from now on which automatically shuts it off within the Nest app. Now the 2 apps don't fight each other anymore and the cameras properly turn themselves on when I leave and off when I return home. Interestingly enough, I'm finding that it works best if I do the same with my wife's iPhone except set the Nest app to run her Home/Away assist which then automatically disables it within the "Routines" function in the Google Home app. I found that if both of our iPhones are setup to have the Google Home app control the Home/Away Assist function, the cameras will turn themselves on when she leaves the house and I'm still home as well as vice-versa. It would have been nice if Google hadn't ruined a good thing and just left the Nest app alone in the first place instead of making the Google Home app have to be running in tandem with the Nest app on our devices in order for the system to work.

SueWilk
Community Member

Set the Nest thermostat to "Away" when we went on holiday. On our return we find that this didn't work and the heating has been working at max capacity while we were away. We dont have any other Google products that could have interfered with the settings.

  The problem seems to be with Google Home and Nest app Not working together. I have noticed that when manually set to away using the phone the thermostat setting still shows  as on on the apps. . Also when deleting apps and reinstalling the Google Home app wants to change my Home/away assist using phone to a different phone even though I only have the one phone.  I have deleted both the Neat app and Google Home, reset the Thermostat and Link to factory settings and Re set up the nest app using iPhone  and  Google Home.  I think the problem is with Home/away and phone location with Google Home.  Your thermostat should have sensed that no one was home but obviously some thing was telling it it was at home.  Wish Google would sort it. Worked fine before they bought nest and integrated having to use Google Home as well

vinn
Community Member

I am having this exact issue. Says I am using with another phone. Switch to my current phone, then it switches off and says the same things after a bit. Super confusing. Also, my thermostat decided to turn from heat mode to off. Temps dropped to 57°F inside overnight.

LizHC
Community Member

Mine worked fine for a while with Nest, but then stopped and this was prior ro Google taking over.  Have tried a million times to get it working.  Customer service hopeless…

Presently have a case running with  Google nest on Twitter about this, after running some checks, advised to just try Home/away /assist using phone  only , in Home/away/assist settings just have phone and not Thermostat checked as well . And ensure you have location settings set to always in Nest app. ( presently only using Nest App)  Everything appeared back to normal with these settings with Home/AwayAssist quickly applying eco mode when I was away from home.  So problem seems to be with Thermostat/ Home/Away setting conflicting with phone  Home/Away settings. 

Got this advise to, however this makes no sense. Thermostat sensor is supposed to set it to home, not away, in the case that I leave home but left some guests not enrolled, thermostat should be kept on to detect someone is home.

This didn't work for me. I also have a case open. It actually changes during the night sometimes when asleep (Thinking I'm away) or on Saturday when I was in the front room about a meter away from it it changed to Eco thinking I was away. It's driving me absolutely mad......I have everything else set up correctly. Yesterday  came home and stood in front of the thermostat and it still remained in Eco mode. 

LifeonMars
Bronze
Bronze

I have completely reset  everything my Nest Learning Thermostat, Heat Link and my Google speaker. I have only used the Nest app on my iPhone to reconnect the Thermostat and heat link.  Home/Away is on and I have set my iPhone to decide if I am Home/away  and also the Thermostat.  I have ignored any Goggle home settings except to log in for my Google speaker.    I can access the Nest app from my computer (macBook)  but I originally set it up through my iPhone.   The iPhone switched the Thermostat to Eco when I went out and the Thermostat also noticed there was no one at home also.   So it is looking promising after a complete reset of everything and redone through the  phone. If it starts playing up again, I will stop location access  to Google home but keep always location access to the Nest App and see what happens.  I am pretty sure that Google Home and Nest app are not talking to each other like they should. I am a UK user.

LifeonMars
Bronze
Bronze

I think the problem is if you allow Location always  on your phone (mine an iPhone)  ,to both the Nest App and Google Home.  Set Google home to  Location "Never" but your Nest App to "always"  This worked for me, with Nest Thermostat and Google Speaker.

Still having problem with learning thermostat,  auto switching to away on iPhone but  Home/away is not switching to eco temp when away, although set up. 

same problem here!  Reset the whole thing.  The fact that there's a Google Home and a Nest app (2 separate apps for 1 functionality) is also super confusing.  We have 2 accounts and the thermostat doenst know how to deal with it.  I have the impression only 1 person can be logged-in the "Google Nest" one.  

This functionality is crap, and it should be the most energy-saving one!  When no-one is at home, it should simply overrule the whole schedule.  I am now wasting energy in stead of saving it.  

please google, both correct and simplify this setup!! 

Nohows
Community Member

Yep, same here. Always worked fine before Google bought nest, but has got worse and worse. I ended up migrating my account to Google home from nest, thinking this might sort it. No such luck. When going out it now sometimes doesn't work at all, sometimes shows that the phone left home and then when it returns later ...but doesn't switch to eco as it's meant to while I'm away from the house. It's random and therefore impossible to work out what the problem is. Having to now try and remember to manually turn it down and up when going out and returning, which defeats the whole object. So frustrating!

With the help of some smart home apps, like home assistant, you could use the API to set eco mode to on and off when away/home

That's what I am doing since Google fails to see the bug. 

kayteemke
Community Member

Have you figured more out since your post?  We have the exact same situation.  When we only had the Nest app, home/away assist worked perfectly.  As soon as we migrated to Google home, it got totally messed up.  Sometimes it works for a few days and then stops and claims it hasn't seen my phone in days.  I do believe part of the problem might be the "presence sensing" of google home getting mixed up with home/away assist on the Nest.  We're now trying to only use the Nest home/away and we'll see what happens.  Additionally, however, even when we're home, it sometimes turns the Nest off as there is "No activity detected" even though our phones are in the house.  Do we have to constantly walk past the thermostat?  They really need to get a fix for this!

I had the opposite problem. The Home/Away with the Nest account never worked very well. It worked about 75% of the time. I was able to get it to work better with a 3rd party app (can't remember the name anymore) that got discontinued. I was able to get it to work pretty well with IFTTT. So, when the option to migrate to the Google account became open, I jumped on it. For about a year and a half, the Google Presence sensing worked perfectly. However, toward the end of last year, around the time when iOS 15 released the new Focus feature, it quite working reliably. I had initially thought it was a bug with the automatic focus features on the phone, making things go into DND mode. I thought maybe the driving focus when I was leaving or arriving home was interfering with the moment Nest detected I'd arrived or left. I whitelisted all of the apps I could think of, and it continued to work ok but not great. However, in December it really quit working. I tried switching back to using Home/Away Assist in the Nest app, and while it worked perfectly for two days, it started doing the same thing. This is completely an app problem, not a device one. My second "home" setup at my work office just has a single smart plug that turns on/off an air purifier. There's no Nest or other Google device there. It's not working either. Their GPS method is crappy, and sometimes even when it works and noticed I left, it doesn't switch the home into away mode. One person at Nest support tried to blame it on my cat triggering the sensors, but I turned all of them off, only relying on GPS, and that didn't help.

Currently, I've got a pretty workable solution using Homebridge and some triggers to set things to Home/Away depending on whether a phone is connected to my network. That's a very technical method though, so it isn't for everyone. It works almost flawlessly except that my phone occasionally disconnects from the wifi and puts everything into away mode while I'm there.

I am having the same issue. I can be home, and if I do not walk past the thermostat in some amount of time, the status changes to Away. How can this be?

Welcome to the “ Location Services not working club”….

Same advice I’m giving to everyone ….go on social media (Twitter or Facebook) and add your complaint

it won’t help as it seems Google support is not doing anything about this problem but at least you get it off your chest for the world to see…

I've already done that - makes zero difference. The latest is they told me it was my iPhone. I have a brand new one as of 2 weeks ago, guess what....? Sometimes it works, sometimes it doesn't, Which isn't good enough....I've given up, frankly. When I need the heating on again in the winter, I'll just have to do it manually!

LifeonMars
Bronze
Bronze

So, so far with Thermostat Home/Away Assist  off,  Only Nest app using phone,  works OK.

Put google home app back on phone to use google mini and only using phone for Home/Away/Assist in Nest app, it fails . Have to log in and out of app to get it to work or delete Google Home.

Have now added Thermostat  Home Away/Assist to Nest App will see how that works.Heating should be onHeating should be onHeating should be onHeating should be onHeating should be offHeating should be offWorking  Home/away/assist with Phone onlyWorking Home/away/assist with Phone only

LifeonMars
Bronze
Bronze