cancel
Showing results for 
Search instead for 
Did you mean: 

Nest Heat Link issue with one day left on the warranty

brabo72
Community Member

Hi,
My Nest Heat link has stopped working - no lights. This is the second of three I bought 2 years ago to break. It's literally one day before the two warranty expires. There is 240 volts to the heat link. I know I've tested it. I tried clicking the button (5 seconds, 10 seconds) on the front. I've switch the power off and on again. 

This is the exactly the same issue I had rough 6 months ago with the other Heat Link.

How do I get this fixed/replaced under warranty?

Thanks,

9 REPLIES 9

johnCNA
Bronze
Bronze

You need to contact Google on the official support site.  This site is for user to user conversations.

https://support.google.com/googlenest/gethelpsupport.google.com

 

CristianC
Community Specialist
Community Specialist

Hi there,

Thanks for reaching out. I'll do my best to get this sorted for you as soon as possible.

Could you also help me with some answers to these questions?

How long has your thermostat been installed for?
Did the issue happen during the installation?
Is there any error on the Nest thermostat display?
Have you had any power cuts recently?
Have you had any work done on your electrical or heating systems recently?
If yes, was the power properly restored at the fuse board after work was done?
How many zones ( thermostats ) are present in the setup?
 

How long has your thermostat been installed for?
It was installed 15/01/2019 by a Nest specialist. It broke on the 14/01/2022, hence I raised an issue rightaway as it the last day of the two year warranty. I also filled in the form for help I found on another thread. If you look you should be able to find it.

 

Did the issue happen during the installation?
No.

 

Is there any error on the Nest thermostat display?
No. As there is no power coming from the Heat Link. If I swap the Nest display over with another it comes on but has no heat link to connect to as the heat link it is paired with is dead.


Have you had any power cuts recently?
No.

 

Have you had any work done on your electrical or heating systems recently?
No.


If yes, was the power properly restored at the fuse board after work was done?
I've checked the fusebox and the power to the heat link and it is good, it is 240 volts

 

How many zones ( thermostats ) are present in the setup?
There are 3 and the two others are good. 

AlexD
Community Specialist
Community Specialist

Thank you for all the info. To proceed I would like to create a case for you. Would it be ok if I reached out to you over the email you have associated with your forum account? 

brabo72
Community Member

Yes. Please do.

AlexD
Community Specialist
Community Specialist

I sent an email your way. Check to see if you received it and reply to it when you are able.

brabo72
Community Member

Thanks. Now filled out.

CristianC
Community Specialist
Community Specialist

Hi there. I just sent you a follow up email. 

CristianC
Community Specialist
Community Specialist

Hello again. Since we've managed to resolve the issue over emails, I'm going to close this thread. Have a great day ahead!