cancel
Showing results for 
Search instead for 
Did you mean: 

Nest Thermostat

Kev_kirby
Community Member

Heat link has no lights completely dead , voltage is present . 

4 REPLIES 4

Frustratedddd
Community Member

They are not suppose to be like that, they are suppose to have lights!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

CristianC
Community Specialist
Community Specialist

Hello @Kev_kirby,

Thanks for reaching out. I'll do my best to get this sorted for you as soon as possible.

Here are some helpful troubleshooting steps:

Press the button on the Heat Link and check if you have any lights on it
Check if the circuit breakers and the switches are set to on
Turn them off and then back on
Press on the button again and check for LEDs

Could you also help me with some answers to these questions?

How long has your thermostat been installed for?
Did the issue happen during the installation?
Is there any error on the Nest thermostat display?
Have you had any power cuts recently?
Have you had any work done on your electrical or heating systems recently?
If yes, was the power properly restored at the fuse board after work was done?
How many zones are present in the setup?


Regards,
Cristian

CristianC
Community Specialist
Community Specialist

Hello again. Just checking in. How's it going with your Heat Link?

CristianC
Community Specialist
Community Specialist

It's been a while since this thread was last updated so I'll go ahead and lock this thread. If you're still experiencing problems, please feel free to start a new thread and we'll be happy to help.