Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Temperature sensor does not connect to thermostat

Community Member

I have three nest temperature sensors.  They all lost connection to the thermostat. I removed them from my app, pulled out battery to reset, tried to add them back to my app.  Keeps saying cannot connect to thermostat, no matter how close they are to thermostat. I've tried everything on the google suggestion page. still does not work.


Community Member

I have the same problem

Though it really shouldn't be this involved, but the reddit directions also worked for me.  👍 Thank you. 

Yeah unfortunately you have to reset and relink everything up and shouldn't be an issue anymore

my sensors quit working after about 6 months, for no reason at all. It's a relatively easy fix. Just go into settings on the thermostat, go to reset, just reset do not scroll down and delete everything on the thermostat. while it is resetting go to one of your sensors and check connection, it will not connect. As soon as the thermostat resets test connection again, this worked for me. Good luck and happy Nesting.

This worked!!! You da man!!!

yep, no idea how/why but this fixed bluetooth being in a failed state on my thermostat as well.

This worked for me. 
Reset - restart

while the nest thermostat is restarting, I tried to reconnect,

fails the first time, tried to connect and it connected! 

thanks bud

I try my best to help people sometimes it's a simple fix and sometimes it's complicated and needs more

Why that reset>restart without wiping the data from the thermostat is not the 1st standard troubleshoot step is unexplainable. Regardless that did resolve the problem immediately after the restart and without any other changes. My concern here is google documentation did not say word 1 about "Reset/restart" in any of the troubleshooting steps for thermostat sensors that I read, as a result it wasted my valuable time removing batteries, devices and having to sift through the forum here to find the most acceptable solution. JT RnR


worked for me!

Worked for me as well.  Huge help, thank you very much for posting.

**bleep** nest! What a pain in the ass

Did you really think technology would be that simple? I guess you did but sophisticated technology sometimes has its bugs

Really as the super pain in the ass but it works almost every time like every time I have to reset the system or change out the batteries I got to do this but yeah fun

Works for Android as well. Thanks for the info!

This is 100% true I love this application every so often it will disconnect but if you wait it will automatically reconnect and say you have power. After I replace every battery in the three sensors I have perfection.

thank you worked great, you'd think it would be in the trouble shooting directions. 

Community Member

Sam problem, all 3 sensors just all of a sudden stopped working. My guess is the Nest Thermostat program update for energy efficiency caused an issue with the sensors and they don’t know how to fix it. 

Try my fix at the top of this page, if you are still having issues 

You might actually have to reset the batteries if there's still in good working Nic. I replaced mine every year just to be on the safe side it's not really that difficult or impossible to reset reset to make sure everything works for a full year. Yes it does take time and understanding of the application the hardware in each sensor but it's the easiest thing to have in your house to monitor your temperature and heat loss from each individual room


Community Member

One thing that worked temporarily was to remove the thermostat and all sensors completely. I recharged the thermostat (the thermostat itself can have connection issue if the internal battery voltage drops low enough). I went through the setup again and it allowed me to connect the sensors again, but after a couple days, they dropped offline again and cannot reconnect. (Thermostat voltage is at 4.0).

If you actually have power going to your system you don't really need a recharge your Nest thermostat

For the longest time I thought my thermostat wasn't getting powered because it kept shutting off was probably just the fact that it was an older model and I needed to update to third generation

This is 100% true but if you have a red power going to the system you shouldn't have to worry about power unless it is disconnected from the outside to the house

Community Member

Did anyone find a fix for this? I have three sensors that went offline after working for 3.5yrs. I was able to reset all of them and re-connect but then a few days later they went offline again. The battery seems to be fine so not sure why this is recently happening?

You never change the batteries in your sensors then recharge your main controller mb

Community Member

I have the same temperature connection problem. Have three learning thermostats and three sensors each one individually connected to their own thermostat for past two plus years. One sensor dropped its connection to its thermostat. I cannot set it to connect. Its about 6 ft away, I removed and successfully added it back into the app, but it fails every connection test. Even after resetting the thermostat.  WiFi is full strength in that  area. Performed two dozen tries over two days. What am i doing wrong, or has the sensor failed? 

Community Member

I’m having the same issue. Did you get it working?

Community Member

Not yet. Still not connecting.

Community Member

I'm having the same issue 😕 

Community Member

I found another post somewhere else that said to take the batteries out of the sensors and basically reboot the thermostat. I rebooted to manufacture settings and put the batteries back into the sensors. They started working after that. So try that if you haven’t. 

I've already tried to reset for 10 minutes and I still get nothing so I'm charging up the thermostat itself


worked great thx

Community Member

The basement temp sensor mysteriously connected to the basement zone thermostat when I wasn’t looking. All by itself!

After dozens of tries using different recommended procedures over several days, all unsuccessful, I gave up and wandered off to work on other chores.


I have no idea how or why the temperature sensor connected itself to the correct thermostat. I left it sitting about 6 ft away from the thermostat for almost two weeks. Maybe I made it angry trying to  configure it so many times and it needed time to cool off.

One evening when adjusting basement temperature upwards (laundry day) using the nest app I noticed the sensor was suddenly communicating correctly with the thermostat, but it was listed in the app as “unassigned”. Assigning it to the basement thermostat was easy after that.

Software that takes so long to complete commands has quality issues IMO

Community Member

Take the batteries out of all the sensors and restart the connected thermostat from the thermostat (no need to factory reset) once the thermostat is back up,  pop the batteries are and recheck the connection

Done that: nothing.


worked for me, thanks

Community Member

Our connection got lost bcoz we have to turn off the internet for quite some. This one worked for us! Thanks!