cancel
Showing results for 
Search instead for 
Did you mean: 

Two thermostats constantly disconnect from server

KenCarty
Community Member

I have two Nest thermostats in my house. I installed them back in December of 2021. They worked fine for months. At some point they disconnected from the Nest server and I had to restart them to reconnect. Since then, both thermostats disconnect from the server on a pretty regular basis. They are connected to my wifi network, I can see them as connected devices. The thermostat itself shows it is connected to my network with a strong signal, but under the server connection I just get "disconnected - g.co/nest/m22"

I did a little bit of searching and found that some people had my same issue but were able to fix it by forcing their thermostat to connect via 2.4 ghz wifi instead of 5 ghz. I set up a mac filter rule in my router to do this and it worked, both thermostats connected and stayed connected for over a month. 

Now, out of the blue, they are back to disconnecting again at random. Sometimes, if I delete the mac filtering rules from my router and enter them back in again, I can get the thermostats to reconnect for a few days, but it never lasts.

I have rebooted them. They are on the latest software build. They have fresh batteries in them and are connected to external power. 

My wifi router is an Arris BGW210-700 provided by AT&T.  

10 REPLIES 10

Patrick_Caezza
Platinum Product Expert
Platinum Product Expert

How do you have them wired?

Do you have two separate HVAC systems or one system and a zone controller?

If you have a zone controller, post a picture of it and its wiring.

It's a dual zone system. I took a couple of pictures

https://photos.app.goo.gl/tRbK5uwQhdeeRT5z8

Ryan_G
Community Specialist
Community Specialist

Hey folks,

I just wanted to follow up and see if you're still in need of help. Please let us know as we would be happy to answer any questions you may have. 

Best regards,
Ryan
 

Ryan_G
Community Specialist
Community Specialist

Hi KenCarty,

 

Thanks for reaching out here in the Google Nest Community.

 

In addition to the help provided by Patrick_Caezza, let's check this guide here for Wi-Fi settings compatibility.

 

Thanks for your help here, Patrick_Caezza

 

Let us know how it goes by replying to this thread.

 

Regards,

Ryan

KenCarty
Community Member

I checked all the settings in the guide, there wasn't anything that needed to be changed. So, situation is pretty much still as it was. Both units connect to wifi but they are not always controllable through the home app, and it's pretty random. For instance, I restarted both units on Friday at the same time. My upstairs thermostat is currently showing up in the app, but the downstairs one has been offline since Saturday. 

Jake
Community Specialist
Community Specialist

Hey KenCarty,

 

I am sorry to hear you are still having trouble with one of your devices. I wanted to jump in, and provide you with an article I found. The article has more details, and troubleshooting steps when your device is showing offline. Please let me know if that helps, or if you have any questions from here.

 

Best regards,

Jake

Jake
Community Specialist
Community Specialist

Hey KenCarty,


I am truly sorry for the trouble and frustration that you are having with the device. I understand that is not the most ideal situation, and I am more than happy to assist. Since you have exhausted all troubleshooting steps, I would like to escalate this to a higher team.

If you could please fill out this form, our Team would then be in contact with you for additional support. Please let me know if you have any questions from here as well.

Best regards,
Jake

Jake
Community Specialist
Community Specialist

Hey KenCarty,


Thank you so much for filling out the form. I am showing a case has been created for you. Please be on the lookout for an email from our Team, and let me know if you have any questions from here. 

 

Best regards,

Jake

Jake
Community Specialist
Community Specialist

Hey KenCarty,


I wanted to check in, and let you know that I will be locking the thread in 24 hours.

 

Best regards,

Jake

KenCarty
Community Member

I appreciate the help in this thread, but I think at this point I just have to accept that both thermostats are going to be offline in the Home app unless I restart them every day. I don't know why that is, but I'm apparently not the only person with this issue.

Just as a suggestion, is there any way that an option could be added to the settings so that you can enable a daily restart schedule of some kind? Like, if I could set them to restart every day at 3 am or something, that would probably help out. It doesn't seem like anyone at Nest or Google is interested in figuring out why they disconnect so often, so at the very least a restart schedule could be a band-aid option for those of us who need it.