cancel
Showing results for 
Search instead for 
Did you mean: 

Google Nest Wifi setup with Spectrum Modem

scottperz
Community Member

Hi,

I had Spectrum internet at previous house and had my Next Wifi connected to it without any issues.  I am in the process of moving and received a newer Spectrum modem to use at my new address.  I tried for hours to get the Nest connected to the modem with no luck.  I had a Spectrum service person at the house today to troubleshoot the problem, and he was able to confirm that the modem is working properly by connecting a Spectrum Router to it.  I tried resetting the Nest, and I followed the setup instructions on the Google Home App numerous times without any luck.  I get as far as connecting to the router, but it always fails while trying to obtain a connection to the modem/internet.

Anyone else experience this problem?  Any tips on things to try?  I really want to use this router at my new location, but I'm getting extremely frustrated trying to get things setup.

Thanks in advance

Scott

83 REPLIES 83

ValS
Community Member

JoeZ's solution worked for me

Whats going on with this Jeff? A lot of us are beyond frustrated at this point.

stucumber
Community Member

Same situation for me -- modem only from spectrum, Nest router is connected directly to the modem via the WAN port (glove) on the Nest. I haven't attempted setting up any points yet. In my case, the light on the router remains pulsing white when I run into trouble after connecting while setting up the WiFi network.

I just set up a new Nest Router and had to perform a Spectrum modem restart using my Spectrum app. MySpectrum Services tab->Restart Equipment 

It would not connect until I did this. 

SergeMedia
Community Member

I’m having the same exact issues. 

SergeMedia
Community Member

Okay I figured it out. I had to reset my Google nest via the Google home app. 

ValS
Community Member

So...it is now Dec 6th and I have tried repeatedly to set up my Nest Mesh Wifi directly to my Spectrum Modem...crickets.  It fails every time by being unable to see the internet when all my other devices are working.  What on earth is going on???  Is there anyone out there who can help?

JoeZ
Community Member

Same here! It has to be the Google router. By connecting the router to the other router (in series) I was able to set the Google router, however it defeats the purpose of having the Google router specially when the download speeds are better with the old router. Is disappointing to hear that for more than a month all you guys are getting "sorry to hear you have problems..." but to concrete solution. Let's see what reaction I would get from this posting.

Texas
Community Member

Hi all,

 

I am having the same exact issue. I was told Google Nest Wifi was really good and I moved into a new house and tried wifi (and was planning to get Google thermostat and security as well) but I am disappointed by the lack of solution provided by Google. Had spectrum tech come to home abs install new wires form the box all the way to the home. Spectrum modem is online but no matter what the Google neat wifi doesn’t connect to the modem. Left a sour taste in the mouth. Planning to return the shoddily designed Google Neat wifi router if I don’t hear back from Google in a day. Customer service at its nadir! And these routers arent cheap for customers to be treated with such apathy by Google!

BudaTexas
Community Member

I'm having the same issues! I have a Spectrum account and modem that is just a modem. I was super pumped about the Nest WiFi with additional access points. I went ahead and set it up. Pretty easy to setup. However, no internet what so ever. I had two Spectrum techs out to trouble shoot the hardware. Not to mention the time on the phone with Spectrum before the techs came out. They replaced the cable from the power pole to my house, swapped multiple routers, performed any test they could think of. Checked their infrastructure point. Still nothing. The morning after, I plugged in my old router and it connected to the internet right away. I am so disappointed that there is no solution for this. I literally bought thousands of dollars worth of Nest Equipment, doorbell, flood light cameras, indoor cameras, door lock, multiple speakers, a hub max, a hub mini and this Nest WiFi to tie them all together. Except I can't. 

JoeZ
Community Member

Hi, I was finally able to figure it out. I connected the Google wifi via the ethernet cable to the old router. It goes thru the process of connecting, I ended up with two routers in series. After the Google router got the data it needed to set a new network I unplugged the power on both the modem and the Google router. I connected the Google router to the modem via the ethernet cable, waited 2+ minutes, then connected the power to the modem. I waited another 2+minutes and connected the power to the Google router, I waited another 2+minutes, and it finally worked. I hope this helps.

VP2IN
Community Member

Hi JoeZ - Your approach finally worked for me. I had the same issue that everyone listed above but the step by step sequence as suggested by you did the magic. 

ValS
Community Member

WOOHOO....your solution worked Happy New Year!!

Anonymous
Not applicable

I wish I could say this worked for me but it doesn't. You've explained it pretty clearly but even when using your steps, I still cannot get the Google Nest Wifi to connect to my wifi through Google Home. I can actually select the Google router and use it for wireless within the house, but I cannot get it to connect through the Google Home app like it should. I want it to replace my Spectrum router, not run through it.

 

How did you get your Google router to get the data it needed? 

 

On a side note, I have spent multiple hours on the phone with Google and Spectrum and no one can figure it out. The whole situation is completely ridiculous that neither one of them know what to do to correct this issue.

Jessalready
Community Member

Going to try this tomorrow.  I’ve been so frustrated all evening! 

NRHTX2006
Community Member

What did Google do that everyone is having these issues.

My sister had the same situation, I tried to help her by following your instructions. She has the black Spectrum modem. I told her to turn the modem off and wait about 2 mins, I told her to connect the Google Wifi from the spectrum modem directly to the back of the GWifi in the globe slot. The GWifi started blinking pulsing blue and I told her to open the app on her IOS and follow the instructions. She was able to get connected, but in the end, she received the same message (Problem connecting Please check if you're online) Before connecting I had her connect directly to her laptop with the network wire and everything worked fine. Then she connected the renter Spectrum router and that was also working.
I had her follow your instructions to the T and she was not able to connect via the Google Home app.
Here is the strange thing, the GWifi was still blinking pulsing blue and GWifi was broadcasting the wifi signal and she was able to connect to her laptop with this setup and the password behind the GWifi. However, because she was not able to connect via the Google Home app via the IOS app and set up and connect with the other GWifi routers I told her to call Google Home support (866) 281-3017 and of course, they took forever and she got tired of waiting.

My experience, was when I purchased my Google Wifi back in 2018 and I swear I connected all 3 Gen 1 GWifi within 20 minutes. The second generation which has the weird reset bottom underneath is giving her major issues.

However, I remember back in Dec 2021, by mistake connecting my Nest Thermostat, I screwed up something on the Google Wifi app that I had to reconnect reset and reconnect all my devices and I also had the same issue. But after an hour I waited and managed to get them to work again.

Surelypberg
Community Member

I was successful with this setup. Adding the router in between somehow let’s the google mesh router connect to the internet to get updates when the Spectrum modem wasn’t enough. I haven’t disconnected the additional router to plug directly into the modem. Too scared to do it but maybe one day. 

  • How is your speed with the extra router? Does a certain one work best?

I have had this issue.  Initially installed Google Nest mesh wifi with one router and two access points in November 2021. It worked for two weeks, then it lost internet connection. I could NOT get the internet connection back, even after resetting the router, the Nest equipment and reinstalling, etc.  Everything would go fine until the it would tell me that Nest could not establish an internet connection with the modem.  I called Google and after an hour on the phone we got it working. I don't recall exactly how, but I believe I had to reset the Nest system from within the app, maybe even delete the app and all my stuff in it and start from scratch..  It was messy, I don't remember all the particulars.

Fast forward 8 months. Everything was working fine until we had a power outtage for 6 hours during a storm.  The next morning one of the access points lost internet connection (but the router and other access point still had it).  Unable to get it to work, I rebooted the modem and the Nest access point, and then I lost ALL internet connectivity through the Nest system!  I could NOT get it reconnect and eventually reset all the Nest devices (using the rest button on the bottom of the devices), even deleted everything in the Home app, and started installing from scratch again. But again, no luck - would not connect to the internet when connected directly to my Specrum provided modem (modem only, not a combo moden/router). 

So then I installed my old Netgear Nighthawk so I could get wifi back.  Had no issues getting internet with that connected to my Spectrum modem. Then I remembered reading on here about the solution of connect Nest to another wired router between it and the modem.  I tried that and Nest installed and set up easy-peasy no problem!  So now I had two wireless networks running, and so I turned off the wireless broadcasting on the Netgear.  So then I was back up and running with Nest as my wifi system.

I'm a perfectionist and it still bothered me to have the Netgear router as a go-between, and worried I might be losing some speed. I read the comments above and, once Nest was working again via the Netgear router, I tried the steps above to connect the Nest back directly into the Charter modem.  But... no dice - no internet connectivity.  I am back to using the Netgear as a go-between, and am afraid to do anything else, so may just leave it that way.  My download speeds are measuring around 224 on my laptop with a direct wired connection to the modem, and around 194 via Nest wifi on laptop. My phone on wifi just measured 211 download. When I connect my phone to the Netgear via that device's wifi I am getting 228.  But I get different results everytime I run a speed test, so who knows.  It appears I might be getting some minor speed reduction with the current setup.

I'd like to look into just getting my own modem and getting rid of the Spectrum as I've read that also solves the problem (that way I can get rid of the Nighthawk go-between). However, we have Spectrum voice and you HAVE to use Spectrum's modem for voice. So that means I'd need to have two modems - one for voice and one for data.  Which is ultimately what I might do. But until then I'm not messing with anything, and am keeping the current setup with the two routers.

samchan80
Community Member

This worked for me as well. Thank you!!!

JJK
Community Member

I’m still having the same issues with spectrum. I just moved and had no issues with my two previous internet providers so it must be an issue with Google WiFi not being compatible with spectrum. I’ve tried factory resets and connecting directly to the modem and to the wireless router separately and I still get the same can’t connect error message. Are there any other solutions out there or do I just have 4 expensive  paper weights now?

colinj
Community Member

I am having the same issue as others have above; the only way to get the Google routers to work is by using the Spectrum router as a middleman. I suspect this is by design and Spectrum just wants to rent out their routers. Have found no fix so far. 

Hookdw
Community Member

I am having the same issue as others have above. May be time to put the retailers on notice that this is an issue with the Google Nests Routers.

EricDeanMorse
Community Member

Same issue. Spent hours trying last night. Modem/router are separate units. Followed exact protocol as others. Reset network on google home, rebooted whole system, scanned code on nest wifi and get the check mark (success), get all the way to "Creating your WiFi network, working on it, almost there, just a few more things to do...."  then the ERROR pops up. Grrr... now sitting on expensive paperweights... now following this thread. 

I had the exact same problem a couple nights ago. Network went down and I tried to reconfigure everything from a factory restart. Spectrum modem + google wifi. It would fail every time when trying to save the network SSID and password. I was on the phone with a google tech agent for at least an hour. He eventually told me the problem must be on Spectrum’s side.

I solved the problem by leaving the google ecosystem and buying a new eero 6 wifi system. With that new system I had the network all set up again in 5 minutes. Thanks for nothing google. 

I tried everything that everyone recommended and could only get 2 of the 4 hubs to connect (could not get the other 2 to work).  Since I not only paid for, but also need to have all 4 in order to have continuous and consistent wi-fi throughout my house, I finally decided to turn in those useless hockey pucks to amazon for a credit and purchased the eero pro 6 system (3 pack).  It also literally only took me 5 minutes to get me up and running and now I have no dead/drop zones.  Thanks for nothing google is right!

EricDeanMorse
Community Member

Are you on Lake Fenton Scott? Think I live next door to you...

MitchellKois
Community Member

Good to hear this isn't a unique situation I'm in.

This is unbearable, Google should be ashamed to pretend to care about this issue. Unacceptably stupid. 

If it isn't obvious, same issue as literally everyone else. You claim Google is aware but unable to diagnose the problem...that certainly can't be possible. You have manufactured the devices and are aware of their connectivity abilities. Your pretending to not know is gross, dude. Admit that Google would need to issue a recall and they aren't willing to do it. What a joke.

I have thousands of dollars investe3d in to a broken system and Google will not even acknowledge the numerous complaints we have. Looks like I will have to dominate social media with complaints now. I have a decent presence. If google does not help on this forum, they will suffer on socia medias platforms.   

Gvmeliberty
Community Member

I was able to get it to work by going to a system with Xfinity modem, setting up the router there, then bringing it back and connecting it to the spectrum modem. Working fine for several weeks now, bizarre that this has not been addressed. 

triekse
Community Member

It took a while, but by "reprobating" the Spectrum modem I was able to get the Nest Wifi to communicate.  Call google at 855-971-9121 and they can help

Carlos19
Community Member

Same here,  Spectrum modem only.  Failed the first time while trying to “set up network” step.  Got the “problem connecting, please check if you are online”.  Factory reset, tried again, had to restart my modem during the process on both occasions per directions…..same result, still shows offline

Looks like my issue was fixed.  It was tedious, but it worked for me.  All I had to do was update the google nest software.   Like others mentioned here, I had to use a different modem which I was lucky enough to have laying around.  This happened to be a netgear modem/router.  So I had to install it through the the Spectrum app, the self install. Once I did that, the nest software was updated, it was not instant, I actually left it on for a while.  After the latest software was installed (14150.43.81 as of 5/28/22).  And set up again, and it worked. In summary the procedure that worked for me.

1. Install old netgear router/combo (you can probably use a different one) through spectrum 

2. Set up the nest through google home app

3. wait and verify for software update

4.  Disconnect the nest and modem/router

5. Reinstall the Cisco modem through Spectrum app

6. Verified I had internet through Ethernet connection,

4. plugged the nest back in 

5.  It was still not connected, so I unplugged the Cisco modem and follow the same start up procedure ( wait 2 min before plugging….)

finally it worked.

Jpo2
Community Member

I too am having issues connecting a nest router directly to a spectrum modem only. 

Jgobjr
Community Member

I’m having same issue. Have rebooted in special sequences and works for a while and then reverts back to inoperable. This has happened now three times 

Jgobjr
Community Member

I think I have diagnosed the problem and will report back here if it turns out not to be correct. I connect a switch to Nest router to bring Ethernet connection to a few wired connections in the house. For some reason when I connect the Sony Bravia Ethernet to the network, it crashes the system and causes the need for a reset. It’s a new Sony running google TV. Have kept connected to wireless and system staying up

davistye
Community Member

Exact same issue. Everything was connected (Nest Wifi directly into Spectrum modem) and working fine. Just stopped last night. I've rebooted everything in the correct order. I've factory rest the Nest and tried a new setup. (The internet from the modem directly to a laptop works fine). But durring the re-setup all I get is "the modem isn't giving your wifi a point of internet connection". I've followed all of the reboot steps in the correct order multiple times. Nothing.

Adam9218
Community Member

Sounds like a fix is to connect it with another router… what are those of us without one supposed to do..

Go pickup a router, make the fix and return the router when done. Or just return the google mesh and pick up an eero

ericortego
Community Member

I just switched ISPs to spectrum and this issue happened right away. 

I haven't done a packet capture yet but I can get the cameras to work for a little while....not sure how long it lasts yet. Lasts for awhile unless they lose internet access.

My setup is like this

SPECTRUM <----> fiber into "modem" <-----> cat6 to netgear wifi <----> PC's equipment etc

T-Mobile<----/disconected/----#

So, if I disconnect my netgear from the spectrum "modem" and plug into T-Mobile, then power cycle the cameras, they both show up in Google Home and are fully operable.  I can now unplug the netgear from T-Mobile and put it back into the spectrum "modem" and the cameras will continue to have access until an undetermined amount of time at which point they will quit operating even though I never get an offline alert.

 

While inoperable they are still connected to the wireless and are pingable on the local network. Just not able to control them on from the app.

 

After running a couple packet captures the only thing I notice is that the camera seems to retrieve a certificate when I put it on T-mobile.  Once switching back to spectrum the cameras just keep working. I can reboot my netgear once they've re-established and when the cameras reconnect they're still functional. I can also reboot the spectrum modem watch it get a new WAN IP address and they still continue to work immediately after the connection comes back up.  But if I reboot one of the cameras, it will not come back until I do the ISP switch again. 

 

EDIT3: Now I just have 2 ISPs hooked up and turn the dhcp server off on one and feed the other to my routers WAN, then I hand out the other one's ip as the default GW to the cameras so they don't go through spectrum at all and it works perfectly even after powering everything off and back on.  Spectrum has something blocked ... I noticed 123 for NTP is blocked and not listed on their Consumer blocked ports page.