cancel
Showing results for 
Search instead for 
Did you mean: 

Google WiFi Throttled Download speed

Glassair
Community Member

My Google router is reducing my download speed to 50. No matter how many times I reset the router via the app or at the router itself, I still only receive the lower speed. The speed coming into the premises has been  tested and is good. I've also factory reset the router twice. I don't know what else to do. The router is less than 12 months old.

1 ACCEPTED SOLUTION

Glassair
Community Member

Success!

I followed the following steps.

I disabled priority settings.

I turned off cloud service for at least 30sec.

Stopped Google home app and rebooted it. Restarted the Google Nest network, router and points and bingo! Full internet speed was restored. I just hope it's not short lived. Thanks Jeff.

View solution in original post

15 REPLIES 15

olavrb
Gold Product Expert
Gold Product Expert

It's likely due to the built in QoS, fq_codel. You could try to disable all preferred activities:

What is QoS, quality of service, you say?

This is a frequent topic, here are some earlier discussions:


I don't work for Google. I'm here to help and learn more.

Glassair
Community Member

Thank you I'll give it a go.

Jeff
Community Specialist
Community Specialist

Hi, Glassair.

I just wanted to check in and see if you were able to try out any of those suggestions from olavrb and to see if you were able to work out the issue here. If you're still having issues, let me know and we can continue to look into troubleshooting steps.

Thanks.

Jeff
Community Specialist
Community Specialist

Hi again, Glassair.

I'm just following up to see if you needed anything else on this or if you were all set.

Thanks.

Glassair
Community Member

Success!

I followed the following steps.

I disabled priority settings.

I turned off cloud service for at least 30sec.

Stopped Google home app and rebooted it. Restarted the Google Nest network, router and points and bingo! Full internet speed was restored. I just hope it's not short lived. Thanks Jeff.

Jeff
Community Specialist
Community Specialist

That's great news, Glassair. I'm happy to hear it's working as it should.

Let's give this a little bit more time before marking it as resolved. I'll check in later and see if all is working as it should. If no problems at that point, we'll close things up.

Thanks!

Glassair
Community Member

Well it's back. Throttled speed again. I got the speed up again for a short time, but it is only temporary. Now I'm finding it difficult to retain the higher speed. It's very frustrating.

I hope a permanent fix is found soon.

Jeff
Community Specialist
Community Specialist

Thanks for letting me know, Glassair. That's definitely frustrating and I'm sorry it's back. We'll keep looking into things.

Jeff
Community Specialist
Community Specialist

Hey, Glassair.

Have you tried changing out your ethernet cable that runs from your modem to your main router? We've seen some people reporting better results after doing so. We're not 100% sure what's the cause there, but several people have mentioned it. It might be worth a look.

Thanks.

Jeff
Community Specialist
Community Specialist

Hey again, Glassair.

I'm just circling back to see if you were able to test out swapping the ethernet cable and if it had any impact for you.

Thanks.

Jeff
Community Specialist
Community Specialist

Hey, everyone.
It looks like we've slowed down here again. We'll be closing up the thread unless anyone else has any input or needs anything else. If so, just let me know and we can keep this open a bit longer.
Thanks.

Glassair
Community Member
Hi Jeff,
 
I originally changed the Ethernet cable when I first discovered the problem. So currently, I'm using a different cable. What I will do though, is purchase a cat 7 cable and see if that works. 
 
The strange thing is every now and then the speed increases by itself without any input from me. Very confusing.
Cheers,
 
 
Show quoted text
 
 
 

 

 

 

Jeff
Community Specialist
Community Specialist

Hey, Glassair.

I'm happy to see that you're having improved performance, but it's a little odd that it seems to have changed out of nowhere.  Let's watch it for a bit and see if it stays stable for you.

Thanks,

- Jeff

Jeff
Community Specialist
Community Specialist

Hi, Glassair.

I'm just following back up to see if your speeds were still bouncing up and down or if they've found any stability. 

Thanks,

- Jeff

Glassair
Community Member

Hi Jeff, sorry to report. Throttled back again. I did notice that if I prioritise a device, the router sends the higher speed. But, this is not the case all the time. I'm scratching my head on this one.