Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest Wifi Pro - error when trying to add second/third node

Community Member

51m ago


Ive just recieved my Nest Wifi Pro (3-pack) - replacing an Asus XT8 setup. However... when setting up Nest Wifi Pro... Ive run into a mess.

In short: Setting up the first node/router, is plain sailing. Everything goes according to the instructions. I have great wifi in the basement (where my Fiber modem is located)

However, when adding a second node everything crashes. I can see the secondary node in the Google Home app, but just as the Google Home app says "setting up mesh network"... both the main router/node and the secondary node "crashes" The crash happens before i scan the QR code on the secondary node. Main node starts blinking yellow.... and i get the following error message in the Google Home App:

the operation couldn’t be completed. (googlemac_iPhone_Home_Wifi_Operations_Impl_Impl.PollForCompletionOperationImpl error 0.)

Ive tried to factory reset (more than 10 times), hardwired the 2 add-on nodes, tried setting it up from several older ios devices, from an iPad, ive checked all the permissions in the app, i have deleted my "home" in google home, reinstalled the google home app.... nothing. Same error message every time.

What am i doing wrong?


Leif Arne


Platinum Product Expert
Platinum Product Expert

Make sure the device used for the setup process with the Google Home app have no VPN enabled/ connected; not any 3rd party product, nor the "Apple iCloud Private Relay" ( ).

Make sure the Google Home app has been granted permission for "local network access" ( ).

Make sure that proxy is set to disabled while connected to the Nest Wifi network ( ).

When adding additional points: IPv6 on Nest Wifi has caused strange problems lately. One thing to try is to disable IPv6 ( ), add new Nest Wifi unit, then leave IPv6 off or enable it again.


If nothing of the above works, try from a different iOS, iPadOS or Android device, using the Google Home app with the same Google account, or a Google account that has been granted access to the specific Google Home home ( ).

I don't work for Google.

Community Member

Thanks. I read your post… yesterday (someone with similar issue)… tried all the suggestions. Still not working

Community Member


Community Member

I had the same issue when I setup my Nest Wifi Pro Mesh, Here are the steps which helped,

  1. Make sure no wired devices are connected to the LAN port of the first Nest Pro router.
  2. On IOS/iPhone in the Nest Pro devices Wifi connection turn off BOTH "Private Wifi Address" and "Limit IP Address Tracking"
    • You have to repeat this step every time your phone/device running the Google Home App is connecting to the local Wifi network of the device being setup (Wifi SSID "") .

I was hopeful when I read your suggestion. Did what you recommened... but it was of no help. ;-/