Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Trying to view Nest Wifi connected devices list triggers 'Something Went Wrong' message.

Community Specialist
Community Specialist

Disclaimer: This thread was migrated from our previous version of the Google Nest Community.  You can continue to receive updates on your thread issue here or simply ask, browse or more in the new Google Nest Community. 

Original Poster:_Lexi

For the last few weeks, whenever I use the Home app to view my Nest WiFi settings, the app's "Devices" tab will either display the message "Something went wrong" or, alternatively, a spinning wheel graphic. This means that I am unable to view the list of client devices connected to my Nest WFi network and that I cannot prioritise or pause them.

This error only seems to occur if my phone, a Pixel 5, is connected to my WiFi network. If I open the Home app while my phone is using its 4G or 5G data connection, the "Devices" tab behaves normally.
The error seems to be affected by two factors. First, as mentioned, the app works normally if my phone is not connected to my Nest WiFi network. Second, the app appears to work more reliably over WiFi if I open it after restarting my network, but before my Nest Wifi network carries out its automated speed test (automated speed tests occur once every 48 hours).
The problem persists even if I clear the Home app's cache, reinstall the Home app and/or reset my Nest WiFi network.
I've seen lots of Home app reviews on the Play Store that mention symptoms similar to mine. No one there appears to have made the connection between these issues and having the Home app connected to the network it is managing.

Community Specialist
Community Specialist
Hello, Lexi.
I'm sorry about the troubles you're having with your Home app and network errors. I imagine that's quite frustrating. Let's see what we can sort out here to get things working more smoothly.
I see you have already tried some troubleshooting. Thanks for letting me know what you have tried. I was wondering if you could try turning your cloud services off and on. The steps for doing so are below.
Open the Google Home app.
  1. Tap the WiFi icon.
  2. Tap Settings.
  3. Select Privacy settings.
  4. Toggle Nest WiFi cloud services OFF and wait for 30 seconds, then back ON.
Once done, close the Home app and perform a full network restart to ensure that the new settings are in place. To do this, I would recommend doing a power cycle on your network.
  1. Disconnect the power adapter and the Ethernet cable from the Nest WiFi router.
  2. Disconnect the power adapter from the Nest WiFi points.
  3. Disconnect the power adapter from the modem. Allow all devices to stay disconnected from the power for 5 minutes.
  4. Connect the power back to the modem only and wait for it to fully back up. All lights should be lit up before moving to the next step.
  5. After the modem is back online, connect the Ethernet cable back to Nest WiFi router's WAN port (globe symbol port).
  6. Connect the power back to the Nest WiFi router and to the Nest WiFi points. Wait until they're all fully back on.
After trying these steps, see if that clears things up for you and makes communication work a bit more smoothly. If you are still having issues, please come back and let me know.

From: Jeff
(Community Specialist)

Community Specialist
Community Specialist

Hi, plien69.

Sorry for the troubles you're having with the Home app. I'm sure that's quite frustrating. There is actually a known bug right now in the Home app that we have identified and we're working to fix. Thanks for pitching in with your experience as everyone's input is helping us to diagnose and fix the matter.

I will update the thread with more information as I have it. Thank you.

Community Specialist
Community Specialist

Hi, all.

I just wanted to check in real fast to see if we still needed help on this one or if everyone was able to sort out their issues. With the recent update on the Home app, I'm hoping things smoothed out for those who were experiencing issues. If there's anything else we still need here, just let me know.


Community Specialist
Community Specialist

Hi, everyone.

As we haven't had any activity here recently I'm going to go ahead and close the thread. If you have more to add, feel free to start a new discussion.


Community Member

I have the exact same issue and symptoms as the OP, also using a Pixel 5. Like the OP, listing the devices works fine if I'm not connected to WiFi and using cellular.

I've performed the steps described to help fix the problem, but it did not help.

I will add a couple other observations:

1. Occasionally, the Home app will successfully refresh and display the devices list, but it is very inconsistent.

2. The old, deprecated Google Wifi app doesn't have the issue. It works successfully, reliably, and quickly to refresh and display all Wifi network devices, even when the Google Home app does not. I can quickly switch back and forth between the two apps, and Google Wifi app will always work reliably, whereas the Google Home app gets stuck trying to refresh/display network devices.

3. The iOS version of the Google Home app does work properly in this same use case.

4. This issue seemed to start with the latest major refresh of the Home app on Android.

Here is a video demonstrating the issue, with timestamps/chapters showing the differences between Home vs Wifi app, and cellular vs Wifi, plus one instance where the refresh worked on the Home app: