Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest Connect Na009

Community Member

I'm trying to get my lock setup but the nest connect isn't working. It keeps giving error code Na009 but I can't seem to figure out what that is. 


Community Member

Same just got a replacement connect and getting the same error you're getting na009

Community Member

Same here just trying to connect nest connect and after reaching the finishing adding Nest Connect to your account it throws the error

Community Member

Same ... ugh!  This is so frustrating.

Community Member

I'm scared to even touch it now, just waiting on support.  This really shouldn't be this hard 

Community Member

Found a solution, i call it a work around because this isn't how the app should function.
Create a new home, lol 

  1. Create a new home in the nest app
  2. Add the connect device
  3. close out of the nest app, force quit or restart phone.
  4. take the batteries out of the lock (30 seconds or more)
  5. put the batteries in the lock
  6. open the app
  7. scan the locks qr code and add lock

There it is!
But dont forget all your other Nest Devices are in your other Nest Home...  So now I have to move all my devices over to this new home.  SMDH.  Unless someone knows another way.  

Hey Google QA!!!!  Look into this please!!!!!!

Community Member

@ICECOLDPIXEL I just spent 2 hours on calls with google support getting fed the same "work around".  I insisted this does not work as advertised if I have to maintain 2 home profiles and/or if its my responsibility to consolidate everything into a new profile...a huge time sink and 100% NOT as advertised.  


This product is clearly defective.  I requested a return, it's out of the extremely limited 15 day window, and was told "i cannot help you" and hung up on....twice.  Big fail, Google.  Not a good look. 

Community Specialist
Community Specialist

Hi folks,


Thanks for reaching out. I’m sorry to hear you can’t add your Nest Connect to the Nest app. Did you get a chance to try the suggested steps provided by ICECOLDPIXEL? If so, how did it go? Let me know if you need more help.



Not yet because it kinda seems like a pain in the ass to do if I'm honest. 

I agree this shouldn't be a fix,... There is a problem with the app that y'all need to fix..... I'm not moving all my devices into a new home because Google can't get it's act together

Just catching up.... Yeah this does not work as advertised.... Sorry to hear about your terrible experience with google.   They aren't what they used to be 

Agreed - now I'm stuck with a $300 non-functional lock that I'm unable to return...and a waste of multiple hours of my time.  

Community Member

I have the NA009(0.80) problem connecting Nest Connect to add a Yale lock.  Tried 3x to connect with no luck.  I’ve called Google Support before, but now I am being told there is no more phone support.  Tried calling Yale, they were no help at all.  I’ve restarted our wireless network and devices multiple times.  We have Nest thermostats, smoke detectors and doorbells.  No issues with those.  WHAT DO WE DO HERE?  And how does one reach any form of Google Support.  The web site simply sends you in an endless loop.  

Through the nest app, on the support tab select contact us.  You should be able to chat with them..


Has anyone deleted the lock out of the NEW home, reset it and try to add it into the old home.  I want to try that but scared I'm going to be back in the ERROR LIFE 😂

You're one brave individual if you go that route.  I threw the box into a closet and just stewed in my frustration.  300 dollar paper weight at this point. 

Removing from new to re-add to old home didn't work

Community Member

I did try this. Does not fix the error code. I also just received a replacement nest connect nothing. I call Google and get the old "restart your router" or it's your ISP which if that was the case then why does it connect to the new home?


Looks like this is a common problem Google!

Community Member

Having the same issue. Received new equipment from spectrum and had to reset up all my devices because of the new wi fi. Not only having problems with just this, also having an issue with some of my Google cameras disconnecting. Don't think it's an ISP issue. I was able to add everything else back to Google home besides the connect. 


Community Member

I am also facing the same stupid issue that started now the door lock is not connecting to the Nest Connect. Wasted 4 hours of troubleshooting with them via call but the issue didn't fix. 

Community Member

I actually have two homes and two different states with multiple nest products. Because of the issues stated above, I've decided to sell or throw away all Google nest products and buy ring/Amazon products because the support is available! Google is trying to push everybody away from nest and sell them new cameras and locks that work with Google home only. 

Hey Google! Thanks for ruining nest! 


Community Member

Bro, the only way to fix this problem is to delete your home from Google Home then create a new one.  This will also be updated in your Nest app.  Now you have to install everything again in your Nest app.

I spend almost two days to figure this out after trying and running out of all available options from the internet.  Btw I also tried disabling 5GHz network from my modem and connecting to 2.5GHz but useless. 

So the only thing I can think of is that once error code NA009 appears, it means that there is something in the google home or nest home which does not allow nest connect to connect with the Nest app.

Hope my answer will fix your problem.    

I had read your solution from another community member already and even spoke to Nest support They also suggested I create a new home but I recently paid for 1 year of Nest Aware on my home that already had several cameras and if I created a new home the contract wouldn’t have included the new home so I needed to find the solution to keeping the home that had all my cameras, thermostats and doorbell. It took 2 days and even the Nest tech wasn’t able to solve the issues because they said I just needed to remove the Thermostats and they didn’t tell me to remove the Doorbell Camera but that was what was blocking everything. Well we did finally get it to work by removing the Thermostats and the Doorbell. Also, it’s very important to do a FACTORY RESET after removing the devices from your Nest Account. 

Community Member

I succeeded by removing my Nest Thermostats (x2) & Nest doorbell from my home then factory reset of those devices befor adding the Nest Connect. I had called the Nest help desk who told me to remove just the Thermostats. They said the cameras weren’t causing the problem. Well they were wrong, the doorbell camera was blocking it also.

After adding the Nest Connect you can add the doorbell back to your home and it actually does this via Nest Connect. Then add your thermostats if you have any. It wasn’t necessary for me to remove any of the other Nest cameras that we have in our home, just the doorbell camera. 

I'll take only removing 3  over 30 lol

I'm going to try this, this week!!!

Community Member

I removed the door camera and keep all others offline. But the issue is still there. The best connection failed by the end when it was showing finalizing the connection.

Community Member

When removing the door bell camera you must first remove it from your Nest account then make a factory reset on the door bell camera before trying to install the Nest Connect. You need to do a FACTORY RESET because this will erase all the wifi settings that might be interfering with the Nest Connect. Don’t just do a simple reset because the wifi settings stay in the system. Factory Reset the Nest Connect before trying to add it. Also, each time you add or remove a device from your account make sure you close completely the App on your phone. 

Hope this helps!

What other devices do you have?

Community Member

I had the same issue, and I took the advice and removed the nest camera and I was able to add the nest connect.  Something else that was very odd was that I could not add my nest thermostats back using my Google phone and I was able to add them back using my iPad.  I would recommend removing the camera and then trying to add the nest connect. If that does not work, I would attempt to remove the thermostat.   Also, I would try using another device add devices.

Community Member

I do it but still have the same issue 

Community Member

Yes can confirm the solution is to remove all the products from the nest app then add the nest connect first. This is much less of a headache then removing all the products from the Google home app. Was having the same issues as every one here and this is the solution.

try everything I remove all and try to connect it but still the same error. It's really headache 

Make sure you're removing from the nest app not Google home then add the nest connect as the first thing 

Community Member

Did you FACTORY RESET the devices?

Community Member

Try removing any Nest Thermostats & Nest doorbells from your home using the Nest App. Then FACTORY RESET those devices before attempting to add the Nest Connect.

After adding the Nest Connect you can add the doorbell and or thermostats back to your home using the NEST app.

It wasn’t necessary for me to remove any of the other Nest cameras that we have in our home, just the doorbell camera and thermostats.