Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest Connect

Community Member

My nest connect unit has gone dead.  plugged in, now lights, not being seen by google wifi or nest set up.  Tried to reset it but get no lights at all.

Is this a common issue that the connect devices brick like this?



Community Specialist
Community Specialist

Hi there,


Sorry for my late response. Thank you for all of your patience while waiting for a reply. I just wanted to make sure that your issue is addressed. I can definitely understand how frustrating your situation must be. I would love to help you find a solution to this issue. 

  • Do you still need help with this issue?

  • What troubleshooting steps have you done thus far? 

  • Have you tried to restart your device if you haven’t already?

  • If the restart didn’t work, have you tried to do a Factory Reset? This would be a last resort option, but would clear out issues and the device would essentially be ‘brand new’

Please let me know if you need further assistance. 

Best Regards,


Community Member

Hi Brad:

I've tried a factory reset.  I can't get any lights or response from the unit. I've plugged it in thinking that perhaps the battery has drained, and still not able to get any response. My app was never able to connect with it.