Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Hub stuck on grey ‘g’ screen, factory reset not helped

Community Member

Hub stuck on g screen factory reset brings it back to g screen. Power off overnight, no change. 

1 Recommended Answer

Community Specialist
Community Specialist

Hey folks,


Thanks for sharing all the details about the issue. 


We understand this issue has been happening for quite some time now, but rest assured that our team is aware of this and looking into this issue at hand. Please try to plug in the device to a different power outlet, then attempt a reset.


If unresolved, perform the workaround below:


  1. At the back of the Nest display, unplug the power cord and wait for 10 seconds, then plug it back in and wait until the screen with the "G" logo shows up
  2. Repeat the first step, 10 more times.
  3. After the customer plugs the power cord back in, wait for the device to reset. The device announces "Welcome to Google Home" to signify that it's ready for setup.

Put your device to recovery mode:


  1. Put the device in Recovery Mode (Unplug the device, then perform a long press on the volume up and volume down buttons while the customer plugs the device back in. Once the device turns back on, release the volume buttons.)
  2. Once the device boots into Recovery Mode (a long press on both volume up and volume down buttons at the same time), attempt a factory reset.


If the above steps don't work, please reach out to us to get immediate support on this link:




View Recommended Answer in original post

1,523 REPLIES 1,523

This is incorrectly called a “solution”. I wish they’d just go ahead and say it’s a brick at this point. Mine went to the grey “G” within minutes of being plugged in for the first time after it tried to update for the first time. Sending back.

Community Member

Hi Frances what is the solution to the problem with the nest hub just sitting with a G on the screen seems like a very common problem?

Community Member

I am having this same issue. Can you make a support ticket for me as well?

Community Member

Is there a solution for this

Community Member

I have the same problem! Has anyone found the solution? 

Okay well I unplugged mine and then press both volume buttons down as I plugged it back in. It allowed me to reset the device, however the first time it went right back to the gray screen. I repeated the process a second time and it reset the device back to the original out of the box set up screen and I was able to restore it to functional status.

Community Member

My Google home is stuck on g. Factory reset did not help

Community Member

My Google home is stuck on g. Factory reset does not resolve the issue

Got the grey screen with the "G" logo on my Google hub this morning. Tried the recommended factory reset. No change.

My hub is an essential part of our household.

Please help!

Community Member

Can confirm, the best way to resolve this issue is not here but to call Google support. Sounds like it's a known issue after some new updates were pushed out

Community Member

I am also experiencing this problem

Community Member

Your form doesn’t get to you. My Google nest hub is stuck on a gray screen with the G logo and I can’t get it to reset.

Yeah the factory reset doesn't work still stuck on "G" screen.  

Community Member

I am having the same issue, stuck on grey screen & reset to factory settings not helping


Community Member

I am having the same problem. Reboot to factory reset does not fix it. 

Community Member

I have the exact same issue. Not sure why it happened. 


Factory resetting doesn't help.

Hello, I’m having the same issue. Tried doing factory reset during recovery several times with no luck.  My decide is only 18 months old. Please advise what I should do. I’m in the UK. 

Hello, I am suddenly having this issue with my gen1 Nest hub. I went into recovery mode and did a factory reset but it still just goes back to the grey screen with the G logo.

Could I get some help with this? Is the hub just dead already?

Community Member

Same problem G screen after factory reset. How do I get a case number.

Community Member

Alright. SOLVED.

I had exactly the same issue, with a G logo frozen on my Nest Hub. I tried rebooting it and that didnt help. Then, I tried rebooting again... a second time... And that worked. 

So, I assume, one might have to try rebooting a few times to get it to work. I probably got lucky with 2 times.

Hope this helps.



Was this issue ever fixed as the exact same thing has happened to my best hub last night.  I have tried everything and still stuck on the grey screen with a white G 

Was a solution found for this problem as my hub has been like this since Monday?? 

Community Member
  • Im in the same situation. My google next is frozen on the black G screen. Recovery and reset doesn’t work 

Community Member

My Nest Thermostate E is doing this as well. Installed a week ago and worked fine until a couple days ago. Disconnected from wifi and now is stuck on Google reboot screen and blinking green light. I charge it with usb and it may come on but doesnt last

Community Member

Link up with google chat. Go though process and they will send you a new one. It took around an hour so set some time aside… good luck

Community Member

Hi Frances!
I have the same problem. I made a factory reset several times, but nothing changed. De you have any idea what can I do?

Community Member


My case number is 1-6059000031755. I was dealing with Kevin who was very helpful in giving suggestions to fix. Then he asked for a video and I haven’t heard anything since. Is there an update on this known issue yet please?

Community Member


I am having the same issue as everyone.  I have tried contacting the support using the link you have provided above and it is not working. Is there another way to contact support for assistance?

Stop posting here...there is no solution.  Google bricked these and may send a replacement unless you only have a Po box. This fix won't work ever

Hi Frances, I have exactly the same issue. Could I have a support number too please?

I can enter the device into recovery mode, but on restart it always returns to the white "G" with a gray background, and shows that indefinitely.

This is still not working stuck on g screen. Your Google Support Inquiry: Case ID [9-7390000032353] still waiting for a tech for next steps. Now going on 3 weeks when they said 24 to 48 hrs. 

Mine has gone on for

more than 3 months. Case ID, google chat, google support, photos etc. still not ready to replace.

Hello i have the same issue everyone is reporting. How can I fix this? I have tried the reset and everything but continues to stay on g. Please advise 

Community Member

I am also impacted by this issue, owned the hub mini for about a year and it won't get past the boot up screen (black background and white G logo) even after numerous attempts to factory reset - started happening a few days ago. What is Google doing to fix this?  I have over 15 Google hardware products throughout my home.  Very disappointing 

Thanks for appearing to be proactive and trying to help- please add me to the growing list of people who's product used to work until the update bricked it. If I can't get this replaced by Google, I'll be scrapping all the google hardware in the house and moving over to Amazon products. 


Frankly Google home has been completely unreliable for months as far as multiroom music goes with constant freezing, disconnects, and flat out not playing at all.

And scrapping the number of devices I have dedicated to music and video is an unpleasant thought, I spent a fortune on your hardware, but this last device failure might be my breaking point.






I have the same issue

Community Member

I have the same problem. 

Community Member

Also have the same issue - trying to open a case but doesn't give contact options.

Community Member

Hi, okay so mine is doing the same thing. Can we have a solution for this posted somewhere easier to find?

Community Member

I have this same issue, tried everything and still bricked