Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Hub stuck on grey ‘g’ screen, factory reset not helped

Community Member

Hub stuck on g screen factory reset brings it back to g screen. Power off overnight, no change. 

1 Recommended Answer

Community Specialist
Community Specialist

Hey folks,


Thanks for sharing all the details about the issue. 


We understand this issue has been happening for quite some time now, but rest assured that our team is aware of this and looking into this issue at hand. Please try to plug in the device to a different power outlet, then attempt a reset.


If unresolved, perform the workaround below:


  1. At the back of the Nest display, unplug the power cord and wait for 10 seconds, then plug it back in and wait until the screen with the "G" logo shows up
  2. Repeat the first step, 10 more times.
  3. After the customer plugs the power cord back in, wait for the device to reset. The device announces "Welcome to Google Home" to signify that it's ready for setup.

Put your device to recovery mode:


  1. Put the device in Recovery Mode (Unplug the device, then perform a long press on the volume up and volume down buttons while the customer plugs the device back in. Once the device turns back on, release the volume buttons.)
  2. Once the device boots into Recovery Mode (a long press on both volume up and volume down buttons at the same time), attempt a factory reset.


If the above steps don't work, please reach out to us to get immediate support on this link:




View Recommended Answer in original post

1,523 REPLIES 1,523

Community Member

This worked for me, the update Google pushed, bricked Generation 1 Nest Hubs. I requested a call and sent in the necessary documentation via email. 

My nest home hub is stuck in a loop. It was working fine one day the next it was on a grey screen with a white "G" logo. I have tried the unplug wait 10 seconds and plug in 11 times method and the recovery to factory reset method. Nothing helps. Now whenever I restart the device it goes to recovery mode without any user input. Holding Factory Reset for 10 seconds makes the device reboot to grey screen with "G" then it goes straight into recovery again. I am not touching anything when it is rebooting. I even attempted leaving it unplugged for 48 hours. As soon as I plug it in (no user input besides power cord provided with unit) it goes straight back to "G" followed by recovery. Please advise.

Community Member

my google hub will not boot. It remains on a gray screen displaying the white google G in the center of screen. Resetting by holding the up and down volume buttons doesn’t work. Unplugging for a period of time and re plugging won’t work. The device doesn’t seem to be connected to my google home app on my phone. Can you please help me figure out why it no longer is functioning?

Community Member

So have any of these case numbers been resolved or is Google still not fixing their products?

Community Member

They’ll replace it! 

Is there a fix for this?  I've tried the factory reset several times and it's still stuck on the grey screen with "G" on it. 

Community Member

No fix, contact customer support. They’ll replace it!

Community Member

I had to go to Google nest support and contact them through the chat function. I explained the issue they walked me through their troubleshooting then had me submit information and as I was told they are replacing my gen 1 with a gen 2 device because they are out of stock. I explained to them I didn't have a receipt because it was a gift. 

Community Member

Awesome and thanks!  I'm on the phone with Google now.  I also don't have the receipt...  Hopefully, they will send me a replacement.  

Community Member

some of us have been awfully patient and case ID has been for 3 months. Google support is a huge disappointment. Please give your kudos here so we can track all those that Google just refuse to do anything although we all know if was an update issue with Google!

Community Member

I am having the same issue.  I am on hold with customer support now.  I have tried powering off the unit by unplugging it (5 times), trying a factory reset by holding the volume buttons, and doing the same reset while unplugging it and plugging it back in.  In those instances I get the factory reset screen but it then goes directly back to the gray screen with the "G" on it with no other response.  Appears to be completely bricked.

FYI, I just finished with Jay in customer support and they are sending me a new unit.  No workaround worked for me.  Contact the support team.

Cannot get to a form keeps bringing me to this post

Mine had also done this now. 

hi Frances,
Can you add me to the list of people that have this issue please and open a case for me too please.

Community Member

Hi frances,

Unfortunately I am having the same issue too, but your link to the form doesn't seem to provide me with the correct support. How do I go about getting help for this?

Thanks in advance!

Community Member



I have tried the reset procedure. It brings the display back to g screen. 

Please help.

Thank you.

Hi Frances,


I recently encountered the same issue. I already tried every suggestions in the thread but had no luck. 

could you help to create a cast for me and associate the case with email #########

thank you!

Hi Frances, 

I'm also experiencing the same problem. I've already tried to reset it and it went back to the G screen. What else can I do?

Did you get an answer to your problem? I have the same issue exactly.

Is there any solution so far. My Nest Hub turned into a brick too. Factory reset is not working either

Community Member

I am having same issues with my home hub. Stuck on screen with g. I tried to restart and still stuck on same screen. Did factory reset and still got same screen then another screen came up saying recovery mode- hold both volume buttons to do factory reset. I did that again and same screen keeps coming up to do factory reset and it is now stuck on that screen no matter what I do.

Community Member

Is this current info. 1/22/2022.  I have a gray screen with the”G” on it. Turned it off, turned it on and the same Gray screen with “G”.

Community Member

Not happy with the solution network. I see a thread from October2021. Do not see any solution for GrayScreen with a “G” .

Did they ever came up with a solution to this?  I can't find it in the thread 

Community Member

I've got the same issue. The trigger for the "Gray screen of death" on my hub was simply by evoking "forget network" through the Google home app. This bricked mine. I wanted to swap to 5ghz wifi. Never been able to"trigger it by doing the 11 point Google suggested dance" Just Bull.

It's stuffed because Google introduced dodgy code, and snuffed mine out.

Android 12. Pixel 3. 

Dead hub. Barely lasted just over a year.

Community Member

I am experiencing the same issue. My google home hub is stuck on the grey g loading screen. Factory reset did not resolve the issue. Can someone please assist?

Community Member


im not able to get in touch with the support team. i got always errors when using the support tool. And the given number is not reachable.

Im completely lost, i have a google nest hub which is bricked by itself and there is no way to reach the google support. 

Would be nice to get some help.





im also experiencing the same problem. Can you advise? Also your link to the support team doesnt work. Constant loop

How do I contact Google to report this same problem

Hi Frances.

I’m having the exact same issue reported to my Google Nest Hub that was purchased in November 2020.  Could you kindly open a case file for me, so I can provide more detail information about my unit. My email account is #########

Thank you so much for your help

Community Member

Hi, I'm having the same issue, I see the response was on January 05, has anyone solved it?

Community Member

We're having the same issue with our Google Home.  Resetting has not helped.  It's not even that old.  Hopefully they come up with a solution. 

Mine is also stuck on 

Having the same issue after following the steps to recover by pressing the volume down key when plugging the power. 

The recovery completed but still stuck at the G grey sceen 


And noticed by sceen been showing distortions too

Community Member

I am having the same issue with my nest hub. All grey screen after factory reset.