Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Most of my LIFX lights are not responding to my home device

Community Specialist
Community Specialist

Disclaimer: This thread was migrated from our previous version of the Google Nest Community. You can continue to receive updates on your thread issue here or simply ask, browse or more in the new Google Nest Community.

Original poster: Phillip Barr 


Yesterday most of my LIFX bulbs stopped working with my Home/Nest Assistant. When I say turn on the lights in my bedroom or living room, only one light will turn on or off. If I try to control the lights in a group from the Home app only one light responds. However that light is a different one than the one that'll respond to my voice. If I use the names for the devices they respond to the assistant. 
I have unlinked my devices from my account and re-linked them; this didn't fix the issue. I have plugged and unplugged my devices and this also didn't fix the issue. 
This problem has come out of nowhere. I haven't changed anything with my home set up in months. When I have a day off I'm going to try some more solutions. I'd really like some advice though.

Community Member

I am also having the same issue.  I rebooted all my google home devices.  I rebooted my wifi.  I unlinked and relinked my lifx, and nothing has worked.  I have 35 lifx lights, so it's getting frustrating.   

They work fine with the lifx app, and alexa, just not google home.  

Also, if I refer to each individual light with google they will work, it is only when trying to control a room or group that they are not responding correctly.

Community Specialist
Community Specialist

Hey there, 

Just wanted to hop in here to see if we still needed help on this. I have sent this information over to our engineering team and they ask that you provide them feedback through the Google Home app to them. They suggest including the keywords, "#Lights" along with the name brand of the lights and a short description of what you're encountering.


Have a great day. 

Garrett DS

I have resolved this issue.  I placed a call to Google technical support, and I provided them with a support code that allowed them access to my home app.  I don't know what they did, but after they were logged in, it all started working correctly.   I don't know if the other people having this issue have resolved it, but the call to Google fixed it for me.

Community Specialist
Community Specialist

Hey folks,
It looks like we have come to a solution so I'm going to be locking this thread. If you have any other concerns or questions, please feel free to create a new thread.

Have a great day.
Garrett DS

Community Member

This problem surfaced last week with my lifx lights, most of the lights in my home are lifx so this thing is annoying everyone. I've tried all of the steps Darkmanbt tried with the same result (nothing changed). I also have SmartHome lights and switches which use the Brillant Smart App, air purifier and air con and they all still work with Google voice commands. It looks as if there's compatibility issue between the Lifx service and google home. Question: When was the last update or change to either service?  

Community Member

I have 3 LIFX Bulbs in a ceiling fixture in my family room. They are grouped as "family room". All were being controlled just fine by voice (Google Home) or on the Google Home app.

2 days ago the connection stopped working. When I asked GH to turn off the lights, only ONE of the 3 bulbs turned off and the GH said "Sorry it appears that 2 lights are not available". Same behavior if I tried to turn ON the lights - only 1 bulb turned on and I got the same message that 2 lights were not available.

I have tried everything I know to get them back working as a trio. I have power cycled them, reset them, forced the app to stop and start, unlinked and re-linked my LIFX account to Home, uninstalled the LIFX app and re-installed, rebooted the router, rebooted the Google Home, checked in my router's connection setting to verify that all 3 bulbs are showing up as individual connections.

In the LIFX app, I can control them as a group or one by one. In the Google Home app I can control them one by one. Even by voice command to Google Home I can turn on or off EACH light on its own (e.g. "turn on Family 1" , or "turn off Family 2" etc.), but as soon as I issue a voice command to "turn lights on" or "turn lights off" (all of which WORKED FINE UNTIL 2 DAYS AGO), I get the same behavior that 2 lights are not available.

Even in the Google Home app, if I go to Family Room, there is a grouping shown of all 3 lights but if I try to turn them off all at once, only 1 or sometimes 2 turns off.

Bottom line is that I can control them 1 by 1, but cannot control the group other than via the LIFX app itself. I cannot turn on or off the 3 lights in tandem either in the Google Home App or by Google Home Assistant by voice.

But all worked fine for MONTHS until 2 days ago. No changes made to my setup or system.

I am experiencing the same!

Community Specialist
Community Specialist

Hey there,

I understand that issues with lights and the Home app can be confusing but I definitely wanted to stop by and see how I could help. 


Just wanted to double check to see if you were still needing help on this? If so, what troubleshooting steps have you tried? 


Please let me know. 


Best regards, 

Garrett DS

Thanks for the reply, and for moving this to a more appropriate thread. It is/is not comforting to know others are experiencing the same issue(s). 

The various steps I tried are all explained above.

I did send a support ticket to LIFX and got this reply a couple of days ago:

"Thank you for contacting LIFX Support. Sorry to hear that you are having problems with our LIFX light's.

We are aware of the issue and seems that multiple customers are affected. Can you try and configure them as a single scene and then to start that scene and to turn off the scene? We are working on resolving this issue completely but try to use this as a temporary solution."

I was about to try the Scene suggestion as requested when, just as suddenly as the problem started, the problem went away. It was broken for a couple of days, but for now, all is working as it should. No idea what the remedy was, or if LIFX did indeed figure it out at their end, but no matter - it works again....   for now....


Community Member

I have been having the same issue for about a week. I have 15 lighting devices consisting of 2 Kasa light switches, 5 IIKEA lights/drivers and 8 LIFX lights. 

The issue occurs when I am trying to verbally command a group of lights. For example, when I say Turn Off the living room lights it will generally turn off one of the three LIFX lights and then tell me two devices are not connected. 
if I voice command each device individually, they work fine. Even right after it tells me that they are not connected from a group command. 

I have tried all of the troubleshooting steps described above with no success 


What is really frustrating is the rare instance when they work like normal and I think whatever communication issue Google and LIFX are having is fixed. But alas, the very next moment when I try again, I get the devices not connected message. 

This is only occurring with my LIFX items. The Kasa and IKEA items work just fine. 

Also, using the Google Home App on my iOS device works okay. Even for groups. 


There seems to be a communication issue from the Nest Speakers interface at Google and with LIFX. 

I have invested in the Google Home system and have been very pleased with the years I have been using…until lately. 

I am dreading a call to Google Nest Support on this issue. 

LIFX support has told me that a) this has affected many customers and b) they were working on it. Today they said there did indeed seem to be a server communication problem that they felt was resolved now.

My lights are back to normal - not via any my interventions I don't think - but via whatever they did/are doing. So my best guess is that this indeed is not a Google/Google Home problem per se, but a LIFX server issue that they are aware of and say they have fixed. If your problem persists, one of the temporary workarounds they suggested to me was to put the room light grouping as a Scene and see if you can command the lights on and off with the scene commands. I never tried this since my lights came back to normal 2 days ago.

Mine worked for a hot second and then stopped again. Same problem as described here. Works in Google assistant app and lifx app but can not get my google home or google nest devices to work by voice for anything.