Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest app will no longer retain custom room creation or device assignment

Community Member

I have had our Nest devices for a number of years. Earlier this week, I decided to rename our Master bedroom to Primary bedroom, as a new custom room. Once I did this and began to assign devices to the room, the room itself disappeared, and all custom rooms (we had roughly 10) disappeared, leaving all associated devices with no room nor label.

I have made repeated attempts to create the custom rooms again, and as I assign the first device to it, it will remove the assignment and the custom room will no longer exist. I've tried this with Nest temperature sensors, Nest Protect, and Nest Connect. I've tried completely removing the impacted devices and starting over, but within a couple of minutes of adding the device and creating, and assigning the device to the room, the room disappears and I have a device floating out there. 


The Google Home app seems fine, and I rarely, if ever use it, so the culprit seems to be the Nest app, which I've uninstalled and reinstalled and tried on numerous devices.


Why can't I create custom rooms and assign devices to them? Short of deleting my home and all 50 devices (which I will not consider, as some are cameras installed high up on the eaves of our second story), how can this be fixed?