Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

nest app crashes adding nest protect

Community Specialist
Community Specialist

Disclaimer: This thread was migrated from our previous version of the Google Nest Community. You can continue to receive updates on your thread issue here or simply ask, browse or more in the new Google Nest Community.

Original Poster:  Kenneth Philbrick 


My nest protects we’re previously working and suddenly stopped seeing the google WiFi that they have been seeing for the last year.  I did a factory reset of the device and then attempted to re-add them to the app. Nest app crashes after attempting to added nest protect to the app.  I select add device, scan the QR code for the nest protect.  Select the room. And, then the best app instantly dies. I have deleted and reinstalled the app multiple times.  Help!


Community Member

I am having the same issue adding a 2nd protect to the app.  Scan QR code, then the app crashes.  Same thing over and over.   Reset phone, reset protects.  I can add any protect I have as long as it is the first one.   If it is the second one, it crashes.   

IOS version 14.7.1 

Fresh install of the app.  

Community Member

I too am having this issue. I reset two protects and attempted to re-add them; however, the app crashes while communicated with the assisting device (located about 5 feet away) and it has to be teriminated. I have tried on both the iPhone and iPad apps, with the same results. iPhone on 14.7.1 (same for iPad)

Community Member

Per tech support (I spent quite a bit of time online today), this is a known bug with IOS devices and engineering is working on a fix. 

Any updates on this crash issue?

We are experiencing the same problem: add > scan > select room > CRASH

Very frustrating and unsafe.

Solved for me. Our modem has two bandwidth networks on it. The Nest Protect want to use the slower network. When setting up the App it was important to default to the same. Six connected smokes running well.

Community Member

For me the fix was a GUI issue, there is a delay after selecting the device to add (no app feedback - so you think the device did not get selected); however, a second selection will cause the crash. Select it only once, wait (it took about 30 seconds as I recall). I was able to get both back online

Community Member

I was adding 5 Nest Protects and the app was crashing. This worked for me.... Only touch the name of the location for the device once. For some reason the check mark does not come up, but it still works with the chosen name. I then received a message that I was not close enough to my nest thermostat. I moved near the thermostat and the device connected. After moving close to the thermostat with all devices, they all connected.