cancel
Showing results for 
Search instead for 
Did you mean: 

Nest Cam (Battery). "Something went wrong" can't install

VBScrapper
Community Member

Can someone please explain to me what I'm doing wrong? I recently purchased the Nest Cam (Battery) for outdoors.  I get through all of the screens and then it says "finishing up".  After 5 minutes, I get an error message "Something went wrong." Try connecting again.  If that doesn't work, try rebooting your device or turning your phone's airplane mode on and off before trying again.

I've tried all of this.  I also tried setting up a new "home".  Nothing is working for me to get my camera installed onto my network.

Please send help!!!

5 ACCEPTED SOLUTIONS

weberj13
Community Member

if you still are having issues. when i was doing the setup mainly i couldnt get the blue light to come on like it said before you could continue. i did and would always get the error. i found out if you hold the reset button for about 10 seconds it will flash yellow and make a noise. after that try to setup. dont plug in until prompted. you will get a different noise with the white light and right away the blue light will come on once the chime stops. continue setup and it works.

 

hope this helps

View solution in original post

Just worked.  Folks on IOS / Iphone, ensure your iphone is updated.  

View solution in original post

FrankO
Community Member

I had the issue for weeks. With help from google, I restarted the cam with the little button on the back of the cam, for more than 12 seconds. (I tried 10...) then a sound and a blue light and I was able to install. Not using the QR code but the code on the device.
I hope this works for you too... 

View solution in original post

Lucahalma
Community Member

What worked for me is creating a new home with only the doorbell in there and then adding all of your devices again. 

(Nest Doorbell battery, IPhone 12 Mini)

View solution in original post

Benchaco
Community Member

Had similar issue with setting up one of the three cameras. Instead of scanning QR code I opted to type in the 6 digit code which is printed on the camera. It worked fine.  

Reset the camera by pressing the small button at the back for 12 seconds or so until you hear a chime

Do not plug it in until you are asked to do so during setup.

View solution in original post

66 REPLIES 66

FrankO
Community Member

I have the same problem. Google send me a new cam. Still the same problem. So it is not the cam. Am using iPhone 11 max pro. Other cams (indoor) and google products have no problems. 

mzentell
Community Member

Same problem with me. iPhone 12.

Just finished setting up a Nest Doorbell. Started on Nest Cam Battery set up and install. All fine until the very end of the connection setup, the the "Something Went Wrong" message. I'm wondering if it's a power issue and the camera has to charge first, but there is no indication or thread that indicates that may be true.

Sure would be nice if Google added an 800 number

CNAX
Community Member

Same problem. I have 8 NestCams and this is my first time buying a battery cam for a new house. This thing is NOT setting up!  I can’t find anything online. GOOGLE - post troubleshooting steps in an online knowledge base so we can look it up and not tie up your phone lines!

Maverick262
Community Member

I’m having the same problem.  Any fix yet ?  I have another nest camera and it works great.   I get the same error you do 

 

Brad
Community Specialist
Community Specialist

Hi there, 

 

I apologize for my late response and thank you for all of your patience while waiting for a reply. I can definitely understand how frustrating your situation must be, but I wanted to make sure that your issue was addressed. Do you still need help with this issue? I know that there's been a delay in response since you posted.

 

Please let me know if you need further assistance. 

Best Regards, 

Brad.

CNAX
Community Member

Brad,

No the issue remains unresolved - I actually own about 20 Nest cam products and have never had this happen before.  No offense but it seems the product team responsible for the Battery Cam released what should have been a Beta to the public before the product was QCd.  I am about to leave town and need this hooked up ASAP - was on the phone with tech support for 1 hour, 6 minutes today - agent could not figure out how to help.  Supervisor was "in a meeting" and rep said supervisor would call back shortly.  That hasn't happened either.  My phone number is in your CRM - if you can call me and resolve, that would be great.

Same here. Just installed two cameras. Considerably through the process, shows as connected, Google Home shows the devices but they can't "Finish setup." Have Nest Wifi router, points, indoor cameras, thermostat and have never had this issue. 

I'm sure we're like others who bought these for holiday security. Please expedite this topic.

Kyleshumway
Community Member

Dude we all still need help. Help us. 

Brad none of us can setup our new Google Cams... I thought your response Monday was weak "Do you still need help?"  Of course we do no one has posed they have received a solution Uggg... 

 

rrudary
Community Member

Yes, I need help with this issue. I can’t finish installation without it saying “something went wrong”. 

Krishyadav
Community Member

I am having same problem here. Tired of trying many times. Do I need to return my doorbell? 

Kyleshumway
Community Member

Same problem here. “Something went wrong. Setup is taking longer than expected.” On loop. 

Yakinvasion
Community Member

Same issue as described above. Two new nest cameras (battery), unable to complete the setup and have a looping error message that states "Getting Device Ready" "something went wrong, setup is taking longer than expected" without an error code. Device shows up in google home app, but I am unable to access any features until setup is complete. 

Attempted to remove the device from google home, reboot, and factory reset. Have also opened ports 11095 on my router in a last ditch effort to resolve the issue. 

https://www.googlenestcommunity.com/t5/Cameras-and-Doorbells/Nest-Doorbell-battery-fails-on-setup/m-...

Going to borrow an android phone from a friend to see if the issue is with the iOS app. 

Attempted the setup on an iphone X, and iphone 13pro both running the most up to date version of the google home app, 2.47.111

Assuming this is a software bug or server side issue. 

To everyone on iOS, this is a google home app software bug. I attempted on two versions of iOS with two separate devices, both of which failed. I just attempted with my friends old android phone and was able to successfully complete the setup on the first attempt. 

Brad
Community Specialist
Community Specialist

Hey folks.

 

Apparently this is a much bigger issue than I had anticipated. I am sorry to hear that many are experiencing the same issue. While we are still looking into this issue, if you have an iOS device, ir may or may not work. Please try to use a different device t try to set it up and see if it works for you. I understand this is an inconvenience, and I fully would feel the same way if I were in your shoes. However, this is still being looked into, so I do not have any fix at this time. Thank you for your patience, and please share your results for steps you have taken that have worked,.

 

Best regards,

Brad.

ucftim
Community Member

Same expect boat with Nest Battery Camera. Extremely Frustrating...

nigelboot
Community Member

Exactly the same problem here, 2 brand new cameras, all the way to the end of the set up then "Something went wrong" . Setting up on iPhone XR. PLEASE HELP!!!

kpaonline
Community Member

2 x Nest Battery Cams, bought today.  Same issue on both...

I can confirm the setup completes on Android, but not my iPhone.

Genuine0strich
Community Member

Same here. So frustrating 

mayrockcreech
Community Member

So seems like we are getting alerts and the cameras are functioning but still no way to "Finish" or control the cameras through the app. Seems like Google Home app or software issue.

Same. I've gotten push notifications from camera to my phone that it's seen a person (me, frustrated at the kitchen table), but I'm unable to do anything with the camera inside the app aside from attempting to finish the setup, or remove the device. 

Is everyone who is experiencing this problem attempting setup with and iOS device?

I am having the exact same issues as everyone else, can’t set up battery cameras OR doorbell. Yes, I’m running IOS device too! 

I just attempted with my friends old android phone and was able to successfully complete the setup. 

Yes, iOS. iPhone Xs 14.8.1

In a different thread about the same issue, someone said they were having the same problem and using IOS so switched to using an android device for set up and had no issues. Seems like it may be an IOS issue… 😞 

Can you link to that thread? Does anyone there offer suggestions for those of us that don't have an android in the house?

 

mayrockcreech
Community Member

So just installed a 3rd camera, this one Wired w/Floodlight. Same issue. Beeps, says "connected" but fails at the final "Finish Here they sit in limbo.Here they sit in limbo.setup."

I was able to fully set up my cameras and doorbell in the IOS app. Just started working abruptly. Try it again if you haven’t! 

Cmevans859
Community Member

Also having the same issue with iOS. Bought a 2 pack of Battery Cams and only one successfully set up but the other will not. 

Mk89
Community Member

Same issue here. I set up one weeks ago, the other will not work.  Same error message everyone else is getting. 

Dblum
Community Member

Same issue here, I setup one 3 weeks ago at the beach house and now it will not go through.  Seems it has been the update that corrupted the code for setup. I have done restart and factory reset just to make sure, but its the app.

Aswell
Community Member

Same issue here with brand new doorbell battery camera.

hugeheadfish
Community Member

Same issue here with newly bought cameras with battery. Twin package

Mine just works today. Setup both of mine.

 

reset after 10+ sec works for me today. ( it didn’t yesterday)

KaraB
Community Member

Well the IOS app inexplicably started working! I have successfully set up both my cameras and my doorbell. I encourage everyone who was having issues before in the IOS Google Home app to try again!

GoogleCamUser
Community Member

Me too!! re Hi I just went back and tried Finishing the install and It worked on my Iphone - They must of fixed it - So try again 🙂