Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest App doesn't work anymore

Community Member

i have two android devices

both with Nest App.

one of them (my phone) won't load the nest cameras anymore, the view is stuck on the loading circle and black screen.

Until a week ago it worked like a charm, and now not anymore, and I can't find online any solution to this.

I've restarted phone, cleared Nest cache, reinstalled the app, made sure Location is on for Nest App.

I don't understand why it would not load any of the 3 cameras that I have.


Any good advice?

Internet connection is 1GBit U/D so that's not the problem as well, both devices are under same network.


1 Recommended Answer

Community Member


The Nest app have just lauch a new update in Google Play, the Nest works now 😊👍

View Recommended Answer in original post


Community Specialist
Community Specialist

Hi Decaone,

Thanks for your efforts here. I’m sorry you’re still having trouble with this. No worries, we’ll sort this out — a few questions: is your Android version up to date? When did you first notice the issue? What’s the make model of your Android device? Were there any changes to your Wi-Fi network? Also, what are the status lights of your cameras?


Here are some troubleshooting steps you can try:


  • Check for software updates on your phone. Obsolete OS versions may break some app functionality.
  • Switch your connection from Wi-Fi to cellular data.
  • Restart your phone. Turn it off for 60 seconds. Then, turn it on.
  • Restart your router or modem. Unplug it from the power outlet, wait for 60 seconds. Then, plug it back in.
  • Try another device if your Nest app works with no issues.

Let me know how it goes.




Hello Jan, 

I've done all of the above already. Standard IT procedure, after all 🙂

The phone is up to date, no issues in that. The system was working and randomly stopped a couple weeks ago, one week before my report. 

No updates / upgrades in the meanwhile so there would not be the need for it to not work anymore.

Besides, I did notice one thing: I have Google Home in my house, and more or less at the same time of this problem, another occurred: Google cannot change anymore the temperature of the heating devices, and if I enter in the device's section in Google Home App, there's only the On/Off button.

And this happened at the same time that Nest wouldn't show anymore the cameras in the main view (only I can see them when entering in the camera)

Are we sure there wasn't any update on Google's side and something bad happened, since on customer's side there was no update at all?


Thank  you for your time.


Community Member


The Nest app have just lauch a new update in Google Play, the Nest works now 😊👍

Community Member

that fixed! thanks!

Now onto Google Home Support... xD


Best, and happy festivity!


Community Specialist
Community Specialist

Hi everyone,


Thanks for getting back to us and we're glad that it's resolved now. It looks like we can consider this one complete. Please let me know if you have other questions or concerns as I will be locking this after 24 hours. Feel free to start a new thread and we'll be happy to help.

I appreciate the help, JT.




Community Member


I have 8 cameraes  and have the samme issue. The Nest app won't view all cameraes simultaneously. I am able to enter / view each camera alone by entering it. I have tried to delete buffer, reinstall Nest app, reboot modem...I am still stuck!