Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Error code P030 Cannot continue setup of device

Community Member

I am getting error code P030 which doesn't exist anywhere.  

Steps I have done

1) restarted my router

2) restarted my iphone

3) Reset the nest protect by holding the button down until it asks to erase itself

4) Tried three different wifi netwroks

5) I tried directly connecting to the nest connect using my wifi


I get the same error code each time P030


Community Member

I have exactly the same error too. Wasting my whole day on trying to get 2 of these things to work and NOTHING works.  Of course there is nothing officially stated regarding a P030 error any debugging log that a user can access. Tried Chromebook and iOS and the result is the same.

Community Member

Hi there, I had exactly the same thing when I got a new broadband router and the network and password changed. To cut a very long and frustrating story short, the root cause of the problem (I think !!) was my mobile (cellphone) virus protection was interfering with the app changing Wi-Fi settings which happens as part of the setup. I disabled all of the Virus protect stuff on my phone, and got the Nest Protect added to my Nest account. It did fail once with another code but tried again and it worked.

Hope this works for you.

Community Specialist
Community Specialist

Hi there, 


I apologize for my late response and thank you for all of your patience while waiting for a reply. I can definitely understand how frustrating your situation must be, but I wanted to make sure that your issue was addressed. Do you still need help with this issue? I know that there's been a delay in response since you posted.


Please let me know if you need further assistance. 

Best Regards, 


Community Member

Yes, the issue is resolved. I had to remove the other (expired) Nest Protects from the system before the new ones would work.


Thanks Brad.

Community Member

Hi Brad,


What was the resolution to the P030 error as I am trying to install a new NEST alarm from my IOS device and none of the trouble shooting steps are working that the original poster of this post suggested. Thanks