Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest Protect P009 Error Cannot Add To Account

Community Member

Come on Google...

I purchased 5x of these units in 2019.


We bought a new Wifi router and turned off the old one.  All I needed to do was change the Wifi password, and now all the units are essentially bricked.  Literally 20+ smart home products had zero issues joining the new wifi network, yet Nest Protect is complete broken.  Thanks!


I've done ALL the P009 troubleshooting steps.  5x times.  Tried multiple phones for setup.  Same error every time. 

I've confirmed they're only connecting to a 2.4GHZ network, IPV6 too.

I'm about to throw these in the trash and send Google an invoice for my time.

Your app told me to remove the Protects from my account and re-add them if I don't have the old Wifi available.  BIG MISTAKE.


I've tried adding all of them so many times, and there's no luck.

What's the trick?  I can't describe how frustrated I am.  

Rest assured, I will cancel YoutubeTV, Youtube Premium and Google will never get another $ from me.


Community Member

I encountered the same problem with my Nest Protect, after changing ISP.  All Google devices required factory reset.  All nest devices reconnected to account EXCEPT Nest Protect.  I cannot say how frustrating an experience it was for about 3 hours of my time. Different procedures for different devices, all supposedly Google devices.  As it stands, with the Nest App am able to set up Nest Protect, including new wifi, but it fails to add device to my nest account, even though the device no longer is shown on my Nest App.  Was able to modify thermostat wifi settings as well as nest doorbell cam, but the protect would not work and required factory reset, after removing from Nest Home using app.  BTW, all Google Home and minis required factory reset and readd just to modify the wifi.  When I move from this house I will not purchase another google product again.  

Community Member

I had the P009 error when trying to install three Nest Protects to my network.  Called Nest for help and they insisted that I needed to create a second "Home" for the Protects.  I did that and was able to install, but the inconvenience of having two Homes in the Nest amd Google Home apps was very annoying - a new one with the Protects and my original with my Nest Hello doorbell and all my other devices.  I had to switch Homes every time I wanted to see the doorbell camera or silence a Protect.

I then saw another thread that suggested the problem was caused by an incompatibility between the Nest doorbell and the Protects.  As this thread recommended, I uninstalled my Nest doorbell and was then able to add the Protects.  Once they were installed, I was able to reinstall the Nest doorbell and both are now working in the same Home.

Nest support never suggested this problem or solution, only the very inconvenient use of a second Home.  Also, as is always the case with Nest (or Google) support, they started by claiming my WiFi router was at fault (my Nest Pro WiFi router that is) wasting about 20 minutes down that path.

THANK YOU, Boulder J. I have spent two days trying every conceivable way to get my Nest Protect to connect. I kept getting the POO9 error code. Today, I went to the Community and saw your post. Delete the doorbell and the Protects will connect. It worked! Don't know how you figured it out, but much appreciated. 


Thank you!!! I was upset and about to return this.  Glad I read your post because I was able to successfully add my product by creating another “home”.  

Did you see my post above with a solution that does not reqire a second Home?

Community Member

@BoulderJ - I can't thank you enough!  I've been having the exact same problem and I was at my whit's end!  Disconnecting the doorbell from the iOS App and then reinstalling after the Nest Protects solved the issue!

Community Specialist
Community Specialist

Hi everyone, 


I'm glad to hear that everything has been sorted out. 


@UnhappyNestUser, I hope you already get the answer you're looking for. Please let us know if you still have questions or concerns, as we'll be willing to assist you further.


All thanks for your help, @BoulderJ




Community Member

I tried uninstalling my doorbell and am still unable to add my nest protects. 

Community Specialist
Community Specialist

Hey folks,


@jsassoon, thanks for reaching out. To know more about your issue, I'd like to confirm, have you factory reset your Nest Protect? Try checking your firewall settings if there's a setting that would restrict your Nest Protect to connect. Hit this link for more information.


To reset:

  1. Press and hold your Protect’s button. It will chime and glow blue. Continue holding the button down.
  2. Release the button when your Protect starts to say its version number.
  3. Your Protect will start a verbal countdown and tell you it’s erasing all your settings.
    1. To cancel the factory reset, press Protect’s button again during the countdown. 
  4. After a few seconds your Protect will reset to its factory default settings. You can then go through setup with the app and add it to an account again.

Looking forward to your response.


I appreciate the help, Zoe and BoulderJ.




Community Specialist
Community Specialist

Hi jsassoon,

I'm dropping by to ensure that everything is covered here. How's it going with your Nest Protect? We would appreciate it if you could share the information I’m asking above. Also, were you able to perform the steps I’m suggesting? We'd be glad to hear from you.


Community Specialist
Community Specialist

Hello jsassoon,

Just one final check in here since activity has slowed down. We'll be locking the thread in the next 24 hours, but if you still need help, we would be happy to keep it open. If there's more we can do, just let us know.