Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest protect will not connect. Error p030.

Community Member

I have been through all the things that other people on this have suggested. Restarted router, restarted phone,  reset protect, turned off mobile data on phone,  tried with husbands apple as well as my android. I have also deleted my thermostat and 2 cameras from my net app and its still will not connect.  (And that's a massive ball ache to re add everything now). 

Really really unhappy.  These aren't cheap and I bought 2. Expensive looking bricks at the moment.  I am adding through the nest app as Google home told me to.  Only thing I haven't done is delete every single Google mini and hub from my account because I can't face the disappointment of it still not working then me having to add everything back in.  Shouldn't have to do that.  There should be an option to add without using another nest product to assist - because clearly that doesn't work.

What do I do now?


Community Member

So I have now deleted every Google device from my home and its STILL says product assisting and will not connect.  I am at the end of my rope.  How can any products be assisting if I have removed them from my home. I have also switched off power to them. I could cry.

Is anyone out there able to help please? 

Community Specialist
Community Specialist

Hello Shelvis,


I'm sorry to hear about your experience on your Nest Protect. I know you did a lot of troubleshooting to resolve this issue. There are still some steps that you can do to pair your Nest Protect back to the Nest App. Also don’t forget that the Nest Protect can only connect to the 2.4Ghz bandwidth of the internet.

Give these steps a try:

  1. Quit and restart the Nest app or Google Home app.
  2. Restart phone or tablet.
  3. Make sure the assisting device is awake and within pairing distance (maximum of 2 to 3 meters).
  4. Restart the assisting product (Example: the Nest Connect when pairing a Nest × Yale Lock).
  5. Put the mobile device or tablet on Airplane mode, then turn on Bluetooth and Wi-Fi.
  6. Try a different mobile device or tablet.
  7. Restart the network equipment (router, extender, or modem).
  8. For Nest × Yale Lock only: Verify that the cable from the keypad is seated securely.
  9. For devices that use Thread networks, enable Internet Protocol version 6 (IPv6).
  10. Reset the joining device to defaults.
  11. Try to manually enter the entry key instead of scanning.
  12. Test with a mobile hotspot.
  13. For Nest × Yale Lock only: Remove the batteries from the lock for 60 seconds.
  14. Create a new home structure and delete the old home structure.
  15. Pair all devices to the new home structure.


Keep me posted.




Community Specialist
Community Specialist

Hello there,


Chiming in to see if you still need assistance with this. Hope the previous post helped. Let us know if you have additional questions, otherwise we’ll be locking the thread.



Community Specialist
Community Specialist

Hi there,


Due to inactivity, I'll go ahead and lock this thread in 24 hours. Feel free to start a new thread if you need assistance with your Nest devices and we'd be glad to assist you further.