Showing results for 
Search instead for 
Did you mean: 

6.2-22 Software Update Issues

Community Member

Is anyone on the 6.2-22 Software version and having issues? My Nest thermostat was updated to the new software last week and since then I have had issues with both shorter cycles and the thermostat running for an extended time (far beyond target temperature). I'm curious if anyone else is having issues. 

I've contacted Google / Nest support and not one person  has any details on the 6.2-22 version and this software version isn't listed on the software version page. 

235 REPLIES 235

Community Member

Sounds plausible. My nest is one of the original third generation units, but it might be worthwhile to push them to see if they will replace it. I’m betting not. Considering switching to a Honeywell t-9 or something else. 


Aside from all the issues you mentioned, pushing an update out just as its getting really cold out is not great timing.

Update. For some reason, when I connect the Nest to my guest network, it no longer disconnects. I’ve never had to do this before (its about 4 years old), but I can live with it as a solution.

Community Member

@bradbort @Your solution is only applicable if you are able to see Guest network in the Nest when you try to connect to Wi-Fi. Mine keeps spinning and no luck seeing any SSID. Pls share details of what had happened to your unit as a result of this goofy firmware and then how did you connect via Guest network. 

Community Member

Sure. What makes things complicated is that both my nest and my router updated firmware within a couple days of each other. Since the nest is the only device having issues, I’m pointing the finger at it.

My symptoms are different from yours. I could see and connect to networks, but if connected to the core router networks, it would drop on the app within a day. If I went to the thermostat, it would say it was connected.  If I set up a repeater, and connected the nest to that, it would also stay connected. Apparently, it also stays connected to guest mode on the router. I’ve always, however, been able to see the available networks. Hard resets did not help. 

I assume your router is working with other clients, and it is only the nest that can’t see anything? If that is the case, I’d suspect its wifi chip has failed. 

While messing with things, I also ordered a replacement Nest, since my utility offers a substantial rebate. I’m in a quandary about whether I should just send it back, if everything is working, or install it under the assumption that there must have been some slip stream improvements since it was released. I bought mine just as it came out, so its been a while. 

What type of router do you have? I’m assuming you have tried rebooting the router, and then doing a full reset on the nest. 

Community Member

This makes a lot of sense. I have two Nests but one was replaced after about a year by warranty because it's wi-fi stopped functioning altogether. That one has had no issues with the update thus far. My older 3rd gen is the one that had issues. A reboot seems to have fixed it (monitoring it closely), but still really worried it'll kick out during a cold spell...

If either go and they refuse to replace, I'm likely going to switch brands. The absolute silence from Google/Nest on this is disgraceful.

Community Member

My furnace is running overtime. 12 and a half hours on Saturday. Plus I keep getting “no power to RH wire” all the time. I had the electrician who installed a new RH wire for me when I got the Nest Thermostat come out and check it for me but he says there is nothing wrong. All my electrical in the house has been updated. I can only think that it’s a problem with the update. On top of that, after the update it took us many tries to get it to connect to our internet and get it to connect to our apps. It was a real pain in the butt. We have third gen Nest thermostat by the way. 

Update: my hubby kept doing factory resets and now it seems to be working. Well my furnace is not running 12 1/2 hours a day anymore. 

Having issues again. I run my Nest Therm on a sensor I have in one of the bedrooms and it does not turn the heat on when the temps drops. I have to manually turn on the heat by upping the goal temp. Energy history is also wrong. I wake up in the middle of the night and my house is ice cold but it tells me that my furnace has been running for four hours. If my furnace ran that long, my house would be a sauna. This update really screwed up my system. I have tenants upstairs so this is extra screwed up. No help from customer service either. 

Whitelily227, the furnace was probably running.  Mine ran all day without heating the house.  The Nest says that the furnace is running, and the furnace fan probably is running, but it's not sending a heat signal to the burner so that the burner is not running.  That was the case for me and that's the worst part about this bug.  I had to have a furnace guy in to diagnose this.  I replaced my Nest with an old manual thermostat and everything works fine.

Community Member

I have a Gen 3 nest thermostat. After google auto updated to 6.2 the Thermostat would no longer respond to command OFF from Nest  App. I set thermostat to factory default. I uninstalled and reinstalled the Nest app, as requested by customer support.  I then added the Nest thermostat back onto my location. Will not work. Nest customer support could offer no other solutions. Thermostat is no longer responds to OFF command. I can set temperature but not OFF. Two other thermostats on the same account are using a previous version 5.9.4-5 software and they respond correctly to all commands from Nest app. 

If goggle forces a customer to upgrade to new software and it no longer works as advertised we should receive a refund. Its a bit like purchasing a car with blind side warning lights and later the manufacture updates software and removes that feature. We purchased for a feature and if they remove they should refund.

Community Member

I am not sure this helps...but at least I was able to add Nest back to my account, but...well you'll see.

I had the same disconnect problem and turning off problem of the thermostat. I assumed the turning off was because it was not connected to the app/account and it turned off (it should not, be self reliant in case of lose connection). So after reading all of the above I did the following:
- reset to factory default (same buggy firmware version 6-22)

- try to add the termostat back to my account using Next app and the QR code scan - it did not work

- I tried to add the thermostat in google Home app- it did not work

- I tried to change the phone to the same network where I will add the thermostat - it did not work

- I tried to add the thermostat using the code and serial number, using the Nest app - it did not work

- I tried to the thermostat in the google Home app using code and serial number - it did not work

- THEN I tried to add the thermostat using the web browser on my computer ( I think) using serial number (the only option). Once I added the serial number in the browser page, the answer was to continue in the Nest app. I moved then to the Nest app and tried to add the thermostat using QR code - THIS TIME IT WORKED.


Now that I had the thermostat added to the app I had to setup the equipment again (make sure you have that handy cause I spent 15 minutes looking for my old installation pics). I verified everything and my thermostat was working good again, and it was much responsive then before in changing the temperature in the Nest app, and then seeing it on the display. 


BUT then, I added the room sensors using the Nest app, I have 6, and things got worse and weird again:

- I have tried to add all 6 sensors at once in the Nest app page. At first the app allowed me only 3, it literally un-checked the buttons in the app, after I checked them. I re-checked them and went back to the app, it only still showed 3 sensors. I went back to the page and checked all 6 sensors again. This time they stayed checked. 

- I then went onto the main app page it showed all the 6 sensors

- I then tried to change the reference sensor to a difference one. It change on the user interface, but it was not reflected on the thermostat screen or in the temperature showed on in the app. - THE THERMOSTAT WAS OFFLINE AGAIN. Soon I had the "offline message again".

- I reset the thermostat, but soon after it was offline again. 


SO MY EDUCATED NON-SCIENTIFIC guess ( i am in embedded software for 40 years) is that the new 6-22 firmware version is having some memory/processor overload when you make the thermostat processor work to hard. SO:

- I took out 3 sensors from the thermostat connection. Since then the thermostat is still working....but is only 2 hours. It still reacts slower to the Nest app then having no sensor, but I am keeping my fingers crossed. 


FOR all of you that still have the connection problem/turning off problem with 6-22. How overloaded is the work of your thermostat (how many sensors do you have, how complicated is your heating/cooling)? Try taking out sensors, may be it helps.


Take the above as very empirical and apply if you see fit....BUT I NEED A NEW THERMOSTAT - I like having all the sensors. 

Community Member

Home app gives me "ERROR" in the thermostat and i can not change any settings. I also had a long chat with Google nest support, and the conclusion was to remove the wires and connect them again..... That's it, nothing was resolved. My heat is set at 70, and the indoor temp is now at 82. WTF how many months do we have to wait for the fix????

They could at least roll back the 6.2.22 firmware update.

Community Member


After all of the above (see my previous post) I still have the same issues.

- Then I took out all my sensors except one. - still have the issues.

- I gave up and called customer support. I spent 2 hours with them explaining all the steps that I went through. The lady escalated  to the "higher techs". They had nothing for me to do or change, I think I exhausted all their options ahead of the call. They cannot roll back, they cannot replace the thermostat if we are out of warranty, THEY WILL REFUSE TO DO ANYTHING. The lady escalated to managers, but I don't expect anything back. 

- However while I was on the call with customer support, the thermostat showed FOR THE FIRST TIME in my account.  SINCE THEN THE THERMOSTAT STAYED ONLINE and connected to the far. It still behaves erratatically (changes temperature limits unexpected) but is somewhat usable.


All the best to all of you!

Community Member

Has anyone gotten a clear answer from Google / Nest on any of the issues with the 6.2-22 update? I have had a case open for over 3 weeks and their support team won't acknowledge the software update is causing these issues.

Here is the last response the support / engineering team provided to me via email  after I asked why my system seemed to be short cycling after the update and also had instances of running much longer than expected (far beyond target temperature):

"The maintenance band became automatically adjustable after the update, the results from doing so could affect when the system starts and stops. This is expected behavior and the customer should not be alarmed for the behavior change he is seeing. 

With regards with the new changes, you can make a new schedule or change the set points in the schedule so that the system behaves more like they are wanting it to behave.  Since this is an automatic thing that is happening this might need to be adjusted from time to time to suit the customers needs."


Honestly, I don't really understand that response and the support agent didn't provide much additional context, but hoping it can help someone else. This whole experience has been incredibly frustrating.


Community Member

I have that software version. After the furnace finishes its cycle with ECO mode set at 65 degrees. The thermostat reads 69 degrees.

Community Member

Yes, my thermostat no longer turns on the heat at preset temps. It is freezing in my house and I have to go wobble the thermostat back and forth for several minutes, then say a few hail mary's before it'll come on and hope it remains on long enough to warm up the place before deciding to shut off again. All since firmware update. 😞 

Community Member

My thermostat went offline on Friday.  Reboot, factory reset, nothing works for more than 5 minutes.  It all comes online after reboot or reset.  After 5 minutes, goes back to offline again.

Community Member

I'm having issues with mine no longer detecting sun with sunblock enabled.  The thermostat will read 83+ degrees for close to an hour before the sun moves away from the window.  During this time, sunblock is not detecting this which blows my mind.  

Community Member

I'm also suffering from the app offline issue and even when it's online the app rarely works when doing simple things like adjusting the temperature etc.. this update broke the 3rd gen nest. It worked flawlessly up until the recent update. It's very frustrating having the thermostat say it's online and connected to the app, but the app shows it offline.

Google, please fix this asap.

Community Member

I finally got around to contacting support, went through the motions of resetting and stuff, still not working.  They looked up my serial number and its no longer under warranty, but they are sending me a replacement anyway, basically they know its the firmware:)

They gave me two options for replacement, one i send them the defective unit they broke back first and then they send me a replacement, or they send me a replacement first and i have 21 days to return my unit.  I chose the second option as i didnt feel like hooking up the old thermostat.  So i have to give them my credit card as they put a hold incase i dont return the old unit.  
Will wait for it to come and hopefully all will be good, my understanding is they just send me the Display unit replacement.

Oh just FYI, i used chat support with them, was quick


But is the problem resolved?  I have spent hours and it is not fixed.


So my furnace is working properly when the tech came to check it out. Even replaced the flame sensor just in case.  My furnace would come on and after ############ min turn off before it has reached desired temp and the fan won't shut off and now it is blowing cold air.  I have to manually go down and flip the switch.  The app won't turn it off, on the thermostat it won't turn off nothing.  

I have now been on the phone with Google for about 2 hours in 3 different calls. I have deleted the thermostat from my app, factory reset about ############ times now. The new version won't reset to the old and they can't reset it either.  I didn't spend 300 on a **bleep** thermostat to not work after only a couple years. This is ridiculous.  My house is cold.  I flat out told ALL of the agents this is a software issue.  Do you have a receipt from your HVAC repair guy?  This is FEB I see posts from OCT.  They know the software is an issue and they don't care!  I was told I have to wait for the NEW update.  I'm like well when I'm frozen, I guess it won't matter?!  I have done everything, my HVAC guy said my heater automatically will shut down when the heat turns off BUT the **bleep** NEST is preventing it.  I can't even manually work my furnace!  This is bullSH@t!!  I have a Nest  doorbell, cameras, sensors and C2o  WTF?!   I am awaiting a supervisor to call me back tomorrow since no one was there today after waiting on hold for over 30 min.(after troubleshooting doing the same reset, delete etc for 30 min prior.  I am disconnected from the internet, deleted all schedules reset by pressing for 10 seconds and the reset on the thermostat (turn dial to the end option)  Nothing has worked.  I can get my furnace on but after 20 min it is only blowing cold air and I have to go to the furnace to turn it off.  The thermostat doesn't work and when I did have the app it didn't work.  OMG I kept telling the last guy Mario don't even try and tell me it's my furnace I know better.  Poor guy got my wrath but who else can I vent to.  I live in Utah and it is cold.  My furnace blowing cold air is not good.  Waking up to 60 degrees and never getting past 67 sucks.  BUT that is ONLY because I turn on the furnace, after 20 min run down and manually turn it off, I am getting exercise, but this is not how things should go.  I'll let you know what happens.  From the sound of things, I'm not very optimistic.  I have the Gen 3 Learning nest but you can disable all of the "learning" and at the least it should work manually and mine won't even do that!  I did not have the wifi issue but Google even knows that my system had turned off and on 23 times in a 24 hr period many times.  I was thinking initially that meant it was going on and off to keep the house warm.  Not realizing it was an actual problem... OMG these guys suck.  I told them I will blast you and tell NO ONE to buy your stuff when you don't stand behind your products.  Your software made my Nest not work, not my fault your fault I demand a new one or get the fix out!

Community Member

I have no idea why all the ### that is when I put how many minutes. Weird that the site did that!  Also, where it says bleep all I said was d-a-m=n   I didn't realize that was such a bad word....OMG

So my furnace will run for twenty minutes then cold air and if I didn't go manually turn it off it would continue.  No bueno.   Monitor much Google?!

Community Member


The customer service agents are from India or the Philippines and don't know anything - they just read a script.  They ask for the receipt from the repair guy as part of the script but then if ask them why they need it, they just say it's to document the case.  They also ask for wiring pictures for the same reason.  They are not there to help, just to document the case.  When I sent them the receipt I thought that they were going to reimburse me for the service charge (due to their software bug), but instead they had no intention of helping me with the bill - it was just to 'document' for no useful purpose.  The tech support is also useless.  In my case they just told me that my thermostat was out of warranty and that I would have to buy a new one.  What good is a new thermostat with bad software!  They are very frustrating to deal with.  I have two thermostats - one in my house and one in my cottage.  I already replaced the one  in my cottage with another brand and will likely replace my home with another brand.

Community Member

One more thing to add.  I just got off the phone with Google and they weren't aware of the update.  All they could tell me is that my thermostat was out of warranty.  I'm done with Nest.

Wow that sucks, completely different from my experience.  It might be worth trying them again to see if you get a different support rep.  Also try the chat support.  I told them every since update 6.2-22 my wifi wont connect back plus a couple other issues.  I cant say they acknowledged 6.2-22, they just concentrated on trying to troubleshoot and getting it working again.  Then gave up and offered the free replacement.  They said mine was out of warranty but still offered the replacement, but only the display piece.  Its the Nest Learning 3rd Gen.  

Sorry to hear your experience wasnt good, but try chat, they got on quick.

There’s no solution.  I gave Google a month of my life.  Replaced it with the same analog thermostat I removed last April.  

Mine so far after 3 different people has not been good.  We'll see if the Supervisor calls me back. I have the same as you.  


Mine was having similar problems and I was able to fix it by turning off the safety temperature feature.  Then it would work normally.  Then the update got rolled back to a previous version.  Hope it works for you.

I have removed all safety temps, schedules, deleted off the app, took off wifi, factory reset about 20 times now. This is a software issue and mine is still not working.  i have to manually turn the cold air off about 2 times an hour. This is ridiculous!   i have wasted 3 hours and have spoken to 3 different people did everything they told me to do and then waited 30 min for a supervisor who never came. Then I was told they would have them call the next day.  It has now been 48 hours I guess I will try again.  

Anyone who received a new part please let me know. The supervisor I spoke with asked me what their case # was.  I understand they have a script and don't initially want to help but I just want the new face plate too.  Help a girl out please!  I have spoken to 4 different people, to no avail.  

Community Member

I thought I was done with the issues but I’m not. My furnace is running 15 and a half hours on a 40 degree day. How is that possible? Even after the Nest app says that my furnace is off, my furnace keeps running. This needs to be fixed pronto. I’m going to have to call tomorrow. 

Yeah, that was same problem that I had.  The Nest tells you that it's calling for heat but it's not sending the correct signal to the furnace.   

Community Member

Get rid of the Nest thermostat and replace it with an old fashion analog thermostat.  Your stress levels will disappear and you’ll regain control of your furnace (and life).  Google will keep you chasing the illusion that there’s a solution to your problem - there just isn’t.  Sorry.  

Community Member

A quick question for those experiencing connectivity issues, but not the erratic furnace performance issues (both seem to be common after the update). What brand/model router do you have. I have an ASUS, which also updated around the same time as the nest update, and I’m trying to sort out what caused the connectivity issues. For me, putting the nest on a guest network seems to have solved the latter. 

Community Member

Asus is specifically the problem, yes.

I personally have the Asus xt8 WiFi 6 mesh ZenWiFi. I had to downgrade the firmware on it to an august release to fix the connectivity issue. It did in fact resolve the issue though.

The problem is the Asus firmware, not the nest.

Community Member

My 3rd Gen thermostat, after the firmware update, couldn't see any Wi-Fi networks, regardless of the source.  On my phone I can see at least 5 Wi-Fi signals in my home (my neighbors' networks and two within my house). 

Google Support also had me turn on a Wi-Fi Hotspot on my phone to see if the thermostat could see that network.  It could not.

Last week, I got my replacement unit and it worked exactly as it should.  It listed all visible networks and was able to connect to the one I chose.  

My previous (returned) display unit was a different version than the one they sent me...

Display Model: 3.4 (could not find Wi-Fi networks with firmware version 6.2-22)

Display Model: 3.6 (works perfectly with firmware version 6.2-22)

You can find this model version number in the Settings menu under Technical Info.

There is also a Backplate model number.  Mine is 5.4 and was not swapped out.  Google replaced only the Display unit.

Community Member

OK. It seems like there are two issues. ONe is a failure for the display unit to be able to detect ANY wifi. That seems to be a hardware/firmware issue.

The second is losing connections frequently. I'm not quite sure that is an ASUS problem, but it could be. CSALL says that he had issues since August, and rolling bakc the firmware helped.  I had not connectivity issues until both the firmware for the nest and the ASUS updated in the beginning of November. AS I said elsehwere, putting the nest on a guest network seemed to stablize things, although I have no idea why. 


Oh wait, I misread CSALL's post. He did not say he saw the problem in August, only that he downgraded to an August ASUS firmware version. So, it does seem to be related to the latest asus firmware, or some interaction between both new sets of firmware.