cancel
Showing results for 
Search instead for 
Did you mean: 

Heat Link Gen 2

LorraineRutter
Community Member

Our Heat link Gen 2 is dead, an electrician has tested it and there is an electricial supply to the unit, he tried to do a hard re-set but it failed. The battery is now drained in the room stat

6 REPLIES 6

AlexD
Community Specialist
Community Specialist

Hi @LorraineRutter , I am sorry to hear you're having issues with your thermostat. I would be happy to try and assist. 

 

You mentioned the Heat Link unit seems to have failed. To confirm the LED lights on it seem to be off even though there is power to the unit, correct?

 

If so make sure to double check all breakers and switches, just to make sure it is all good. 

 

If it all looks good try and do a power cycle on the Heat Link, if you are comfortable in doing so. Turn the power off to it for a few minutes and then turn it back on. See if it has any reaction after when you press the button on it.

Thanks for the advice AlexD.  We've tried all that you suggest and there is still no green light/dead as a Dodo

 

AlexD
Community Specialist
Community Specialist

Thanks for trying @LorraineRutter

 

Let us check a few things next:

 

1. How long ago was the thermostat installed?

2. Was it installed originally by a Nest Pro or a heating/electrical engineer?

3. When did you first notice this behavior?

4. Have there been any power cuts in the area recently?

5. Has there been any work done on the heating or electrical system at the location?

6. Do you have one or multiple Google Nest thermostats at the location? 

Answers as below

1. 2.5 years

2. Yes

3. 5 days ago

4. No

5. No

6. 3 in total, the other 2 are fine

Thanks

Hey @LorraineRutter,

Thanks for the details. Sorry for the late reply. Just checking in, was your issue resolved in the meantime?

Hey. It's me again. How's it going with your thermostat?