cancel
Showing results for 
Search instead for 
Did you mean: 

My heat link has died and we have no heating

Jsmoth87
Community Member

Hello

Last night our thermostat was displaying a symbol of like a screwdriver and a wrench? The screen said that it couldn’t connect to the heat link which was strange because it was working fine since we had installed (November 2020).

Moving the thermostat didn’t fix it, so I went to check on the heat link and it looks to be totally dead? There’s still power going to the boiler and the rest of the room. I’ve tried pressing the button, holding the button, turning off the power at the wall for a few minutes, but it’s am just totally dead. We have no heating, can someone tell me how to get this fixed or just even how do I disconnect the heat link so that I can have heating again until we get a replacement? 

8 REPLIES 8

Frustratedddd
Community Member

Quick easy fix is to fit a jumper wire between the terminals at the Heat Link. That will give you heat., but only a temp job for tonight. Then get something sorted correctly until you get the Heat Link replaced.

What are the connections in the Heat Link?

Thank you for your suggestion… great advice I’d you know one end of a screw driving from another! 

AnaM
Community Specialist
Community Specialist

Hey @Jsmoth87,

 

It's unfortunate that this happened, but I'd like to help you fix this. Please answer the following questions so that I can properly document your case:

 

  • What type of Nest thermostat do you have?
  • When was it installed?
  • Did the issue happen during installation or after installation? Was it installed by a Nest Pro or by a regular installer?
  • Are there any lights on the Heat Link? Does the boiler activate when calling for heat by pressing the Heat Link's button to activate Manual Mode?
  • Are you seeing any wiring report or error on the thermostat and/or the app?
  • Have you had any recent power cuts in your area? If yes, has the power been restored?
  • Have you recently had service or maintenance on your electrical, plumbing, or heating system?
  • Have you tried any troubleshooting steps before contacting us?
  • How many thermostats o you have?

Tommy26
Community Member

Hi AnaM,

 

I have the same issue and have had a power cut in my area recently. Power is now restored but the heat link is dead and have been trouble shooting all day. No heat in the house. All was fitted by a Nest pro engineer..

Any insight would be greatful.

 

thanks

Tommy

Ktea
Community Member
  • Please see my answers to your questions in bold below - I have already answered these elsewhere.  If you can make further suggestions that would be helpful. 

    What type of Nest thermostat do you have?-  Hub generation 3 
  • When was it installed? - circa 18th ago
  • Did the issue happen during installation or after installation? Was it installed by a Nest Pro or by a regular installer? - no not during installation - don’t know 
  • Are there any lights on the Heat Link? Does the boiler activate when calling for heat by pressing the Heat Link's button to activate Manual Mode?  No lights - bottom in centre of heat link not working 
  • Are you seeing any wiring report or error on the thermostat and/or the app? H71
  • Have you had any recent power cuts in your area? If yes, has the power been restored?  No
  • Have you recently had service or maintenance on your electrical, plumbing, or heating system? No
  • Have you tried any troubleshooting steps before contacting us? Yes - all available 
  • How many thermostats o you have? One 

AnaM
Community Specialist
Community Specialist

Hey there,

 

Just checking, do you still need help?

Ktea
Community Member

yes I still need help!!! Are you able to offer any? 

Ktea
Community Member

Either that or get it replaced.  Google clearly know the UK have a problem - there is an announcement on their website.  The contractor they have engaged to deal with this is pretty unresponsive!  I am about to have the system removed and replaced with an ordinary thermostat.  We have been without ANY heating since Friday and no response from BOXT - Google’s appointed engineer. 🙄