cancel
Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest thermostat 3rd generation

chamosas69
Community Member

My nest 3rd generation is no longer powering on. I’ve tried removing from plate and connect to usb charge with no help either. It just keeps flashing red. I even drained the battery completely for days and tried to connect to usb via AC but same results. Any ideas? Is this the internal battery issue? Thanks in advance 

1 REPLY 1

zoeuvre
Community Specialist
Community Specialist

Hi chamosas69, 

 

Thanks for posting here in the Community forum, and I'm sorry to hear about the situation. Let me take a look at this for you. 

 

A few questions: 

 

  1. Are you located from North America or Europe?
  2. When did the situation first occur?
  3. Is this a newly installed thermostat? If yes: What is the make and model of your heating, ventilation, and air conditioning (HVAC) equipment?
  4. Are the power breakers on, and do you receive power to your home?
  5. Is the thermostat's display seated properly?
  6. Are all the wires of your thermostat seated firmly in its terminals (with no loose or exposed wires)?
  7. Did you used a micro-USB cable to charge the thermostat display? 
  8. For how long did you charged the thermostat display? 
  9. For how long does the thermostat lasts after you charged it? 

 

Have a look on the following: 

 

  1. Remove the thermostat display from its base and check if any connector pins are bent.
  2. Check if the thermostat wires are secured in their terminals and all the buttons are down.

 

Keep us posted. We're happy to help. 

 

Best,

Zoe