Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest Router won't set-up

Community Member

Hello - We have Google Fiber as our internet provider, and just received a Nest Router and Point package. When I try to set-up things, the router won't connect, and I get told there's no internet connection for it. I've watched multiple videos, read forums, but nothing I try seems to work. I've also tried resetting the router, but no luck.

So, our original equipment that worked:
- Cable comes into our house and connects to the Fiber Jack (GOGP220C)
- Ethernet cable from that connects to the Network Box (GFRG210)
- We have ethernet cables from that to our devices.
- The Nest Router (H2D)

I would like to install the Nest Router at this point, and have tried:
- Connecting directly to the Fiber Jack
- Leaving the connection from the Fiber Jack to the Network Box, and connecting to the Network Box.

Both of these steps result in the same, the router will not set-up. From the Google videos I watched, connecting to the Fiber Jack directly should have worked. However, since that didn't, I thought the Network Box acted as a modem, and would connect to that at least. Both failed.

Am I missing something, or do I have a bad router I should return?

Thanks in advance for any guidance!