Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest Yale lock doesn’t recognize connect

Community Member

We set up our nest connect. I have ensured it has a good connection and it is close to the best Yale lock. I have tried having Wi-Fi only on my phone and ensured the button on lock is blue while I try to connect. I have tried to connect by scanning code and looking up device on app. I have restarted my phone. Each time it does not recognize that the Nest Connect is already set up and asks that I set up this device first. Spent over 30 min with all the above trouble shoots. What else should I do?


Community Specialist
Community Specialist

Hi SusieP,


I’m sorry for the delay. Let’s sort this out — a few questions: what’s the status light of your Nest Connect? How far is your Nest x Yale Lock and Connect from the router? Are the batteries of your lock fresh and standard AA alkaline batteries? Also, what Wi-Fi frequency band do you try to connect to (2.4 GHz or 5 GHz)?


Here are some troubleshooting steps you can try:


  1. Take off the battery cover and remove the batteries from your lock. If you received a low battery alert, use a fresh set of standard AA batteries. Don't use rechargeable batteries with your lock.
  2. Put the batteries back in after 60 seconds. Wait a few minutes to check if your lock comes back online.
  3. Restart the Connect: 
    • Plug Connect into a power outlet. 
    • Hold down Connect’s button until the light pulses blue (about 10 seconds). Then release the button. 
  4. Factory reset your Connect. Hold your Connect’s button for much longer than 8 seconds, the light will turn yellow, which means your Connect is preparing to factory reset. Keep holding down the button, when the light flashes yellow then goes off, release the button. 
  5. Remove it from the Nest app. Then, add it back. The recommended router settings are the 2.4 GHz Wi-Fi frequency. 
  6. Restart your modem or router, unplug it from the power outlet, wait for 1 to 2 minutes. Then, plug it back in.
  7. If all else fails, factory reset your lock. Then, re add it to your Nest app.

Let me know how it goes.




Community Specialist
Community Specialist

Hey there,


I just wanted to follow up to see if you still need our help. Please let us know as we would be happy to answer any questions you may have. 

I appreciate the help, JT.




Community Member

Able to get it connected. Finally worked after resetting the lock. 

Community Specialist
Community Specialist

Hello SusieP,


Sounds great! Thanks for the update, and we're glad to know that resetting the lock did the trick.


So we can mark this one as finished, and I'll lock the thread in 24 hours unless we can help with anything else.