Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest door lock won't connect to nest connect

Community Member

I know there are multiple threads like this, but I've tried all the suggestions including creating a no password guest network.  That made no difference.  We had to change our wifi router and so everything had to be recreated.  Google home devices all restarted fine on the new network.  The nest connect sets up fine with the nest app and connection tests look good.  But adding the door lock fails all the time.  The key pad lights don't light up when the connect button on the lock is pressed. That doesn't seem to change when the Yale button is pressed to "wake it up".   The Nest connect blue light flashes as if it's trying to connect but the process eventually times out with "something went wrong" .   We've tried everything I can find including resetting the devices multiple times.  What can anyone suggest?



Community Member

Same issue, soon as I got the nest aware trial, it worked just fine

Community Member

Thanks, but I don't have any of the hardware, like bell, cameras etc, that Nest Aware supports. Just the door lock.  Is that you case too?


Edit several hours later. I finally managed to get my x-Yale lock to connect. After multiple attempt at resetting it by removing the back, and holding the reset button while reinserting batteries it finally reset correctly. Had  done this at least 5 times before the thing actually reset and the following setup proceeded as advertised.  So I believe all my problems have been due to not getting the lock to reset completely before this.