cancel
Showing results for 
Search instead for 
Did you mean: 

Indoor Nest Cam (gen2) will not finish setting up

Awducker1
Community Member

I have multiple Nest devices in my home. We bought an indoor camera to use as a video monitor for our child. When adding the device on the Google home app, it goes through the normal process of setting up, selecting Wi-Fi etc and the light even turns green. The app says the “Device is setup” and then goes into a cycle of “setup is taking longer than expected” and my only two options are try again and cancel. 
I have restarted my router, reset the camera but the hole in the bottom, reinstalled my nest and Google home apps on my iPhone. I don’t know what else to do. 

1 ACCEPTED SOLUTION

Mkovach
Community Member

Finished setup fine this morning. In seconds. Whatever the glitch was must’ve been corrected!

View solution in original post

34 REPLIES 34

steven807
Community Member

Ditto.  I actually got most of the way through installation earlier this morning, postponed the rest, and I when I tried again I found myself having exactly the same problems you are having.  Perhaps there's a failure on the Google server side, hopefully temporary?

Kyleshumway
Community Member

The exact same thing is happening to me with nest cam battery. Been at it for hours now and can’t seem to find any help. 

Dorozco09
Community Member

I’m having the same issue. Just bought a Nest Doorbell today and when I try to connect it, I get stuck at “something went wrong setup is taking longer than expected.”

I am not given an error code or anything to go off of and can’t seem to find a solution. 

Yep. Exactly 

DavidS
Community Member

I have exactly the same issue.  Seems like some type of a firmware glitch, and there is no solution.  Its amazing how poor Google's product support is when there is an issue.  No phone number, no solution.  Might be a return on my part.

Awducker1
Community Member

I am thinking the same thing. Going to give it another try in a hour or so and then just return it if I can’t get it going. Any benefit is not worth the hassle at this point. 

DavidS
Community Member

I have another identical Nest camera in white that I bought last week from BBY and it works great, set-up in minutes, and is still online working fine.  I'm not sure why the new gray/green camera I just received directly from Google fails to work.

Kmoreland
Community Member

Same here. Been trying to setup a new nest battery doorbell and a new nest cam outdoor. 

rynhys
Community Member

Same problem on my part. 2 purchased from Google during the BFCM sale and both are giving me the same result.

Grizly
Community Member

Same issue with nest doorbell. Tried to reset and re-add it multiple times, didn’t help. 

Kris986
Community Member

same issue as well with 2 battery powered nest cameras

Mkovach
Community Member

Same issue. Both cameras of a battery 2 pack. Disappointing.

Norrelle
Community Member

Same. 

This is a **bleep** show. 

Doubleoseven
Community Member

Wow I’m shocked at how many people bought cameras today. Having the same issue. Went and exchanged as I thought it was an issue with a camera. Now this post exists and seems to be an issue on Google’s part. Hope this gets resolved soon. 

plantheaction
Community Member

Just got my 6th nest cam and trying to set it up and having the same issue. this sucks

Whitney
Community Member

Same exact issue with my new nest doorbell battery. I spent a half an hour on the phone with the customer service rep and she ended up finding out that this is a known issue that started about six hours ago. They said there is a bug and they’re working to resolve it they’re hoping it will only take a couple of hours but it said to try again tomorrow.

Rg23
Community Member

Thank you ! 

Victoria13
Community Member

So no one has a fix or advice for this I also just bought about four of the indoor cameras. I can’t set up any of them.

Rg23
Community Member

It’s a Bug Google said try tomorrow .

edh
Community Member

Same issue with me, are the times on the messages here accurate, is everyone having the same issue??

Got my hands on a gen 2 indoor wired nest cam literally 15 mins ago, and have been trying to connect to it through the google home app

Awducker1
Community Member

Yep. We are all having the exact same issue. Crazy! Someone said google knows about it and will get it fixed. I’m going to try again in the morning. 

bman
Community Member

Glad to see I'm not the only one having this issue. I thought I was going insane. Was on the phone with support for 2+ hours earlier and couldn't get it worked out. Tried multiple workarounds with them and nothing. Going to wait and try again tomorrow to see if anything changes.

Jaxter
Community Member

SAme issue. **bleep**ing horse**bleep** in hogwash 

aubiebrown
Community Member

Same issue here, glad to know I’m not the only one. 

Mkovach
Community Member

Finished setup fine this morning. In seconds. Whatever the glitch was must’ve been corrected!

Same for me. Glad they got it fixed! 

Brad
Community Specialist
Community Specialist

Hi there, 

 

I apologize for my late response and thank you for all of your patience while waiting for a reply. I can definitely understand how frustrating your situation must be, but I wanted to make sure that your issue was addressed. 

  • Please make sure that if your device does not pair successfully first, then you will need to Factory Reset the device, and then pair again. We were having this issue a couple weeks ago and it was reported as resolved. Giving this a try if you haven't yet Factory Reset your device. 

Please let me know if you need further assistance. 

Best Regards, 

Brad.

Brad
Community Specialist
Community Specialist

Hi there,

 

Just checking in to see if you still need assistance with this issue.

 

Please let me know if you need further assistance. 

Best Regards,

Brad.

I have just opened my new Nest Indoor Wired Camera (Gen2) and it is giving me the same issue even after resetting EVERYTHING! Please help.

 

'Connecting to assisting Nest device'

 

 

Waynetoo
Community Member

Final step still will not complete.

Makes you want to never use WIFI connected accessories again. My favorite Christmas gift this year was a jar of pickled okra. Just open and enjoy!

DavidS
Community Member

I was able to get the camera working this morning.  Google seems to have fixed the issue.  Yay!

IOT-Robin
Community Member

still not Works in Sweden 😞 

Have you tried contacting google support? When this happened 3 weeks ago, I was told it was an issue with connecting the devices via iOS devices. I contacted them on twitter, got a quick reply and then it was fixed the following morning. 

Brad
Community Specialist
Community Specialist

Hey Folks.

 

At this time, I'll go ahead and lock this thread. If you're still experiencing problems, feel free to start a new thread and we'll be happy to help.

 

Best Regards,

Brad.