cancel
Showing results for 
Search instead for 
Did you mean: 

Protect can't finish setup, various error codes

Beckyj412
Community Member

I got a new internet provider with new router and my nest protects cannot connect to my new network. My thermostat connected just fine but the protects can't. I deleted them and tried to re install completely. I get an error during setup but it's a different error number every time. I have turned off the dual band to try and use 2.4 ghz and it doesn't seem to help. I have ipv6 turned on. I'm not sure what else to try. 

1 ACCEPTED SOLUTION

GarrettDS
Community Specialist
Community Specialist

Hey there, 

Thanks for giving me the error codes you're receiving. 

I was able to find a great article that can help you with the troubleshooting steps when it comes to these error codes, and I would suggest reviewing that.

 

When it comes to the P030 error, it seems as though adding a new home for the device worked for this user.

 

Please let me know if you have any further questions. 

Best regards, 

Garrett DS

View solution in original post

12 REPLIES 12

Helphelp
Community Member

Hi Beckyj412

Did u ever get a solution for this as I'm struggling myself to connect. 

Nope. No solution yet. I haven't been able to get them connected.

GarrettDS
Community Specialist
Community Specialist

Hey there,
Sorry for the late response, but I wanted to drop in here to help.

I understand that these issues can be confusing but I definitely wanted to stop by and see how I could help.

Just wanted to double check to see if you were still needing help on this? If so, what troubleshooting steps have you tried?

 

Just for reference as well, there is a current issue when trying to setup Nest Protects within the app and the app keeps crashing that we are aware of and are actively working on. 

Please let me know.

Best regards,
Garrett DS
 

GarrettDS
Community Specialist
Community Specialist

Hey there,
Just wanted to jump in here to check to make sure that you saw our response. Please let us know if you have any other questions or concerns as I will be locking this in 24 hours.

Have a great day.
Garrett DS
 

By adding a 2nd Home to my account and adding the Protects to that one as explained here for the user, I was able to finally get my Protects connected. Apparently they couldn't share with my Nest Thermostat. Good Luck!

GarrettDS
Community Specialist
Community Specialist

Hey folks,
It looks like we have come to a solution so I'm going to be locking this thread. If you have any other concerns or questions, please feel free to create a new thread.

Have a great day.
Garrett DS
 

Beckyj412
Community Member

I still have the issue. I have done all the possible troubleshooting and about given up and will have to throw these protects away and get some regular smoke alarms.

I have gotten codes P008, P018, P006, P015, and the latest is P016. I have already checked the Nest service status and made sure the version was all up to date. My wi-fi network is working fine, I have moved closer to the router, restarted the router, restarted my cell phone, and reset my Nest devices. I have a dual band router that does not allow me to change the network names (it automatically connects appropriate devices to the correct band) so I have turned off the 5ghz so only the 2.4 is available to connect and that didn't help either. There are no parental controls on my network. And I've turned on the IPv6 setting. Not sure what else to try.

GarrettDS
Community Specialist
Community Specialist

Hey there, 

I'm so sorry you're still having these issues. 
Would you mind telling me what the current error code that you're getting is now? Once I get that, I can troubleshoot what the issue is. 

 

Best regards, 

Garrett DS

I had error code P016, then when I hit the "try again" button I got P018. But I have literally done this 100s of times and have gotten all of the error codes.

Oh, this one is a first - just got P030 and that's not in the list of error codes to troubleshoot.

GarrettDS
Community Specialist
Community Specialist

Hey there, 

Thanks for giving me the error codes you're receiving. 

I was able to find a great article that can help you with the troubleshooting steps when it comes to these error codes, and I would suggest reviewing that.

 

When it comes to the P030 error, it seems as though adding a new home for the device worked for this user.

 

Please let me know if you have any further questions. 

Best regards, 

Garrett DS

View solution in original post

Beckyj412
Community Member

By adding a 2nd Home to my account and adding the protects to that one as explained here for the user mentioned above, I was able to finally get my Protects connected. Apparently they couldn't share with my Nest Thermostat. The article referenced above had already been tried during all my troubleshooting and nothing listed worked.  So for anyone else with this problem, if none of those steps work, possibly adding a 2nd home (I named it Nest Protect) will allow you to connect them.