cancel
Showing results for 
Search instead for 
Did you mean: 

The iOS Nest App crashes while installing Protect

jdpindynet
Community Member

I already have a Nest Protect and just bought a new one (my second).  The Nest app repeatedly crashes when I try to "add product".  The steps are 1) click on the gear icon, 2) select Add Product, 3) scan the barcode, 4) click on Next, 5) select Basement.  At this point, the app crashes with no messages or warnings, it just dies and the next thing I see is the iOS home screen.

1 ACCEPTED SOLUTION

jdpindynet
Community Member

Thanks WestCoastGuy for sharing your experience.  With your encouragement, I kept trying.  As you said, none of the usual fixes worked, rebooting the iPhone, deleting and reinstalling the app, I even read my one message, but nothing worked.  I then put the battery's pull tab back in place, and pulled it out when the app told me to do so, and it finally worked.  Not the first time, but eventually.  I think there was something very intermittent that I finally managed to avoid.  I probably went through the process 25 times.  My best advice to anyone that reads this message is to keep trying.  The code must be very buggy, but there is at least one path through it that works.  Good luck, I hope you have a better experience than I did.

View solution in original post

3 REPLIES 3

WestCoastGuy
Community Member

Hi.  I was having the same issue.  Got on a chat with Nest Tech Support and ran through all of their usual fixes (reboot iPhone) re-install the app, confirm the iOS and app are current, etc.).  While waiting for a reply I got bored and deleted all of the messages in Nest.  That seemed to work.  I was able to install 3 more units without a problem.  Good luck.

jdpindynet
Community Member

Thanks WestCoastGuy for sharing your experience.  With your encouragement, I kept trying.  As you said, none of the usual fixes worked, rebooting the iPhone, deleting and reinstalling the app, I even read my one message, but nothing worked.  I then put the battery's pull tab back in place, and pulled it out when the app told me to do so, and it finally worked.  Not the first time, but eventually.  I think there was something very intermittent that I finally managed to avoid.  I probably went through the process 25 times.  My best advice to anyone that reads this message is to keep trying.  The code must be very buggy, but there is at least one path through it that works.  Good luck, I hope you have a better experience than I did.

View solution in original post

GarrettDS
Community Specialist
Community Specialist

Hey folks, 

It looks like we have come to a solution so I'm going to be locking this thread. If you have any other concerns or questions, please feel free to create a new thread. 

 

Have a great day. 

Garrett DS