Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest thermostat won't connect to app

Community Member

My 3rd generation Nest Learning Thermostat won't connect to the app. Everything else is good, including Wi-Fi. I tried both the QR code and the entry key. The QR code tries to connect then goes to an error. The entry key hangs and does nothing.

1 Recommended Answer

Community Member

This is a paste of @Stevew89 post, since you can't locate it.  This worked for many folks, including me.

1.) Remove your thermostat from the Nest app. Tap your thermostat on the Nest app home screen, then tap Settings. Scroll down and select Remove thermostat.
2.) On your thermostat, go to Settings and then Reset and then WWN Connection.
3.) Select Reset and confirm that you want to reset. Your thermostat will restart.
4.) Go to Settings and then Network and reconnect your thermostat to Wi-Fi
5.) Go to Settings and then Nest app and get the entry key.
6.) Start the Nest thermostat installation flow again. On the Nest app home screen tap Settings and then Add product. Choose your thermostat and select Already installed to skip ahead to the entry key step. Type in the entry key you see on the thermostat screen.

View Recommended Answer in original post

220 REPLIES 220

Finally something that works. Thanks a bunch!

Community Member

Just purchased the Nest 3rd Gen Learning Thermostat. The instructions given were the same exact ones cited here as the solution. However, that didn't work no matter what I did. Followed all advice, latest Nest App installed, restarted Wi-Fi, etc. etc. etc. Kept receiving the TD017 (3.3) error which made no sense to someone that doesn't have a magic decoder. Anyway what worked for me was the following:

1. Manually configured Nest Thermostat with my Wi-Fi through its menu options
2. Manually updated the Nest Thermostat Software through its menu options

3. Thermostat automatically updated/restarted

4. Went back through original steps and was able to add thermostat to the Nest App

I can only surmise that there's an incompatibility between the older software running on the thermostat and the latest Nest App version (at the time). Have had 0 issues since then. 


Community Member

None of this worked for me. Connects fine to my internet and the previous owner said he removed it from his account but I add it to my account. Tried both the QR code and manual code entry

Community Member

If the unit has been set up under a different user before, the key is to reset the WWN setting.

Community Member

I thought for sure this was going to be the answer but alas it didn't work for me. It's been an entire year and our Nest Learning Thermostat has not ever worked with our app. We have an overpriced piece of pretty metal on the wall that barely does anything different, other than look good and cost 10x, than our old thermostat. What an absolute disappointment with Google technology here.

Community Member

Did you buy your thermostat pre-used by any chance?  What model is it?

Yay! Resetting WWN resolved the problem. Thank you group.


Community Member

When I enter the key code on my I-phone 8 plus nothing happens. Do I continue trying the connect steps over and over.?

Community Member

I am out of town and my nest app is showing I am away with local outside temperature but is not appearing to be connected to local wifi.. cannot see in house temperature or change thermostat.. do I need Simone to visit and manually connect wifi?

Community Member

Well the outside temperature is just what the local weather reports say and based on the location you set for your Nest home.

It's possible your home internet is down. Can you do an online check of your internet service status on your ISP's website? If it's this, everything should start working again when the service resumes.

Otherwise you will have to get someone to visit to check out the problem.

Community Member

Thank you. Spent hours on other approaches. This one works!!

Community Member

I don't have a WWN option under reset. 

Worked exactly as written. After following these steps, once I added to the Nest app the thermostat then auto-populated into Google Home under 5 minutes later. 

Community Member

Thanks!  This worked for me.

Community Member

Deleted my thermostat from the app, now it won’t let me add it back on! Any ideas?

Community Member

You're brilliant!  I've been trying to fix this all morning!  This was easy.  Thank you!

This was exactly the answer I needed - thank you!

Thank you.  It worked for me.

  • I cannot connect nest app at the final stage, the program hangs. when it is necessary to indicate where the thermostat is located, everything freezes and there is a record that the connection is not completed.

Community Member

Welp, this worked great for my Nest that went offline a few weeks ago and has been a total royal pain in the @- - to get added back to the app. But guess what? Now my other TWO Nests that were working fine have dropped offline from the app!  (BTW, according to the Thermostat UI's, they are connected to WiFi and the app). This is cruel and unusual punishment. Now the trouble shooting starts again 😠

Community Member

EDIT: whenever i plug it in my device isn't charging. I've tried everything and talked to support. i may need to get a new one.

I did all of this and my device still will not connect to the app. i live in an apartment and this nest was here from the complex.


Community Member

How do I work the phone from the app

Reset WWN does work. 

Factory reset does NOT work.

Basically the problem most probably is with the existing entry key setting in the device.

Reset WWN will let NEST issue a new entry key to the device. 

This worked for me! I didn't even have my 3rd gen learning thermostat connected so this definitely works for initial setup. I got a different entry key after resetting WWN connection. Also my entry key was ###-pepper but I just put in the ###pepper and it worked, in case the hyphen threw anyone else off since you can't enter symbols characters into entry key field. 

Community Member

This above absolutely works 100%!!!!  I've had to find his response 3 times every time!  Finally saved it to my own iPhone photo album, for future references/problems!!!!  After following Google's suggestions, taking hours of my time doing what they say, talking to them on the phone, this above was the only advice that actually worked...I've learned now, when I have problems with anything, on apps, computers, etc. I automatically go to Community Support now, instead of the brand "experts"...The community relates better, and give you easy answers!!!  

Community Member

Make sure your iPhone and thermostat are working off the same network.  Let me find Steve's answer in the community here to this problem.  Much easier than Google explained it, and made everyones life a living you know what...

Community Member

Look at my response below, to Omar.  SteveW's instructions work 100%!


Community Member

When you bypass the QR scanning, make sure you check your entry key number...I learned, the hard way, that that number does change!!!  That was a big part of the problem also!  


Same with me! I got hvac guy- $100 through google. Hasn’t worked since a week after he did it. I’ve checked everything they’ve said here. Ugh! And when I took it off the wall to get 4 digit code, it didn’t have it. It’s already set up & I want to change settings & cant

Community Member

Same same same.  Shouldn’t have to repurchase all of these devices because neat and the google home app no longer recognizes them 

Community Member

I am having the same issue.


New installation. deleting the app, rebooting your phone, then reinstalling the app didn't do anything. 

I did the above recommended steps and the app did not find the nest

This is a brand new thermostat. I reset the app restarted the wifi and it still won't connect.

I have tried very single suggestion to reconnect to my nest thermostat and to my nest door lock. Nothing works. Nothing. I had to buy a new nest thermostat.   This is Google’s disaster 

This did not work for me. Any other ideas. Cannot get it to connect at all

Community Member

I have the same issue. 


Tried the app on an iPhone an iPad and and Android phone. Only 1 out of my 4 nest 3rd generation learning thermostats connects to the app. Note this is a brand new setup.


I have rebooted the phones, reinstalled the app, factory reset the nests, changed the WiFi name, turned on and off the 2.4Ghz WiFi band, nothing seems to fix it.

I get the TD030 error consistently.


Any suggestions?



Platinum Product Expert
Platinum Product Expert

Just pulling this from Google support here :

The TD030 error can occur because:


The assisting device your thermostat uses to communicate within a thread network is powered off.

Your phone and the assisting device are on two different Wi-Fi networks.


 To check that the assisting device is working correctly, follow the troubleshooting steps below.


Make sure that the assisting device is powered on. If it isn’t, charge it or connect it to a working power source.

If the assisting device isn’t in use, remove it from the Nest app.

If you have more than one Wi-Fi network, you may have to move your phone to the same network the assisting device uses.


So... My first inclination is to do a reboot of your router , go into you Google home app and be sure that there are no "offline " devices, and be sure you only have one wireless network (no ap isolation mode or band steering features active).  If this fails , then I will escalate this for you as it would be above my head!

I need it escalated as nothing seems to work after trying everything suggested above multiple times. 

Community Member

I’m in the sane boat. This should be easy, abs I’ve wasted 2 hours of my Saturday over a silly app connection. With the QR this should be a 5 min thing. Google needs to make this far more consumer friendly. I have a modern network and have zero issues with my other shaft devices, including an earlier Nest thermostat.