cancel
Showing results for 
Search instead for 
Did you mean: 

blinking red lights on Nest

mrwendel
Community Member

Hello,

 

I've had my NEST working for years and for the last week or so, I've struggled to get it running.  One thing to note is that it appears to have a tight connection to the base, but it doesn't "click in place" like my upstairs unit does.  That said, there are "blinking red" on the top indicator.  I can "sometimes" push on the display and get it to restart.  After the google logo appears, it will give me a working disply for just a "few" seconds and then display a "The thermostat is restarting. Back in a bit" or the thermostat needs to restart message.  ...at which point it will go from blinking green to blinking red again very quickly.   It does NOT restart as it seems to imply.

How do I know when the device needs to be replaced?  I've seen numerous threads with related issues, but nothing seems to do the trick.

 

Any other ideas?  What might I be missing?

1 Recommended Answer

mrwendel
Community Member

Charging via USB did not work, however; I changed the battery and it’s working now. You can lock this thread. 

View Recommended Answer in original post

5 REPLIES 5

Houptee
Silver Product Expert
Silver Product Expert

Battery might be bad. There are some videos on youtube how to take it apart and replace the battery but it is not approved by nest to do this repair and takes some skill.

Your gas or electric utility probably has a rebate program to get a new one for a really low price.

mrwendel
Community Member

I'll see if I can find them and do it myself.  My energy provider does not offer any such rebates, but I'll cross that bridge when I have to.  thanks!

EdwardT
Community Specialist
Community Specialist

Hey folks,

 

@Houptee, thanks for the help!

 

@mrwendel, thanks for reaching out. How's it going with your Nest Thermostat? To isolate the issue, could you try charging your Nest Thermostat using a USB cable for an hour?

 

Thanks,

Edward

mrwendel
Community Member

Charging via USB did not work, however; I changed the battery and it’s working now. You can lock this thread. 

Jeran
Community Specialist
Community Specialist

Hiya mrwendel,

 

I'm glad to hear you were able to get your Thermostat working! If you run into any more issues in the future, please feel free to create a new thread.

 

Have a good one!

 

Best regards,

Jeran