cancel
Showing results for 
Search instead for 
Did you mean: 

Google WiFi with TPLink AX50

mfrymyer
Community Member

I just received the Google WiFi mesh (2 units) from Google to replace the old Google Fiber router. Since the old Google router was so horrible I bought a new TP-Link AX3000 Gigabit Wi-Fi 6 Router, Archer AX50 and have connected it to the old Google Fiber router via ethernet cable (after turning off the WiFi in the old Google Fiber router).I also have an access point, AC1750 Wi-Fi Range Extender, RE450.

My house is over 3000sq.ft. so I'm trying to figure out if I can use all of these together to allow for better WiFi experience. Any assistance would be appreciated.

1 ACCEPTED SOLUTION

mfrymyer
Community Member

Hi Jeff, Yes I saw his reply. I removed the Google Fiber box from my setup and am using the AX50 alone and all is right with the world.

View solution in original post

8 REPLIES 8

MichaelP
Platinum Product Expert
Platinum Product Expert

Hello @mfrymyer 

There really isn't a good way to use both a Google WiFi system alongside your TP-Link system. If what you have is working well for you, I would continue using it as-is.

Thanks MichaelP. I appreciate your comment. I'm just not sure that I am getting the best wifi using the TP-Link router versus the Google Wifi. I'm really trying to avoid this, but I also want to have the best experience I can.

MichaelP
Platinum Product Expert
Platinum Product Expert

Well, if you have some time this weekend, you might crack open that Google WiFi system and set it up instead of the TP-Link system (just turn off the TP-Link system and disconnect it from your internet service; you can use the same network name and password as your TP-Link system so your devices all connect automatically). Follow the recommended placement advice as much as you possibly can – put the primary as close to the center of your home as possible with the secondaries one or two rooms away from the primary (in any direction). They should all have "great" mesh test results. From there they will provide 2.4GHz and 5GHz coverage to more distant clients. Don't put a secondary where your clients are already struggling to get coverage – that won't help (and that advice applies to the extender in your TP-Link system).

Then you can see if it ends up working better than what you have now or not. I still wouldn't try to use both at the same time. 

Thanks MichaelP,

I think I'm screwed either way. My router connection to the Google Fiber ethernet access is on the second floor. That is where the router will need to be. My current TP-Link router is on the second floor with an additional access point (TP-Link AC1750 WiFi Extender (RE450)) is located on the main floor. My basement does not have an extender and it receives very poor coverage, about 50 - 90mb down and 50 - 90mb up. I don't see how I can place the access points within a couple of rooms of each other and get the coverage I need throughout my house.

MichaelP
Platinum Product Expert
Platinum Product Expert

It sounds like you may need to start thinking about running some Ethernet. One run to get the primary on a middle floor would be a big improvement, since you'd be able to put one secondary on the second floor and another in the basement. But, in a big home (or one with more dense construction materials like concrete, brick, or plaster), you might want to consider running Ethernet from the primary to the secondaries. This lets them be placed further from the primary (since they no longer rely on the 5GHz mesh interconnect). I know that may be daunting, but in a large home, WiFi alone may not be sufficient to get reliable coverage everywhere you need it. Note that if you have coaxial cabling in place, you may be able to use MoCa adapters to create an Ethernet equivalent without running new wires.

Jeff
Community Specialist
Community Specialist

Hi, mfrymyer.
I just wanted to jump in real fast to see if you saw MichaelP's last reply and to see if you still needed some help on this or if you were able to get it sorted out. If you are still needing some help, just let us know and we'll be happy to continue helping.
Thanks.

mfrymyer
Community Member

Hi Jeff, Yes I saw his reply. I removed the Google Fiber box from my setup and am using the AX50 alone and all is right with the world.

Jeff
Community Specialist
Community Specialist

Thanks for letting me know, mfrymyer! I'm happy to hear that things are working well. As we have our solution here, I'm going to go ahead and close up the thread, but if you need anything else, please feel free to open up a new thread.

Thanks!