Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Yale Lock Issues with reinstalling lock, lost all access to nest app on phone

Community Member

It all started with Yale Lock saying constantly "Offline" for well over a month and was sick of it since I needed to add a new guest user for the weekend and I really didn't want to give my master code out.

  • Re-added Nest Connect to the nest app and still was getting offline with nest lock. (10/17/2022)
  • Took out batteries from the Lock and still got "Offline" (10/17 & 10/21)
  • Disassociated Lock from my nest app (10/21)
  • Tried to add back and still was offline
  • Took apart the Lock and hit the factory reset button
  • Tried to add Yale Lock via Google Home app and got message "Must use nest app."
  • From Nest app, tried to add back and it couldn't (Lock never held a flashing green light)
  • All codes except my master code were wiped from the Lock. (Very annoying)
  • Then, my nest app stopped working completely
    • "There was a problem connecting to the Nest service. Try again in a few minutes."
      • Tried again still nothing
      • Rebooted phone (Samsung Galaxy 20+)
      • Rebooted router
      • Uninstalled app from phone
      • Reinstalled app
      • Logged in with google account sill nothing
      • Logged in with old nest account and it went to a blank home but got past the 'problem connecting to the nest service.'
      • Logged out and back in with google and again got message of the problem connecting to the Nest Service.
      • Went to Google Chrome (via computer) and and logged in with Google ID and the thermostat and cameras show on the nest, but no locks from either house are visible on the nest computer page. (Yes, we have two houses and 3 Yale locks) (10/22)
      • Today (10/23), I again did all of the above, in regard to the nest app and the phone. Including rebooting the router and again... it is not working.

Please help fix this issue. 


Community Member

This just happened to me too! The only way I can access my thermostat now is through Google Home. The Nest app just says "Loading..." forever, even if I delete it and reinstall. 


I just bought and installed the lock today and was able to make a master code from the lock itself but can't access anything via the Nest app and the lock isn't showing up in my Google Home devices. 

Community Specialist
Community Specialist

Hi there,


Sorry to hear you're experiencing this, I would love to look into this further for you. If you haven't already, you can learn here how to factory reset your Yale lock, which may help to reset issues it may be having. Please let me know if you need further assistance.


Best regards,


Community Specialist
Community Specialist

Hey folks,


I just wanted to follow up to see if you still need our help. Please let us know as we would be happy to answer any questions you may have. 

I appreciate the help, Brad.




Community Specialist
Community Specialist

Hey there,


Just checking in to make sure that you've seen our responses. Please let me know if you have other questions or concerns as I will be locking this in 24 hours if I won't hear back from you again. Feel free to start a new thread and we'll be happy to help.


Thanks for the help here, Brad and Archie.




Community Member

Thanks, fellas! I was able to problem solve with the Google customer service team over the phone.  They could see that my lock had paired with my account but it froze somewhere along the feedback loop. I reset the lock and it didn't do anything initially, other than allowed me to use the master code to get in and out. I still had a frozen Nest app. They opened a ticket with engineering that night, and magically (because we still don't know how) the next day I tried the app again, it loaded everything. I haven't had an issue since. Engineering never had to do anything and the customer service team was surprised too.