Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Can't change my device name

Community Specialist
Community Specialist

Disclaimer: This thread was migrated from our previous version of the Google Nest Community. You can continue to receive updates on your thread issue here or simply ask, browse or more in the new Google Nest Community.


Original poster: Ian Leworthy-Coleman 



I can't change my device name. It won't let me click the device name or edit it in anyway, I can move rooms and cast to it as normal, just desperate to change the name. I'm connected to the same WiFi and am the only account connected to Google home. Tried reinstalling the app, removing the device, and remaking the household. No luck. Help!
160 REPLIES 160

Community Specialist
Community Specialist

Hi Ian,
Have you tried the below steps correctly,

Make sure your mobile device or tablet is connected to the same Wi-Fi network or linked to the same account as your speaker or display.
Open the Google Home app .
Tap the device you want to edit.
At the top right corner, tap Settings Device information Device name.
Enter a new name > tap Save.


-from Arun Kumar S (Product Expert)

Community Member

I have the same issue with my Google WiFi (original not Nest), which I hadn't had before the migration to Google Home.  I have some 2.4G cameras that show up as Unnamed device and the pencil icon to edit is grayed out and doesn't let me edit.  I don't even see those devices listed in Google home.

Community Member

This doesn't work...

Check my reply below for a workaround

Community Member

Still didn't work

Uninstalling the Home app and installing an old, say 2020 version, will allow one to rename a device. Then just update tot he newest version. Worked for me easily. Links below. The home/nest app is a pretty **bleep**ty google programmed app. Billions and they can't get proper developers to fix this, the Bluetooth connectivity, and disconnects. Give me the code... Lol.


Community Member

That worked for me.

I had the same issue and the steps above didn't work on my Android phone but I had an android emulator on the PC and it allowed me to change the name with no issues.


I've tried this but it doesn't work. The name appears as changes in the device settings screen, but on the main control screen ( where you control volume, cast etc).device still shows old device name

Same issue here.  I have a hub that says Office Display in Device Information, but when I go to Edit Name, the device name is Den Display.  When looking at the Home App, the device is also named Den Display.  No matter how many times I edit the name, it always stays w/ the old name.

Community Member

same issue, had to reset the device to rename it

Community Member

Same thing happens to me. I go in and make the name change in the device settings and it sticks and saves but when in the screen before device name it still lists the old name

Community Member

This doesn't work, I moved two devices and they're stuck with the wrong room names. Even setting them up "like new" doesn't work

If it's the same problem that mine is having, it's because there is no settings gear in the top right, and so we can't access the name change function.

Community Member

I am currently trying to rename my Google nest hub, and I am going to settings, device information, clicking name, changing the name, and hitting save. And even though I am doing everything correct, the name is not changing and I have rebooted the device, and I have removed the device.

I have the same issue with both a Google home mini and a Google wifi point -- i think it's a bug in the Home app 

Community Member

Same here. I can't change device name, or any other device related information(preview program, paired bluetooth device, etc).  There are 9 devices in my system, including a Nest Home and a Nest Mini. I can change the name of each device except the Nest Mini. What I noticed is that the Nest Mini region is different from the other devices (Mini is ES region, the other devices are EU region). I think this is causing the problem. I did a factory reset on the Nest Mini, removed it from the account and relink, but it doesn't work.

Exactly the same issue. Can rename all other devices, no problem. But the Nest Home refuses to change. Tap save, go back and look... nothing.

Community Member

Same issue here. Very frustrating, but at least I know I'm not just crazy now.

I've tried all the tricks, even deleted the device, reboot, clear caches etc, nothing works. 

The behavior is rather odd though, when I edit the name field and save, then go back to edit the name, and it will have a different name in the field than what I last saved (will be one I tried to save some time ago), but also not the name displayed either. And then if I back out, then go back to settings and then the current name is in the field again, even not changing anything. It just doesn't seem actually connected to that field or something. Very odd.

Community Member

Have you tried factory reset of the device. That worked for me. Hold down the small circle underneath the Google Home Mini for about 10 seconds

Does nothing

Community Member

Have you tried telling the Google Home assistant that you want to change the name of the device? I get the message: "Sorry, something went wrong and I'm unable to control your home device". On the app screen I get "Something went wrong" and that's that. Could it be an issue related to the version of the app?

It tells me that I need to rename the device in the Google home app

Community Member


Install an old version, from 2020 and uninstall your old version first, then just install the old version and all your settings and devices are there. Rename the device and voila!

It's the new app and it had bugs. Thanks for the old version advise. Excellent idea. 


How can i get an old version of the Google Home software for Android?

Easy to google old apk, but this link is safe and good.


This right here worked swimmingly. They definitely broke something in an update. I went back to the as suggested by @pauliezapps and fixed all the things that I couldn't fix before with the names of my speakers. 

You saved me and us! ‌‌ 😃

better than Google supporter 

YES! Thank you! This is such a small but annoying issue and now it's resolved! 

2 things:

1. I would recommend downloading version (from Oct 6), the previous 2020 versions crashed when I clicked on the gear icon for my Max icon.

2. Once you change the name, you can re-install the new version and the name change sticks! 

thanks i can finally fix the name!

This worked perfectly for me.

I am glad I read this, gave me a different idea.  I can't update the name on my Android but I used the app on my iPhone and was able to update it with no issues.  To your point, something is wrong with the Android version of the app, go figure!

Thanks to your suggestion I just performed the same steps on my iPad that I've been repeatedly trying in vain on my Android phone, and it worked perfectly. Unbelievable.

Good solution unless you're in Google's Advanced Protection Program and sideloading/ADB is a no-no.

I know, I'm kind of a big deal hotshot. 💅 😜

How can I get an old version? on Gppgle play??

please save me 😞

Had the same issue when I moved a hub from Dining Room to Bedroom. Finally just did a factory reboot of the hub (hold down the two volume buttons - i.e. both ends of the bar) for 10 seconds. This will reset the device and erase it's old name. Then just reinstall it at the new location - it will rename itself in the new location. It also removes its old name from the app. 


But that doesn't work if you want to rename it anything other than "Room Display," as described dozens of times on this thread. What happens if you try to rename yours Train Viewer?

Community Member

Same here. The device name changes in the section device information but in the screen with the big circle for volume control and cast audio the name doesn't change

Same here