Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Cannot reset or run safety check on Nest Protect

Community Member

A few days ago I had a carbon monoxide alert from the protect in my garage.  The levels reduced after opening the garage doors, but all of my Protects are pulsing yellow every 5 seconds.  I have tried to run a safety check via the app, but it will not start.  I have tried to perform a reset, but after pressing and holding the button, the device starts to say its version number, but is cut-off before it can complete and instead says “silenced” and returns to the yellow pulse every 5 seconds.  This is the behavior on all of the protects in the house.  Google support was not able to resolve.  The Gen 2 protects were purchased and installed approximately 6 months ago.


Community Member

Problem solved.  I was not able to isolate a single protect, but did continue to attempt to reset different protects.  I also have a Nest mesh wifi, and sequentially reset each end point.  Apparently that forced the protects to reconnect and that resolved the issue.

Community Specialist
Community Specialist

Hi folks, 


Thanks for posting and apologies for the late response. 


@H-Man, really appreciate the help! 


@bwali, appreciate you for updating this thread with your resolution, it's a big help. We will consider this as resolved and will close the thread within 24hrs. Thanks!