Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest thermostat

Community Member
  • I have recently changed my wifi and am now unable to connect my thermostat. I’ve tried following the instructions online but get stuck on step1. When I tap the settings icon, the display just goes back to showing the current temp. 

Community Member

I am stuck on the 'Choose the last 4 characters of your device's serial number....I HAVE the serial number but there is no place to enter it?  Any one out there (or Google perhaps) have a suggestion for this issue?  Right now I have a standalone Nest TStat for my mother-in-law's house but no way to connect it to her Google Nest Hub Max. HELLLLPPPPP


Have you tried a restart by pressing the display against the wall, wait until the house shows, then release. That might help?

Community Specialist
Community Specialist

Hey folks,


Thanks for visiting the Google Nest Community. 


Since this thread hasn't had activity in a while, we're going to close it to keep content fresh.

If you have additional questions, feel free to submit another post and provide as many details as possible so that others can lend a hand. 


Hope this helps!


Kind regards,