cancel
Showing results for 
Search instead for 
Did you mean: 

Nest Heat Link - No Power

JPMNest
Community Member

Hi, My Nest Heat link has stopped working - no lights. There is 240 volts to the heat link. I assume the unit is dead.

How do I get this fixed/replaced under warranty?

Thanks,

John

1 ACCEPTED SOLUTION

Vladut
Community Specialist
Community Specialist

Hi there, thank you so much for reaching out. Can you tell me if any LED comes on after you press the button on the Heat Link for 30 seconds?

View solution in original post

38 REPLIES 38

Vladut
Community Specialist
Community Specialist

Hi there, thank you so much for reaching out. Can you tell me if any LED comes on after you press the button on the Heat Link for 30 seconds?

View solution in original post

JPMNest
Community Member

Hi there is no leds after pressing button for 30 seconds, but there is 240 volts to the heat link.

Thanks

John

Vladut
Community Specialist
Community Specialist

We'd love to investigate this further — please fill out this form so we can gather your details securely and let us know once you've done it: https://bit.ly/3h2TDJp. You can find the Serial Number in Settings > Tech Info > Display, or on the back of it. It begins with 09. Also, the email address included should be linked to your Nest Account, and for the postal address section, input a shipping address.

Kerin
Community Member

Hi,

I've filled out the form and submitted it. My Heatlink was only installed a year ago and Ive tried all the troubleshooting suggested

MarkD
Community Member

I have the same problem, heat link has power but no LED lights. I have tried all the suggest fixes.

Here are the answers to the questions.

  • How long has your thermostat been installed for? Since Feb 2020
  • Did the issue happen during the installation? No
  • Is there any error on the Nest thermostat display? H71
  • Have you had any power cuts recently? No
  • Have you had any work done on your electrical or heating systems recently? No
  • If yes, was the power properly restored at the fuse board after work was done?
  • How many zones are present in the setup? 1

Any help would be appreciated.

Buch1234
Community Member

Mine is exactly the same installed February 2020 hopefully will be covered with the warranty. Must be a common complaint ??

There is a blue light permanent flashing

But no heat

JPMNest
Community Member

Hi completed form but forgot to put in my post code S12 4NQ

Thanks 

John

AlexD
Community Specialist
Community Specialist

No worries, if you ever forget any details you can just complete the form again and let us know you did. We'll reach out to you over email as soon as possible to assist you further. 

JPMNest
Community Member

Form recompleted

John

AlexD
Community Specialist
Community Specialist

That is great. Our colleagues already reached out to you. Make sure to stay in touch with them.

andysedd
Community Member

Hi, I have exactly the same problem but can't get hold of anyone to help. How do I do so?????

CristianC
Community Specialist
Community Specialist

Hi andysedd,

I'll do my best to get this issue sorted. Can you please help me with some answers to these questions?

  • How long has your thermostat been installed for?
  • Did the issue happen during the installation?
  • Is there any error on the Nest thermostat display?
  • Have you had any power cuts recently?
  • Have you had any work done on your electrical or heating systems recently?
    • If yes, was the power properly restored at the fuse board after work was done?
  • How many zones are present in the setup?

 

Regards,
Cristian

Prisque
Community Member

I have the same problem with my Heat Link 3rd Gen. There is power to it but no LED light at all. Thermostat shows error H71.

AlexD
Community Specialist
Community Specialist

Hi @Prisque and @Antnie77 .

 

If you have not already check any breakers or switches at the location, to make sure nothing has tripped. If it all looks good you can try and cut the power to the Heat Link for a few minutes, if you are comfortable in doing so, and after turn it back on. See if it has any reaction after you power cycle it when you press the button on it. 

 

If it still has no reaction let us know here and make sure to also answer the questions my colleague posted above. 

Prisque
Community Member

Hello

I have not heard back from you. Please update on the next steps.

Antnie77
Community Member

Hi, i have exactly same issue

thx

KarlMcCann
Community Member

Same issue for me.  Been posting in the old support group / forum with no success.

Heat link has power but is non responsive.  Have power cycled on and off several times, attempted factory resets, all no joy.

 

Answers to questions below.  I need this sorted please before winter!  

I have 3 heatsinks, other 2 work fine.  The one that is non responsive controls one zone and hot water.

 

  • How long has your thermostat been installed for? Since APX Jan 2020
  • Did the issue happen during the installation? No
  • Is there any error on the Nest thermostat display?  Displays H71 error.
  • Have you had any power cuts recently? No
  • Have you had any work done on your electrical or heating systems recently? No
    • If yes, was the power properly restored at the fuse board after work was done?
  • How many zones are present in the setup? 3

Thank you,

 

Karl

AlexD
Community Specialist
Community Specialist

Hi @Buch1234 , @JenBerenguer , @janicewy , @MarkD , @Cazaroo , @KarlMcCann .

 

I am sorry to hear you are all facing difficulties in using your thermostats.

 

If you already checked breakers and switches, as well as power cycled your device make sure to fill out the form above: https://bit.ly/3oVDg4g , making sure to include all the required details. Especially make sure to include your username from here on the forum in the "Social handle" section, so we can identify your submission. 

 

Once it is filled in, let us know here and me or one of my colleagues will look it up and reach out to you over email after.

 

Regards,

AlexD

janicewy
Community Member

Hi,

I filled in the form 2 days ago, but haven’t heard anything since. 
Many thanks

Regards

Janice

AlexD
Community Specialist
Community Specialist

Thanks for letting me know @janicewy . We have to know here once it has been submitted so, me or any of my colleagues can look for it after.

 

I did manage to locate the form but it seems that the address field is incomplete, it only has a postcode in it. 

 

Make sure to fill out the form one more time and include your full address: https://bit.ly/3oVDg4g . Once you have just let us know here. 

janicewy
Community Member

Hi,

I have filled it in again.

Cheers

Janice

AlexD
Community Specialist
Community Specialist

Thanks. Me or one of my colleagues will reach out to you as soon as possible over email. Keep an eye on your inbox.

Cazaroo
Community Member
  • Hi @AlexD, I've completed the form.  Thanks, Caroline 

AlexD
Community Specialist
Community Specialist

Thanks for letting me know @Cazaroo . Me or one of my colleagues will be in touch with you shortly over email.

MarkD
Community Member

I have completed the form. Thanks.

AlexD
Community Specialist
Community Specialist

Thanks @Kerin and @MarkD

 

Me or one of my colleagues will soon reach out to you both over email.

Cazaroo
Community Member

Hi, 

I have the same problem too.

I have followed all the suggested advice above and it's still dead with no LEDs on at all.

Here are my answers to the questions:

  • How long has your thermostat been installed for? Since Jan 2020
  • Did the issue happen during the installation? No
  • Is there any error on the Nest thermostat display? H71
  • Have you had any power cuts recently? No
  • Have you had any work done on your electrical or heating systems recently? Back in June the flue was repaired
    • If yes, was the power properly restored at the fuse board after work was done? Yes and no problems until now
  • How many zones are present in the setup? 1
  •  
  • Thanks, Caroline 

janicewy
Community Member

Hi, 

I have the same problem too.

I have followed all the suggested advice above and it's still dead with no LEDs on at all. I have asked a boiler engineer to come and look at it and he suggested it's the Nest Heat Link + Thermostat that's faulty as there are voltage 

Here are my answers to the questions:

  • How long has your thermostat been installed for? Since Sep 2019
  • Did the issue happen during the installation? No
  • Is there any error on the Nest thermostat display? H72
  • Have you had any power cuts recently? No
  • Have you had any work done on your electrical or heating systems recently? No
    • If yes, was the power properly restored at the fuse board after work was done? 
  • How many zones are present in the setup? 1

Thank you very much!

Janice

JenBerenguer
Community Member

Hi,

I have the same problem too.

I have followed all the suggested advice above and in the troubleshooting guides ( have hold the button 10, 20, 30 seconds) and it's still dead with no LEDs on at all. My heat link is 2nd gen.

My answers to the questions:

How long has your thermostat been installed for? >Since July 2020
Did the issue happen during the installation?- No
Is there any error on the Nest thermostat display? -H71
Have you had any power cuts recently?- No
Have you had any work done on your electrical or heating systems recently? -No
If yes, was the power properly restored at the fuse board after work was done?-N/A
How many zones are present in the setup?- I'm not sure what this means, but I'll guess 1.

If you have not already check any breakers or switches at the location, to make sure nothing has tripped. -Confirmed

If it all looks good you can try and cut the power to the Heat Link for a few minutes, if you are comfortable in doing so, and after turn it back on. -Done it a few times already.

See if it has any reaction after you power cycle it when you press the button on it. -No reaction

Thanks

Jen

 

Since our boiler is less than 2 years old we called our installer them and they came and exchanged it..I did say there seemed to be a lot that had gone faulty and he said there had been a bad batch from 2 years ago and they were just starting to go wrong....Not sure how true that is but it does seem to match up with comments I've seen were installed about 2 years ago...Is this something Google knows but is keeping quiet about!

@AlexD I also filled out the form yesterday (without the social handle, I'm afraid), but put my email and address - hope that's enough to get help from your end. 

Thanks a mil in advance!

AlexD
Community Specialist
Community Specialist

Thanks for letting me know @JenBerenguer. In that case please fill it out one more time with the same details, just add your username to the "Social handle" section this time: https://bit.ly/3oVDg4g . Once you filled it out again, just let us know here and me or my colleagues will look for it.

done, @AlexD  Thanks 🙂

AlexD
Community Specialist
Community Specialist

Awesome @JenBerenguer . Me or one of my colleagues will reach out to you soon. Keep an eye on your inbox.

Ashleighgroves5
Community Member

Hello

I am having the same problems as above and really need this working I have two small children and desperately need hot water!!  I have completed the form and the questions as above!  

My answers to the questions:

How long has your thermostat been installed for? >Since August 2019
Did the issue happen during the installation?- No
Is there any error on the Nest thermostat display? -H72 heat link 
Have you had any power cuts recently?- No
Have you had any work done on your electrical or heating systems recently? -No
If yes, was the power properly restored at the fuse board after work was done?-N/A
How many zones are present in the setup?- 1.

If you have not already check any breakers or switches at the location, to make sure nothing has tripped. -Confirmed

If it all looks good you can try and cut the power to the Heat Link for a few minutes, if you are comfortable in doing so, and after turn it back on. -Done it a few times already.

See if it has any reaction after you power cycle it when you press the button on it. -No reaction

Thanks

Ashleigh

Ashleighgroves5
Community Member

Did anyone get a replacement or did nest fix it for you?  Any advice appreciated thanks