Showing results for 
Search instead for 
Did you mean: 
Replies are disabled for this topic. Start a new one or visit our Help Center.

Nest App on Iphone Will Not Login with Google; Loops Back to Login Nearly Immediately

Community Member

This problem has been mentioned in multiple closed/non-resolved threads:
(last thread still open, but not located in 'apps' forum)

First occurred ON MY DEVICE 20 August 0734 Central time; no software or settings were changed by me on my device any time within 4 days prior to that.

To reproduce this behavior:

1. Open the Nest App on Iphone; Screen reads "Welcome Home" with a button to "Sign in With Google"
2. Click "Sign in With Google"
3. System prompt asks if I'd like to allow Nest to connect to Google for the sign in; Select yes/confirm
4. When the account screen is shown, select my gmail account and click Next
5. When the permissions screen is shown, click "Allow"
6. The in-app browser closes and the Nest App main display shows the house with blue circling around it for a few seconds. I might get about 1s glimpse of my home devices/camera view. There is not enough time to click anything.
7. The screen immediately transitions back to what was shown in step 1 above ("Welcome Home")

  • Based on the above, successful login and use of the Nest App for my account on iDevices is not possible

Device configuration:
iPhone 14 Pro
iOS 16.6
Latest Nest app (per the App Store, updated yesterday; before that it was multiple weeks since the last update)

Connected Nest Devices:

Gen 1 Nest Outdoor Camera
Nest Thermostat; unsure of version, but older
2 Nest Protects

  • This happens on my own wifi (Spectrum, strong consistent wifi signal), Verizon LTE, and Verizon 5G
  • All of my devices have the latest iOS for their hardware
  • Same steps are reproducible on my iPad device, same account; login loops behaves exactly the same.
  • I can successfully login to home.nest from iPhone Safari browser; however, when I click to view the camera it gives a warning that the browser is not supported, despite Google's documentation saying that it is.
    • In addition, logging in via browser does not allow immediate notifications via iPhone for either the cameras or my Nest Protects.
  • I can successfully login to home.nest from Mac laptop Safari Browser and can view camera feed there
    • Does not allow immediate alerts to iPhone from Protects or Camera
  • I can successfully login to home.nest from Windows Laptop (Dell Latitude 5440, Windows 10 Enterprise 22H2 19045.3324, Firefox 102.12.0esr (64-bit) both without proxy and with it.
    • Does not allow immediate alerts to iPhone from Protects or Camera

The following troubleshooting steps have been done and have not resolved the problem:

  • Uninstall the Nest app, and then reinstall the Nest app and attempt to login.
  • Change the Date/Time "set automatically" to off, then back on.
  • Turn off iPhone, wait 6 minutes, turn iPhone back on
  • Log in to my Google Account Settings, remove permissions granted to Nest entirely. Log in via browser to re-grant permissions. Attempt app login; fails.
  • Multiple combinations of the above, e.g.:
    • Uninstall Nest App, toggle "set automatically" in Date/Time to 'off', remove Nest permissions from account, then turn iPhone off for 10 minutes, turn iPhone back on, toggle "set automatically" in Date/Time to 'on', repeat step 4.
  • Unplug/turn off all Nest Devices. Plug them all back in.
  • Reboot modem (Spectrum/cable)/router and reconnect to home wifi
  • Set iPhone to have static IP address
  • Change DNS servers from Spectrum default to Google (,
  • Ran Speed Test/test for packet loss (150 Mbps, no loss)
  • Attempted all of the above at different times of day, from both iPhone and iPad
  • Viewed analytics logs to look for any reference to Nest/Jasper/Google (none found)
  • Connected iPhone to Mac, loaded console, viewed logging real-time during attempt to login to app; multiple errors/warnings were noted, but I have no clue which were significant. Among them:
    • default 00:21:32.205918-0500 locationd {"msg":"computing freshAuthorizationContext", "ClientKey":"com.nestlabs.jasper.release", "BigSwitch":1, "InUseLevel":{"type":"decode failure","raw value":4,"expected type":"Generic"}}
    • default 00:21:32.204344-0500 mediaserverd -CMSessionMgr- CMSessionMgrHandleApplicationStateChange: Client com.nestlabs.jasper.release with pid '2566' is not allowed to play in the background AND does not continue AirPlaying video when device lock
    • There's another error that has to do with a code variable type being set in some legacy way that apparently won't be valid in future software (it was associated with Jasper) but I didn't save that unfortunately and I'm not at my home laptop right now.
  • Created a new Nest account with a second person Gmail address; account creation was successful (0 devices connected), and I could log in and interact with the app without immediately being kicked back to login screen. After this I logged out of that secondary account, and attempted to login to my primary one again. Login attempt failed.
  • I am sure I tried other things that I've forgot to mention, but I'm open to suggestions.

‼️Of note, it is not possible to set app Location services to 'always on' or precise without first successfully logging into the app; because of this, on each new install after attempting again to uninstall/reboot/reinstall, if you visit the App properties in the Settings menu, "Location" is not mentioned at all. It is not possible to enable Location options via the web browser settings.


On 21 August I contacted 'madebygoogle' via Instagram messages and discussed the above with them. They ended up referring me to a form to submit along with case number (40705555). I have heard nothing from them since then.









Right my devices are bricked in terms of getting real-time alerts because of this error, and Google Home is not a sufficient stand-in for use of the Nest Protect (I really don't care if you aren't supporting that hardware; it's part of your ecosystem, and you are supporting the Nest App still which is broken) nor is it capable of viewing camera history or real-time alerts on camera detections for my camera hardware.

If anyone would like to suggest further applicable troubleshooting steps please do. If anyone has a direct line to someone Google-side who will pay attention to this, that would be appreciated. If anyone else is experiencing these issues please comment or tag yourself; I'll cross post this topic in the thread located in 'cameras and doorbells'.



Community Member

Forgot I also tried:

  1. Clearing all Safari website cookies and data (+ reinstall, reboot, etc)
  2. Logging out of all gmail accounts on my device(s) (+ reinstall, reboot, etc)

(additions 24 Aug)

3. As of 23 Aug Nest released a new app version, 5.72. This version does not fix my problem. 

4. Tried disabling 'cross site tracking' in Safari (along with reinstall, reboot, all that jazz) at the suggestion of @EmptyNester ; no dice. (ref this thread:

5. I finally, at the suggestion of @MplsCustomer ( contacted support via chat, under the header of 'Nest Aware' (as I currently cannot use my subscription to Nest Aware on my primary device, when their app is broken). After a lengthy chat (I can provide the transcript if anyone is interested) I was told that the engineers are working on it, currently no estimated fix time, but I was given a case number (different from the one given by 'madebygoogle' Instagram account, which - this chat tech could not even locate so yay) and an avenue to continue to request status on case resolution. So... thank you @MplsCustomer , for your suggestion. Here's hoping a fix appears, or even at least an acknowledgement of the known bug. 

Other noted errors and faults in the Console logging when attempting to log in to app on iPhone:

  1. Couldn't read values in CFPrefsPlistSource<0x2826fbc80> (Domain:, User: kCFPreferencesAnyUser, ByHost: Yes, Container: (null), Contents Need Refresh: Yes): Using kCFPreferencesAnyUser with a container is only allowed for System Containers, detaching from cfprefs
  2. fault: One or more models in this application are using transformable properties with transformer names that are either unset, or set to NSKeyedUnarchiveFromDataTransformerName. Please switch to using "NSSecureUnarchiveFromData" or a subclass of NSSecureUnarchiveFromDataTransformer instead. At some point, Core Data will default to using "NSSecureUnarchiveFromData" when nil is specified, and transformable properties containing classes that do not support NSSecureCoding will become unreadable.
  3. *** -[NSKeyedUnarchiver validateAllowedClass:forKey:] allowed unarchiving safe plist type ''NSNumber' (0x1f0e975c8) [/System/Library/Frameworks/Foundation.framework]' for key 'NS.keys', even though it was not explicitly included in the client allowed classes set: '{(

        "'NSMutableDictionary' (0x1f0e8fcb0) [/System/Library/Frameworks/CoreFoundation.framework]",

        "'NSMutableOrderedSet' (0x1f0e8f580) [/System/Library/Frameworks/CoreFoundation.framework]",

        "'GDTCOREvent' (0x10221cc38) [/private/var/containers/Bundle/Application/15007936-C85E-4B6B-803A-335D2D31A40B/]"

    )}'. This will be disallowed in the future.

  4.  nw_path_necp_check_for_updates Failed to copy updated result (22)
  5. quic_crypto_session_state_serialize [C4.1.1.1:2] [-f43fec617a3f1182] TLS ticket does not fit (6925 > 6144)

  6. Error fetching client root key: Error Domain=io.grpc Code=5 UserInfo={io.grpc.HeadersKey=<private>, io.grpc.TrailersKey=<private>, NSDebugDescription=<private>, NSLocalizedDescription=<private>}, requestID: <private>

Honestly I'm not a Mac gal, and I just used Console for the first time to investigate this. But it logged 3100 errors and faults for Jasper (alt name for Nest in the package code I guess) within this few seconds window in which I tried to login. The list I supplied is a subset. Maybe it'll mean something to someone. 

Platinum Product Expert
Platinum Product Expert

Try these steps:

Open Settings > Safari > Turn off the setting “Prevent Cross-Site Tracking”,

Thanks for the suggestion David. I did that, and then cleared website data and cookies, rebooted. Still cannot successfully log in Nest app. 

Community Member

(copied from:


Aight y'all that still have this issue. I'm proposing a  course of action that may or may not help you. I can say it has at least helped me for right now, though I'm not sure how optimistic I'm going to remain that I can still successfully log in later on.


How feasible this is depends on who you have around you, sadly.

  1. Locate someone who does not have the nest app installed on their device at all right now, and preferably, never has.
  2. Ask if they will install the app and let you attempt to log in. Verify it's the latest app version (5.72 right now). In my case, I own a iPhone 14 Pro, but my coworker let me use her phone to try this and she has an iPhone 12 Pro Max
  3. Open the app, go through all the 'log in with google' steps
  4. Now - here's where we hope the results start to look different. In my case, on HER phone, the app logged me in and let me stay logged in. I could interact with my gen 1 camera and both Nest Protects.
  5. WHILE STILL LOGGED IN HER PHONE: pick up my own phone, and open nest app, step through 'log in with google' steps
  6. Here's hurdle 2; in this case, while still logged in her phone's app, I was able to stay logged in the app on my own phone with the caveat that I was first spammed with a stupid "nest renew" ad.
  7. Keeping in mind I can't verify this again because I can't have my cell at work (closed lab), I was able to close the app on her phone and still be logged in on my own at that time. Now, whether this is going to 'stick' when I try to view the app later, I do not know, but I figured it was worth at least sharing.


I have a couple hypotheses related to this:

  • First, is it possible the Nest Renew ad spam is interrupting the authentication process?
  • Second, their app devs are not successfully clearing some existing cache or cookies on the device where the app is updated/existing/ever existed and this is interrupting or causing the authentication process to fail

Just hypotheses. I hope maybe this might help someone? I know it's not really feasible for a lot of people to just randomly locate someone else who will install the app and let them try to log in, but if you can, let me know if it works for you?